Previous 1 2 Next 29 Replies Latest reply: May 4, 2015 12:41 PM by christophe v. Go to original post
  • Joseph Heinen Level 1 Level 1 (0 points)

    JK et al. -

    I can offer one solution after this discovery :

    I upgraded both my iMac and MacBook Air (MBA) to Mavericks and then experienced similar problem -- the shared file access and shared printer capabilities disappeared.  I spent hours trying changes to sharing preferences, AFP protocol, pinging network addresses, restarting, etc.  Discovered that it was a problem with my iMac name.  The iMac name had an apostrophe (Joe's iMac).  Somehow, after changing to Mavericks, the machine could not be discovered.  Changed the iMac name (Joe iMac) and now the MBA shows it in Finder and the shared folders and printer have returned. 

    Good luck.

  • mazg4182 Level 1 Level 1 (0 points)

    Hi Joseph,

    You have solved my problem. I've been having the exact same problem with an iMac and MBA for the past month. Removing the apostrophe worked for me too.

     

    Marina

  • Tracy McCarthy Level 1 Level 1 (0 points)

    I am tearing out my hair due to lost productivity with this issue. Oddly, of the four Macs in my workgroup, three use an apostrophe in the computer name (and CAN share) while the fourth does not use an apostrophe and is not acccessible through conventional means.

     

    Before the upgrade to Mavericks, we had no problems accessing each other as registered users. Now, my MacPro (mid-2010, on 10.9) can connect to iMac-1 (mid-2011, on 10.9), and iMac-2 (mid-2011, on 10.6.8), but it cannot connect to iMac-3 (mid-2011, on 10.9), nor can iMac-3 connect to my MacPro.

     

    If I use 'Go to Server' and connect manually to iMac-3 by IP, it shows up in my Finder as 'imac-32-ac60', not 'Crystals Computer', and likewise when iMac-3 tries to manually connect, my computer shows up in her Finder as 'macpro-aa2-faf'.

     

    And this connection doesn't persist. I haven't noticed exactly when the connection is lost, but it doesn't stick around for very long.

     

    I'm fuzzy on terminology but we four are the mac-group in an office of PCs using Windows server 2003. We've always accesseed a folder on the server called Shared Files where we put docs for the office to use. Right now, iMacs-1 and -2, and my MacPro can all accesses files in Shared. Imac-3 can go to the folder but when she tries to open a file it says 'The application can't be found.'

     

    I have deselected the 'share using SMB' in the Options of the Sharing pane (as did iMac-3) but I notice that in the main Sharing window it says 'Other users can access shared folders on this computer, and administrators all volumes, at afp://... or smb://...'

     

    I would think deselecting 'share using SMB' in Options would remove that access.

     

    At any rate, I would deeply appreciate any ideas about how to troubleshoot this.

  • dharward Level 1 Level 1 (0 points)

    For me the issue was that after upgrading to Mavericks there was not any share name at all on my MBP but there was one on my Mac Mini so my MBP was not able to access the files on the Mini. I just had to open the shareing settings under system preferences and set the share name.

  • Kosmodzik Level 1 Level 1 (0 points)

    Hi everyone,

    I tried pretty much everything you mentioned throughout this discussion and becasue nothing worked, I figrued I'd give it a try to just add a new user in the sharing screen. Seems to have resolved all the problems. Try it yourself.

    Regards,

    Chris

  • stellarbill Level 1 Level 1 (0 points)

    Everyone may have figured this out but I was having the same issue with two Mac Minis inside the office, 7 others were fine after the upgrade. I did figure out that just changing your computer name seems to fix the issue, at least it did for the two problematic machines here. Removing the apostrophe should work because it ultimately changes the name. Goto System Preferences -> Sharing -> Change Computer Name. Hope this helps someone! :-)

  • logusgraphics Level 1 Level 1 (0 points)

    Had the same issue. This solved the problem. Thanks.

  • Jim Kahnweiler Level 1 Level 1 (5 points)

    I have a similar setup: three macs on a wired/wi-fi home network. I installed two of them and neither would connect via file sharing. Turning off SMB allowed both to connect. Oh, and I did call AppleCare and was routed to a senior technician, who couldn't solve the problem. I was sent recording software and sent reports back for engineering to evaluate. My guess is that the Macs should connect via SMB or AFP, as the default setting is for both to be checked. I guess it could be a problem in a mixed platform environment.

     

    I suppose I should care, but I'm glad I have my network back.

     

    Thanks to all.

     

    Jim

  • cesarpetricevic Level 1 Level 1 (0 points)

    I have this problem too,

     

    My problem was that in users and groups, my guest user you have to check allow the users connect to sharing carpets,   this solve my problem   hope solve yours!

  • Jasgrek Level 1 Level 1 (0 points)

    Thank you so much for posting this-- worked for me, too after checking credentials three times and all settings.  Very strange that Apple has not fixed this bug where default sharing settings when turned on are not correct for upgraded Maverick-to-Maverick sharing!  Hope that will change soon.

  • SJBarlow Level 1 Level 1 (0 points)

    Finally! None of the other suggestions worked for me. This did the trick though.

    To reiterate:

     

    Once you've got your settings done in System Preferences > Sharing...

    1. Open System Preferences > Users & Groups

    2. Select Guest User (you might have to unlock in the lower left corner first)

    3. Click the checkbox for Allow guests to connect to shared folders

     

    It seems to me that this should be in the Sharing options since it's specifically about sharing and nothing you do in the Sharing options will work unless you enable it.

  • OzziesMAC Level 2 Level 2 (150 points)

    I am having the same issue with Yosemite, My shared Mac Mini pops up on the left pane in finder under shared but connection fails.

    SMB is not checked.

  • frozen999 Level 1 Level 1 (0 points)

    You need SMB checked for Windows7 to allow you to login. However that being said I still am having problems even after following the suggestions here http://blog.kowalczyk.info/article/ffn/Accessing-Mac-file-shares-from-Windows-7. html even after doing those changes in Windows7 Pro I am still unable to login. Note If you are using WIndows7 Home there is no security policy or group policy editor available. The strange thing is I had no problem connecting to the Mac from my WIndows7 Home x64 machine. The problem is with Windows7 Pro x64. It is refusing the login credentials, the same ones that Win7 Home used.

  • Sheel B. Wright Level 1 Level 1 (0 points)

    SJBarlow wrote:

     

    Finally! None of the other suggestions worked for me. This did the trick though.

    To reiterate:

     

    Once you've got your settings done in System Preferences > Sharing...

    1. Open System Preferences > Users & Groups

    2. Select Guest User (you might have to unlock in the lower left corner first)

    3. Click the checkbox for Allow guests to connect to shared folders

     

    It seems to me that this should be in the Sharing options since it's specifically about sharing and nothing you do in the Sharing options will work unless you enable it.

    Yes, this has been bugging me for quite a while.  Thank you SJBarlow.  Totally agree.

  • christophe v. Level 1 Level 1 (50 points)

    issue solved thanks. VERY weird issue and still present under Yosemite with two macs having done a complete clean install...

    Screen Shot 2015-05-04 at 21.37.37.png

Previous 1 2 Next