Previous 1 2 3 Next 106 Replies Latest reply: Dec 18, 2014 6:06 PM by jcv
AppleDane Level 1 (0 points)

I did the standard updates tonight - which included a remote desktop update (to version 3.7 I think) - the ARDagent.app in the System -> LIbrary -> CoreServices -> Remote management folder.

 

After the update (I'm still running Mountain Lion) - screen sharing doesn't work with any of my other Macs in the house.  It basically sits there and never connects - saying "connecting to...." - similiar to what it did a long time ago after the 3.6 updates from 3.5.  Eventually it gives this error... "connection failed to ..."  and "Please make sure that Screen Sharing (in the Sharing section of System Preferences) is enabled on the computer to which you are attempting to connect. Also make sure your network connection is working properly."

 

I have already tried to restore that folder from time machine to version 3.6.2, as well as restored the screensharing.app file to the older version, but to no avail.  Have already rebooted all the machines, restarted my airport, network hubs, etc.  Tried stopping and restarting sharing already as well.  No go on any option.  Was working just fine before the updates tonight.

 

Any one else have similar issues and know how to fix?

 

Thanks.


OS X Mountain Lion (10.8.5), Screen sharing not connecting
  • ic70 Level 1 (0 points)

    Screen Sharing broke for me too. On 10.8.5 and 10.7.5 computers.

  • ic70 Level 1 (0 points)

    It appears the firewall has something to do with it.

    When I turn off the Firewall completely, screen sharing works.

    When I manually enable everything in the firewall list, screen sharing fails.

    Is there a hidden app that is not on the firewall list? How can that be?

  • IDHH Level 1 (0 points)

    Same her fro me ic70. Trun firewall off then all is good. Turn firewall on, even with all connections allowed, and Remote desltop allowed in the options then screen sharing fails

  • merced317 Level 1 (0 points)

    This only appears to be happening for me on my 10.8.5 (12F45) machine with ARD Version 3.7.  My 10.7.5 (11G63) machine with ARD version 3.7 still works.  I can only connect to the 10.8.5 machine with the firewall disabled.  This sounds like it's a bug that Apple needs to address.

  • AppleDane Level 1 (0 points)

    Yep - same behavior with the firewall.  When I turn off the firewall on the destination machine (the one I want to control remotely), but leave the firewall on the machine I'm using - I can connect to the destination machine.

     

    I can't remember how to submit a bug request to Apple.  Can someone give me the link to follow?  Thanks.

  • Bill Totman Level 1 (0 points)

    Ditto.

     

    Two Macs upgraded to Mavericks and Screen Sharing only works if the firewall is turned off on the target machine.

     

    This is even with 'Sharing' settings properly set.

  • fzznk Level 1 (0 points)

    Same for me too, hopefully there will be a fix for this soon

  • Bill Totman Level 1 (0 points)

    I've been in contact with Apple Support and they are looking into it.

     

    (I did it via a chat session - I also have Apple Care on this machine.)

  • XFox Level 1 (90 points)

    AppleDane wrote:

     

    I can't remember how to submit a bug request to Apple.  Can someone give me the link to follow?  Thanks.

    Same problem here on a 10.7.5 machine.

    Apple Bug Reporter is here: https://bugreporter.apple.com/

  • Still_here Level 1 (0 points)

    Screen sharing not working on Mac Mini server and iMac after installing Mavericks on both.  As I don´t have a separate screen for the Mini, life suddenly became complicated.  Any ideas or solutions for turning off the firewall on the Mini without logging in (I can access the drive)?

  • merced317 Level 1 (0 points)

    If you can still SSH in to the machine, you should be able to do:

     

    sudo /usr/libexec/ApplicationFirewall/socketfilterfw --getglobalstate

     

    That should return:

     

    Firewall is enabled. (State = 1)

     

    Then you can run:

     

    sudo /usr/libexec/ApplicationFirewall/socketfilterfw --setglobalstate off

     

    That should return:

     

    Firewall is disabled. (State = 0)

     

    Now go ahead and connect with ARD.  When you're done connecting with ARD, simply re-enable the firewall with:

     

    sudo /usr/libexec/ApplicationFirewall/socketfilterfw --setglobalstate on

     

    Since the connection is already established, you can safely enable the firewall once you've connected with ARD, you don't have to wait until you're done using ARD.  Not the most elegant solution, but at least it's a short term workaround.  If you're fast enough, you've only got to disable your firewall for a few seconds.

     

    Hope that helps.

  • Mad9000 Level 1 (0 points)

    I had the same problem.  I'm running Lion 10.7.5 on the target Mac mini and Mountain Lion 10.8.5 on two other Mac's which were trying to connect to Screen Sharing on the mini. I received the error message as you described. Interestingly, File Sharing worked fine. Only Screen Sharing was broken.

     

    This is what worked for me:

     

    1. Go to System Preferences > Sharing and uncheck Screen Sharing and File Sharing

     

    2. Restart Mac

     

    3. System Preferences > Sharing and recheck Screen Sharing and File Sharing

     

    4. Problem solved (for me anyway)

     

    I hope that works for you.

  • Eric Root Level 9 (50,105 points)

    Send Apple feedback. They won't answer, but at least will know there is a problem. If enough people send feedback, it may get the problem solved sooner.


    Feedback

  • Nan Yar Level 1 (0 points)

    Same here too. Tried some workarounds, but they only work until next reboot :-(

Previous 1 2 3 Next