Previous 1 2 3 4 5 Next 106 Replies Latest reply: Dec 18, 2014 6:06 PM by jcv Go to original post
  • jesse2014 Level 1 (10 points)

    I have noticed this with the clients I have running 10.8.5 (12F45).  I can set the firewall to Allow screensharingd, but it will revert to Blocked again after I reboot the client computer. 

  • medavies Level 1 (0 points)

    I'm seeing the same behavior with 10.7.5 as well and allowing screensharingd didn't seem to make any difference at least temporarily until it's reverted by a reboot. The one 10.9 client I have no longer has Screen Sharing listed but has screensharingd set to Allow however I'm unable to connect to the machine.

  • mattiasvdm Level 1 (5 points)

    I moved everything from "/System/Library/CoreServices/RemoteManagement/" to the trash. Then downloaded the Remote Desktop Client 3.6.2 from the Apple website and installed it. Rebooted the MacBook and everything works like a charm... Just a workaround.

  • bigkatch Level 1 (0 points)

    Just tryed this 3.6.2 workaround on 10.8.5 and it did not work for me.

  • bigkatch Level 1 (0 points)

    same results for me

  • mattiasvdm Level 1 (5 points)

    Strange... I'm also on 10.8.5. I had to reboot before it worked.

    I also removed the screensharingd entry from the firewall first and when that didn't work I downgraded the client to 3.6.2. Maybe it's the combination of those two.

  • bigkatch Level 1 (0 points)

    That worked! Thanks much

  • Olaf Barthel Level 1 (0 points)


    jesse2014 wrote:

     

    I have noticed this with the clients I have running 10.8.5 (12F45).  I can set the firewall to Allow screensharingd, but it will revert to Blocked again after I reboot the client computer. 

    I was lucky: the settings did not revert to "Block incoming connections" after a reboot. Both my Mac Mini (10.8.5) and my Macbook Pro (10.9) will leave the "screensharingd" entry set to "Allow incoming connections".

  • enigmakv Level 1 (0 points)

    Same problems for me, folks!

     

    In prepping my 2012 Mini (10.8.5) and 2012 Air (10.8.5) for a Mavericks upgrade, I went to the App Store and selected "Update All" on the pending software updates and remember seeing "ARD" in the small text.

     

    I went ahead and upgraded the Air to Mavericks.

     

    Now, I cannot screen share between the two computers EITHER WAY!

     

    Also, I use iTeleport on my iPad to access the two computers and it does not work either.

     

    Per the tips in this post, I checked on the firewall settings and found the "screensharingd" to be blocked.

    I set it to "Allow incoming connections" and still cannot screen share by any means.

    I rebooted, and "screensharingd" is once again blocked.

     

    These ARD updates are becoming a big pain!

  • enigmakv Level 1 (0 points)

    So here's what I've tried.

     

    Not sure if I should have, but I went to the ARD 3.7 download page, downloaded 3.7 installer package and ran the installer.  Rebooted. Still no screen sharing.

     

    Then I went to System Preferences, removed screensharingd from the firewall, unchecked "Screen Sharing" in the sharing preference.

     

    After a reboot, I re-enabled the "Screen Sharing" preference, immediatily got a firewall notice to either allow or block screensharingd.  I selected "Allow" and went to firewall preferences to verify that it was indeed allowed.

     

    Tried accessing screen sharing via iTeleport on iPad... SUCCESS!!!

     

    Rebooted computer and screensharingd is once again blocked in the firewall. 

  • SIUE Tech Level 1 (0 points)

    So I found at least a tempory fix to this. If you have another mac with ARD client 3.6.2 on it go to /System/Library/CoreServices/ and copy the entire RemoteManagement folder and replace this on the system with 3.7. I have tried this a few times from 10.7.5 to a 10.9 system with sucess. Rebooting multiple times and it still works. ARD reports the 10.9 system with client 3.6.2 installed with firewall enabled.

  • msehelp Level 1 (0 points)

    Here is my solution and experience.

    I have upgraded several 10.8.5 computers and there was no issue for Remote Management. The latest upgrade was slightly different. When I went to the App Store, which listed Maverick and other updates; I choose the other updates to install first. This list included Remote Desktop Client 3.7 as well. Later, after reboot, I installed Maverick and my Remote connection to this computer was broken. On all the other computers, I did Maverick first, and later the other available packages. Those computers never had issues.

    My solution to the problem is: I went to the App Store and I downloaded Maverick again, manually. I ran the upgrade install newly, (without having any outstanding other update packages) and the Remote Management started working again. Not the fastest solution, but it worked.

  • nummernegen Level 1 (0 points)

    As mentioned above... downgrading to ARD Client 3.5.4 and probably 3.6.2 on the 10.8.5 Server solved the whole issue.

    http://support.apple.com/kb/DL1693

    awaiting the Apple engineers...

     

    h

  • Steve Maser Level 1 (10 points)

    SIUE Tech's suggestion seemed to work, but in order to do so I also had to remove the blocked screensharingd line from the FireWall GUI.

     

    Just replacing the RemoteManagement folder -- either 3.6.2 or from a clean-install Mavericks 3.7 (meaning a *non-ARD-upgraded folder) and rebooting didn't fully solve the problem.

     

    And once I rebooted, then I had to remove and readd the client to ARD Admin.

     

    A pain, but that suggestion seems to be the way to go (if you can get your hands on a non-upgraded folder, that is...)

  • PeeDee768947385 Level 1 (10 points)

    Downgrading my client to 3.6.2 solved the issue. Only a half day down the tube. Why Apple continues to break fundamental functionality in order to force through cosmetic changes like desktop patterns and the dock is beyond me.

Previous 1 2 3 4 5 Next