Previous 1 2 3 4 5 6 Next 106 Replies Latest reply: Dec 18, 2014 6:06 PM by jcv Go to original post
  • dandeliondigital Level 1 Level 1 (30 points)

    Hi PeeDee768947385,

    When I tried to "downgrade" my 3.7 clients (running X.7.5) to 3.6.2, I get a warning that that is not possible because a later version (3.7) is already installed.

     

    So could you run the procedure by us for removing the 3.7 client software, please?

     

    Also, will 10.9 run with the 3.6.2 client? I also have one computer running 10.9.

     

    Thanks, and so long for now, TOM

  • quniverse Level 1 Level 1 (0 points)

    My first submission... For those still on Lion.

     

    Right click on the screenshingd from the firewall prefs and show in finder, navigate up to the Remote Management folder, move to trash (restart may be required if it doesn't let you.)

     

    Restart.

     

    Re-install the old client (3.5.4).

     

    Turn off screen sharing, file sharing and/or remote login in sharing.

     

    Restart again.

     

    Turn on the screen sharing again - notice no silly allow/deny option like before. Restart - and it seems to hold for me.

     

    Forgive me if I added too many restarts but better to be on the safe side and hope I haven't repeated what's all been said before.

     

    Sean

  • garVart Level 1 Level 1 (0 points)

    Thanks for this info, completely solved my problem!

  • Larry Nolan Level 2 Level 2 (175 points)

    Trashing the Macintosh HD/System/Library/CoreServices/RemoteManagement folder and replacing it with one with the 3.6.2 version of ARDAgent instead of the 3.7 version, then Allowing incoming connections in the Firewall Options for screensharingd. 

     

    After restarting, screen sharing on my 10.8.5 iMac system works again when I access from my iPad2 using Desktop app.

  • PeeDee768947385 Level 1 Level 1 (10 points)

    "Downgrading my client to 3.6.2 solved the issue."

     

    Sorry dandeliondigitalI wasn't more explicit, but was following a range of suggestions earlier in this thread though I read so many on this problem I lost track. I'm running a headless mac mini server, OSX 10.8.5 on both the client iMac and the server.

     

    First, I had to hook up a screen and keyboard to the mini. I then verified that it was the firewall bug discussed in this forum by screen sharing with the server firewall off. I then turned screen sharing off in preferences, and removed the "screenshared(?)" line entirely from the firewall using the minus button.

     

    Then, on the server I moved the contents of the folder "/System/Library/CoreServices/RemoteManagement/" to the trash. I then searched up and downloaded the 3.6.2 version of this file: "RemoteDesktopClient.dmg". Running the install pkg inside that file reinstalled the earlier version.

     

    Finally, I turned "Remote Management" on in the preferences pane (but I think "Screen Sharing" would do) and "Enable screen sharing" in the Server Settings pane.

     

    Restarted the firewall in Preferences Security.

     

    I probably restarted the server after each of these steps.

     

    Still working for me today. Good luck.

  • spinner2012 Level 1 Level 1 (0 points)

    I downgraded to 3.6.2, which restored my ability to Screen Share.  However, the keyboard doesn't work.  I can drive the cursor on my trackpad, but when I try to type, it's non-responsive.  Is anyone else running into this issue?

  • dandeliondigital Level 1 Level 1 (30 points)

    Hi PeeDee,

    I tried your suggestion, and  have solved it on my Lion X.7.5 iMac, All I had to do was to remove "screenshared" line from the firewall, and then remove the 3.7 version of ARD Client found in  "System/Library/Core Services/RemoteManagement", and replace it with the install from the .dmg 3.6.2 version. After restarting, that Mac was available in my ARD v3.7 app again. Excellent!

     

    I have 3 other installs of the 3.7 Client, one on the X.9 Mavericks. Not sure if I want to do that one or not. I think I will wait for the update from Apple for Mavericks.

     

    Thanks to this thread, at least I got back to where I once belonged.

     

    Thanks, and so long for now, TOM


  • dandeliondigital Level 1 Level 1 (30 points)

    Hi,

    Well, I spoke too soon. Here's clarification.

     

    If I run ARD on my old computer that wasn't updated to Client v3.7, the ARD v3.4 app allows me to screen share with the iMac I "downgraded to Clinet 3.6.2," but if I try to run ARD v3.7 on that iMac with the Downgraded to v3.6.2 client, I receive the following dialog when I launch ARD v3.7 app.

    -----

    The Remote Desktop client software on this computer does not match the administrator software version.

     

    The Remote Desktop administrator software requires a newer version of the client software. Click “Check for Updates” to search for updated software.

    -------

    I can't wait for a fix to this, but at least I can see the "important to me" client I needed to see.

     

    For now, I will simply live with a broken situation.

     

    So long for now, TOM

  • kyu32 Level 1 Level 1 (0 points)

    Worked for me thanks!

  • yakuba Level 1 Level 1 (0 points)

    Worked for me to.  Thanks. 

     

    I'd been doing another thread's recommendation which basically involved trashing the following two files:


              /Library/Preferences/com.apple.alf.plist

              /Library/Preferences/com.apple.alf.plist.lockfile

     

    This did allow for keeping Firewall on but ONLY until the next reboot as you all have mentioned.

     

    So going back to ARD 3.6.2 is the right move for me...all Sharing is working again.

     

    You guys rock!

  • Steve Maser Level 1 Level 1 (10 points)

    "I downgraded to 3.6.2, which restored my ability to Screen Share.  However, the keyboard doesn't work.  I can drive the cursor on my trackpad, but when I try to type, it's non-responsive.  Is anyone else running into this issue?"

     

     

    This happened for me on a Mac OS 10.9 machine -- the 3.6.2 client only allows for cursor control.

     

    For the 10.9 machine, the fix was to set up a clean-install 10.9 system and grab the "RemoteManagement" folder from that machine and replace as indicated above with that version. 

     

    3.6.2 will not allow you to type on a control session on a 10.9 machine, but the "3.7" client that comes with stock 10.9.0 will.

     

    So, what you really need for a full workaround for this issue is the 3.6.2 client for 10.8 machines (and earlier) and the stock-install 3.7 client for 10.9 machines.

     

    - Steve

  • Jason Pelletier Level 1 Level 1 (5 points)

    Here's an interesting little tidbit and brings more mystery to the ALF....if you manually manipulate the alf.plist to change the state of ScreenSharingd from 2 to 0 and restart the firewall, both the command-line and the gui will tell you that screenscharingd is being allowed however it isn't which makes me wonder where on earth the ALF is getting its preferences from? I had thought that changing the plist would set the preferences and the ALF would honor them. Even though the plist changes persist through a restart, the blocked apps still can not get through.

  • spinner2012 Level 1 Level 1 (0 points)

    I appreciate your reply, Steve.  Wondering if you could give me a little more clarification.  I have a Macbook Pro and a headless Mac Mini attached to my HDTV.  I upgraded both computers to Mavericks 10.9.  I would like to use my Macbook to remotely access and my Mac Mini with full funtionality (keyboard, mouse, etc). 

     

    Are you suggesting that I put ARD 3.6.2 on the Mac Mini, and 3.7 on the Macbook Pro?  Or vice versa?  Or something else?  Thanks for the clarification!

  • Mad9000 Level 1 Level 1 (0 points)

    Spinner,

    I have a setup like yours. Once I upgraded my Mac mini to OS X Mavericks, the screen sharing problem ceased to exist. There was no need to do anything.

  • Steve Maser Level 1 Level 1 (10 points)

    So in my specific case, I used ARD Admin 3.7 to push the 3.7 client (build 370A71) to both 10.8.5 and 10.9 machines.   After rebooting both machines, both OSes had the "could no longer control" problem with the "screensharingd" firewall blockage, etc.

     

    On my 10.8.5 machines -- I was able to replace the "RemoteManagement" folder with the 3.6.2 version and that fixed that (after rebooting and removing the "screensharingd" firewall block.)

     

    On my 10.9 machine, installing the 3.6.2 client allowed me to resume control of the 10.9 machine -- but only for mouse movement.  Keyboard functions would not work.

     

    So, on the 10.9 machine, I had to replace the the 370A71 client "RemoteManagement" folder with one from a *stock install* 10.9 machine (the build number does not show for that version other than calling it "3.7").

     

     

    I suppose it's possible if you have a 10.8.5 machine with the "broken" 370A71 3.7 client and you upgrade that to Mavericks, that the ARD client would be replaced with "3.7" and that would temporarily fix the problem.   I have never tried that scenario.

     

     

    So, Spinner, if you have both machines running 10.9 and you installed the 3.7 370A71 client and things are broken, you'll have to find something else you can do a clean-install of Mac OSX 10.9 on to grab that "RemoteManagement" folder to replace it with.     I'm not sure how people who only have a couple of Macs that they already upgraded are supposed to easily do this, though...

     

    One hopes the rumored "3.7.1" ARD client is correctly signed *and* can revert machines that installed the borked 3.7 370A71 client with the wrong firewall settings, etc...

Previous 1 2 3 4 5 6 Next