Previous 1 4 5 6 7 8 Next 106 Replies Latest reply: Dec 18, 2014 6:06 PM by jcv Go to original post
  • RogerGP Level 1 Level 1 (0 points)

    Hello. This works for me today to solve the problem about the error message "Please make sure that Screen Sharing (in the Sharing section of System Preferences) is enabled on the computer to which you are attempting to connect. Also make sure your network connection is working properly."

     

    In the mac I want to control remotely:

     

    • Go to System Preferences
    • Sharing
    • Unselect File Sharing, Remote Login and Remote Management
    • Restart the computer
    • After restart, Select again the option in step 3.

     

    Now I can access that computer from my Apple Remote Desktop.

     

    Versions:

     

    Apple Remote Desktop: 3.7

    OS X: Mavericks.

  • irob_swe Level 1 Level 1 (5 points)

    This is usually the best medicament to ard-patients with a bad hearing:

     

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -privs -all -allowAccessFor -allUsers -restart -agent -verbose
    

     

    Oh, and with remote login enabled at the client that command save you if you are lazy or offsite as you can login via ssh and use it

  • RogerGP Level 1 Level 1 (0 points)

    Hello irob_swe

     

    Thank you very much for your advice. It works perfectly

     

     

    Bes regards

  • walter.dufresne Level 1 Level 1 (0 points)

    FWIW, I have six Mountain Lion machines that displayed the Screen Sharing error message.  For me, Roger GP's solution only worked until the next reboot.  Last week I cloned and upgraded the least-used, non-production MacMini (it mostly does telephony) to Mavericks, and Screen Sharing works again, through reboots.  Yesterday, I cloned and upgraded the next least-used MacMini (it watches a Promise Pegasus array) to Mavericks, and Screen Sharing works again, through reboots.

    I've stopped upgrading for now, and will watch the two Mavericks machines for future trouble.

  • irob_swe Level 1 Level 1 (5 points)

    Woha, sorry for the off topic but that was a very dangerous move to upgrade that system. ARD might be your least problem right now...

    Beware walter.dufresne you might have a ticking bomb there with Pegasus on the OSX 10.9!!!

    If you ever have had any WD disk attached there might be a risk you also have their software and that can format the whole Pegasus array in an instant. You might very well lose every file you have and it's irreversible.

     

    WD has removed their software from their web and are investigating what happens and what disks are in risk zone but fact remains - Pegasus owners lose data every day at the moment as they find out the Pegasus is actually that empty volume named "MyBook". Remove any daemon named wd asap.

  • walter.dufresne Level 1 Level 1 (0 points)

    I know, I know, Mavericks is currently an unreliable solution.  Thanks for the alert.  I'll keep a sharp eye on the Minis.  (FWIW, the Pegasus array is backed up to another Pegasus off-site, and there's a week's worth of work I need to train-net from one site to another.)

  • irob_swe Level 1 Level 1 (5 points)

    Great, just hope you don't have two MyBooks then if you updated that system to 10.9 at the same time.

    If you gonna do it - do it properly! ;-)

  • enigmakv Level 1 Level 1 (0 points)

    OOPS.  Not for me!

     

    I tried this terminal trick on my 2012 Mini, Mtn Lion (10.5.8).  I did a copy and paste of the entire command and got the full verbose feedback with no errors reported.

     

    No luck with Remote connection.

     

    Even tried a reboot...still no luck with Remote connection.

     

    irob_swe wrote:

     

    This is usually the best medicament to ard-patients with a bad hearing:

     

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -privs -all -allowAccessFor -allUsers -restart -agent -verbose
    

     

    Oh, and with remote login enabled at the client that command save you if you are lazy or offsite as you can login via ssh and use it

  • irob_swe Level 1 Level 1 (5 points)

    This is why you should skip refering to your OS by name - I guess you have 10.5.8 (which has another stupid cat name) so here is a command you can use with that OS to see if the ARDAgent is running on your system:

     

     

    ps -x | grep [A]RDAgent

     

    Enable File Sharing and try to connect to your computer over AFP. If you find the computer in the Network folder in the Finder and you open that you should have both "Connect as..." and "Share screen...".

     

    If ARDAgent is running and you have all the settings from the command I sent in the other post I'd say you must take a look at your firewall in the Security pane of System Preferences or start looking if the pesky app called Little Snitch is there somewhere.

  • geychaner Level 1 Level 1 (5 points)

    I ran into the exact problem described here trying to get Back to my Mac working with Remote Desktop 3.7.0 on OS X 10.8.5. I solved it by eliminating Remote Desktop 3.7.0 as follows (after downloading the installer and getting the file list it installs by running it and using Show Files):

     

    sudo rm -rf /Library/Application\ Support/Apple/Remote\ Desktop/Notify

    sudo rm -rf /System/Library/CoreServices/Menu\ Extras/RemoteDesktop-Lion.menu

    sudo rm -rf /System/Library/CoreServices/Menu\ Extras/RemoteDesktop.menu

    sudo rm -rf /System/Library/CoreServices/RFBEventHelper.bundle

    sudo rm -rf /System/Library/CoreServices/RemoteManagement/ARDAgent.app

    sudo rm -rf /System/Library/CoreServices/RemoteManagement/AppleVNCServer.bundle

    sudo rm -rf /System/Library/CoreServices/RemoteManagement/ScreensharingAgent.bundle

    sudo rm -rf /System/Library/CoreServices/RemoteManagement/screensharingd.bundle

    sudo rm -rf /System/Library/LaunchAgents/com.apple.RemoteDesktop.plist

    sudo rm -rf /System/Library/LaunchAgents/com.apple.screensharing.MessagesAgent.plist

    sudo rm -rf /System/Library/LaunchAgents/com.apple.screensharing.agent.plist

    sudo rm -rf /System/Library/LaunchDaemons/com.apple.RFBEventHelper.plist

    sudo rm -rf /System/Library/LaunchDaemons/com.apple.RemoteDesktop.PrivilegeProxy.plist

    sudo rm -rf /System/Library/LaunchDaemons/com.apple.screensharing.plist

    sudo rm -rf /private/etc/com.apple.screensharing.agent.launchd

     

    and then installing the Remote Desktop 3.6.2 package from http://support.apple.com/kb/dl1594. Definitely a bug.

  • merced317 Level 1 Level 1 (0 points)

    Apple Remote Desktop 3.7.1 is out.

     

    http://support.apple.com/kb/HT6045

     

    One of the fixes is:

    • Prevents an issue that could cause the OS X Firewall to block Remote Desktop connections. See Additional Information below.

     

    The Additional Information is:

    • If you previously updated a Remote Desktop client to 3.7 and lost access to it because of the OS X Firewall service, restart the client computer after installing the 3.7.1 update. The correct firewall rule will be automatically added, and you will be able to connect to the client via Remote Desktop.

     

    I can confirm that I have installed this on my 10.8.5 system, restarted, and it works!  I'm glad to see Apple fixed the problem.

  • SMJ NY Level 1 Level 1 (0 points)

    FYI --

     

    3.7.1 finally solved my issue when installed last night.  Multiple reboots on my Mac Mini, and working as expected.  Been spending the past month or so constantly bringing down/up the firewall to access.  Been a real pain but happy it's now working.

  • Mac.Y Level 1 Level 1 (0 points)

    On my iMac and Macmini with OSX 10.7.5, ARD 3.7.1 does not work correctly.

    The problem is exactly the same as 3.7.

  • XFox Level 1 Level 1 (90 points)

    Mac.Y wrote:

     

    On my iMac and Macmini with OSX 10.7.5, ARD 3.7.1 does not work correctly.

    The problem is exactly the same as 3.7.

    Did you reboot the Macs?

    It works here.

  • Mac.Y Level 1 Level 1 (0 points)

    Yes, I did several times.

    But not changed.

Previous 1 4 5 6 7 8 Next