Previous 1 2 3 Next 153 Replies Latest reply: Nov 9, 2015 3:12 PM by S. G.
Igor D. Level 1 Level 1

After installing Mavericks I'm unable to unselect "Store draft messages on the server" and "Store sent messages on the server" checkboxes under my Gmail accounts settings. Unselecting both checkboxes and saving settings works for up to a minute or so - after that the check marks re-appear again by themselves. As a result I end up with dozens of half-finished drafts in the Trash folder after I finish the original and send it out.

 

I used to have both checkboxes unselected prior to Mavericks, and everything was working fine.

 

Any suggestions on how to fix this?


MacBook Pro (Retina, 15-inch, Early 2013), OS X Mavericks (10.9)
Reply by Steve Rhyne on Oct 24, 2013 10:30 AM Helpful

I had the same problem and it was causing dozens of versions of autosaved drafts to appear in my Trash. (Gmail autosaves drafts at the server level and trashes previous saves. The feature is not customizable.)

 

This fixed it for me, at least for the time being:

 

1) Quit Mail.app.

2) Log into Gmail in your favorite web browser.

3) Click on the gear menu and select "Settings".

4) Click on the "Labels" tab.

5) Under "System Labels", next to "Drafts", click on "show if unread" and uncheck the "Show in IMAP' box.

 

Now disable "Store draft messages on the server":

 

6) Launch Mail.app.

7) Select Mail > Preferences...

8) Click on the "Accounts" button in the toolbar.

9) Click once on the account name and then click the "Mailbox Behaviors" tab.

10) Uncheck the "Store draft messages on the server" box.

11) Close the window and opt to save your changes when prompted.

 

A few other Gmail / Mavericks Mail.app discoveries:

 

* You must enable the "Show in IMAP" option for the "All Mail" label in Gmail if you had it disabled before. (Google this tip for explanations and ramifications.)

 

* Mail.app now seems to automatically map the Sent, Junk, Trash and Drafts folders, i.e. you can't use this menu command anymore: Mailbox > Use This Mailbox For > Drafts / Sent / Junk / Trash

 

* I used to add the "[Gmail]" prefix under the "Advanced" tab of my mail account to eliminate it from the IMAP view, but it doesn't seem to be necessary any more, and might even have been causing some weirdness.

All replies

Previous 1 2 3 Next