Previous 1 10 11 12 13 14 Next 354 Replies Latest reply: Feb 25, 2015 3:59 AM by teh dave Go to original post Branched to a new discussion.
  • wwmihe Level 1 Level 1 (0 points)

    This worked!

    On your computer - select all and then export your contacts as vCards. Save to desktop.

    Email them to yourself. Open the attachment and you will get a prompt to either creat new or merge with existing contacts.

    No cloud - no wi-fi.

    Hope this helps.

  • geezerhiker Level 1 Level 1 (0 points)

    The new location trick worked for me, after trying everything under the sun.

  • nathaliejit Level 1 Level 1 (0 points)

    Devices failed to appear in itunes and I could not wi-fi synch my iphone (4s) and ipad (2) since upgrading the imac to mavericks. Connecting devices physcally using the usb cable did work though. Only, as soon as I disconnected the cable the devices became invisible to itunes whereas this used to work prior to mavericks.

     

    In my case, what solved my problem after some searching was to enable the IPv6 "link-local only" mode on the imac (go to System Preferences > Network > Advanced > TCP/IP > Configure IPv6). My IPv6 default config was set to 'off' or 'disabled' since IPv6 first appeared years ago on osx.

     

    Restart the imac and voila!, the devices magically appeared in itunes again and I could synch music, apps, contacts, calendar etc ... It's all working flawlessly via wi-fi synch again.

  • patrick.fr Level 1 Level 1 (0 points)

    Hi

     

    the wifi sync is ok with your solution , but i still didn't have the tab in tunes to sync agenda and calendar

    Apple remove this functionnality with Mavericks and forced users to sync agenda and calendar with Icloud

     

    see this linkhttps://discussions.apple.com/message/23825860?ac_cid=tw123456#23825860

  • Amin_AA Level 1 Level 1 (0 points)

    Well, apparently I spoke too soon. Back to square one.

  • lkrupp Level 4 Level 4 (3,400 points)

    Amin_AA wrote:

     

    Well, apparently I spoke too soon. Back to square one.

     

    I think the number of voodo-like solutions that others have reported indicates, more than ever, that this is some basic bug that needs addressing. I too have tried various troubleshooting techniques and my iPad 2 only appears sporadically in iTunes using Wi-Fi. I can find no pattern to it working or not working. Last time it appeared was after a restart. It worked for a while and then disappeared again. Since some Windows users are reporting the same issue I suspect it's a problem in iOS. Meanwhile I just continue to use USB for syncing. While annoying this is not some catastrophic deal breaker and we all should continue to report this to Apple via feedback.

  • Armando Stettner Level 2 Level 2 (205 points)

    Oops!  I mistakenly reversed the items in the first sentence of my note on Nov 13, 2013 11:02 AM!!  The first sentence should read:

     

    Armando Stettner wrote:

     

    Mavericks itself (regardless of the version if currently available iTunes), has removed the ability to sync contacts and calendar (and, apparently, keychain entries - passwords, authorizations, etc.) via direct connection (via USB or WiFi) but rather now syncs them ONLY via iCloud.  As I understand it, all other items can go over those local direct connections and do not have to go over iCloud.

     

    Sorry for the confusion.

     

       aps

  • lkrupp Level 4 Level 4 (3,400 points)

    Armando Stettner wrote:

     

    Oops!  I mistakenly reversed the items in the first sentence of my note on Nov 13, 2013 11:02 AM!!  The first sentence should read:

     

    Armando Stettner wrote:

     

    Mavericks itself (regardless of the version if currently available iTunes), has removed the ability to sync contacts and calendar (and, apparently, keychain entries - passwords, authorizations, etc.) via direct connection (via USB or WiFi) but rather now syncs them ONLY via iCloud.  As I understand it, all other items can go over those local direct connections and do not have to go over iCloud.

     

    Sorry for the confusion.

     

       aps

     

    This is really not the discussion thread for that issue. We are talking here about our iOS devices not mounting via Wi-Fi when iTunes is launched. Your issue is about syncing through iCloud instead of locally. Two totally different issues and discussions. In the spirit of clarity would you kindly find the correct discussion thread for your issue? It's very confusing to combine the two.

  • Gerry Beggs Level 1 Level 1 (0 points)

    I agree there there must be a bug. I have reported it to Apple through their bug reporting website (developers only).

     

    I have been able to reliably reproduce the problem and reliably able to make the problem go away (temporarily).

     

    This also might explain some people's experiences posted here.

     

    After I restart my Mac, I can sync via WiFi with no problems at all as many times as I like. I have an iPod touch and two iPads, and they are all recognized by iTunes via WiFi.

     

    The problem always starts after the computer goes to sleep (either when I issue the command to go to sleep, or if it automatically puts itself to sleep after being idle).

     

    When I wake the Mac up, the WiFi sync stops working and the only way I've been able to make it work is to restart the Mac again.

     

    There may be a specific process that only needs restarting, but I don't know which one it is.

  • lkrupp Level 4 Level 4 (3,400 points)

    Gerry Beggs wrote:

     

    I agree there there must be a bug. I have reported it to Apple through their bug reporting website (developers only).

     

    I have been able to reliably reproduce the problem and reliably able to make the problem go away (temporarily).

     

    This also might explain some people's experiences posted here.

     

    After I restart my Mac, I can sync via WiFi with no problems at all as many times as I like. I have an iPod touch and two iPads, and they are all recognized by iTunes via WiFi.

     

    The problem always starts after the computer goes to sleep (either when I issue the command to go to sleep, or if it automatically puts itself to sleep after being idle).

     

    When I wake the Mac up, the WiFi sync stops working and the only way I've been able to make it work is to restart the Mac again.

     

    There may be a specific process that only needs restarting, but I don't know which one it is.

     

    Well, I'll be a monkey's uncle. You have indeed found the pattern. I tried your scenario and it duplicated itself on my machine exactly. I restarted, launched iTunes, and my iPad mounted immediately. I put the machine to sleep, woke it up, launched iTunes, and my iPad refused to mount, just as you predicted. Tried it several times with the same results.

  • mm_on_asc Level 1 Level 1 (0 points)

    Exactly what I have been experiencing and also posted earlier. What I found that worked for me to resolve the issue was how I was connected to the internet. I traditionally have had my iMac connected to my airport extreme via ethernet cable. By unplugging the cable and turning on WiFi, I found that my iOS device are now always recognized in iTunes, whether it be after starting the iMac and launching iTunes, or waking up the Mac after having gone to sleep.

  • geezerhiker Level 1 Level 1 (0 points)

    I have had a similar experience, but not consistently. It always worked before with my iMac on Ethernet.

  • Gerry Beggs Level 1 Level 1 (0 points)

    Me too. Wi-Fi sync always worked for me - and my Mac is connected via Ethernet.

    it only stopped working when I upgraded to Mavericks (or iOS 7, but since restarting the Mac fixes it temporarily, I suspect it is Mavericks that is the problem)

  • Allan Clark Level 1 Level 1 (10 points)

    The key therein might be in the Console Log:

     

    com.apple.usbmuxd: _SendAttachNotification Device xx:xx:xx:xx:xx:xx@fe80::ipv6:ipv6:ipv6:ipv6._Apple-mobdev2._tcp.local has already appeared on interface ##.  Suppressing duplicate nofitication.

     

    com.apple.usbmuxd: _heartbeat_failed heartbeat detected detach for device 0xd25-fe80::ipv6:ipv6:ipv6:ipv6:ipv6!

     

    1) I'm not sure I have ipv6 configured on the airport Extreme between the MacMini and the iPhone.

    2) note: DUPLICATE: the process is refusing to notify that a duplicate device attachment was detected

     

    Is it possible that restarting the Mac hosting the iTunes wipes the detection, allowing the first attachment becuase it's non-dupe, but that attchment never removes?  This would cause every second/third/fourth attachment to not reach the iTunes, allowing the iPad or iPhone to appear in the device list.

     

    I also see (sudo /usr/sbin/tcpdump -i en0 host {iphone IPv4 addr}) that the two systems (iphone, mac) are communicating, so perhaps that's the communication to the attach notify.

     

    I'm going to see if I can restart just the daemon hosting the notify.  I'm currently bogus-ing my launchctl commands, but I was going to start with restarting the iTunesHelper.  Additionally, I'll see if deactivating ipv6 (from current: link-local) affects things.

  • Allan Clark Level 1 Level 1 (10 points)

    So... AirportExtreme doesn't offer a way to check/enable/disable IPv6.

     

    iPhone <--> AE <--> MacMini (10.9.x) seems to be mdns soliciting "who is mini.local", then communicating via IPv4.  iPhone is communicating with a socket owned by the iTunes process, not the iTunesHelper.  Killing the iTunesHelper does not cause iTunesHelper to restart on the next sync attempt.

     

    No change in sync success throughout: iPhone starts the sync, no obvious change on iTunes screen despite IPv4 traffic, duplicate attach is ignored per logs.

Previous 1 10 11 12 13 14 Next