Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Can't use the keyboard shortcuts in Photoshop CS6 when updating Mavericks

Can't use the keyboard shortcuts in Photoshop CS6 when updating Mavericks

Posted on

Reply
Question marked as Helpful

Nov 10, 2013 5:15 PM in response to helena.hoang In response to helena.hoang

Problem finally solved in my case (Japanese keyboard) as suggestions offered above failed to fix the problem, thanks to a post on adobe Forums, so kudos to someone named sevdestruct:

1. Quit Photoshop if open,

2. Go to ~/Library/Preferences/Adobe Photoshop (your version) Settings,

3. In the Adobe Photoshop (your version) Settings folder, delete:

a. Keyboard Shortcuts.psp

b. Keyboard Shortcuts Primary.psp

c. Adobe Photoshop (your version) Prefs.psp (Given by sevdestruct as for good measure, won’t hurt!),

4. Go to System Preferences > Keyboard > Input Sources,

5. Select U.S. as input,

6. Make sure that in your top menu bar, U.S. input source is selected EVERYTIME you open and use Photoshop,

7. Open Photoshop… et voilà!

8. sevdestruct also advises to save any custom shortcuts you may create from now on.


Repeat (at least for Japanese input users): do NOT switch to any other input method than U.S. while working in Photoshop! Thanks again to sevdestruct and i hope this works for you all.

There’s more to the conversation

Read all replies

Page content loaded

Oct 23, 2013 6:30 PM in response to helena.hoang In response to helena.hoang

I had the same problem. I have Japanese installed on my computer, and the OS update defaulted my keyboard settings only to Japanese (Kotoeri). For some reason the update deleted the US keyboard input. I reinstalled the US keyboard through system preferences (Keyboard --> Input Sources --> U.S.) and the problem was corrected.

Oct 23, 2013 6:30 PM

Reply Helpful

Oct 23, 2013 11:00 PM in response to helena.hoang In response to helena.hoang

Had the same issue (again, Photoshop CS6) but seem to have cured it with the steps below:


1) While in Photoshop, go to 'Keyboard Shortcuts' under the 'Edit' menu in the Mac's menu bar. The 'Keyboard Shortcuts and Menus' panel opens.


2) With the 'Keyboard Shortcuts' tab selected (as opposed to 'Menus'), double-click 'File' (has a triangle next to it) under the 'Application Menu Command' and select/highlight the 'Open...' command.


3) Without editing the key shortcut in any way, click the 'Accept' button to the right. Then 'Okay' to close the panel. This successfully reinstates the 'Open' keyboard shortcut.


4) At this point, you're probably thinking, 'My god, I'm going to have to repeat this process for every single keyboard shortcut...'. But no, simply 'accepting' the 'Open' command appears to successfully reinstate every other keyboard shortcut too!


Bizarre. Only tried this in desperation after a full reinstall of Photoshop failed to resolve the issue.


Hope this helps ☆

Oct 23, 2013 11:00 PM

Reply Helpful (1)
Question marked as Helpful

Nov 10, 2013 5:15 PM in response to helena.hoang In response to helena.hoang

Problem finally solved in my case (Japanese keyboard) as suggestions offered above failed to fix the problem, thanks to a post on adobe Forums, so kudos to someone named sevdestruct:

1. Quit Photoshop if open,

2. Go to ~/Library/Preferences/Adobe Photoshop (your version) Settings,

3. In the Adobe Photoshop (your version) Settings folder, delete:

a. Keyboard Shortcuts.psp

b. Keyboard Shortcuts Primary.psp

c. Adobe Photoshop (your version) Prefs.psp (Given by sevdestruct as for good measure, won’t hurt!),

4. Go to System Preferences > Keyboard > Input Sources,

5. Select U.S. as input,

6. Make sure that in your top menu bar, U.S. input source is selected EVERYTIME you open and use Photoshop,

7. Open Photoshop… et voilà!

8. sevdestruct also advises to save any custom shortcuts you may create from now on.


Repeat (at least for Japanese input users): do NOT switch to any other input method than U.S. while working in Photoshop! Thanks again to sevdestruct and i hope this works for you all.

Nov 10, 2013 5:15 PM

Reply Helpful (5)

Jan 17, 2014 10:38 PM in response to Octorobot888 In response to Octorobot888

Found a solution for ≠ being stuck in the menu shortcuts on English Keyboard and having American keyboard and Koteri Keyboard selected in System Preferences.

1. Close Photoshop

2. Go System Pref. and remove the Koteri Keyboard.

3. Open Photoshop and set your Keyboard shortcuts. (Delete/replace all the ≠ with your shortcut of choice.

4. Go ahead and reselect your Koteri keyboard.

5. Never Quit Photoshop. (if you do repeat from step 2)

Jan 17, 2014 10:38 PM

Reply Helpful (1)

Jun 13, 2014 1:19 PM in response to helena.hoang In response to helena.hoang

As others have mentioned, after installing latest Mavericks update, the US keyboard disappered leaving only Kotoeri. Photoshop does not like. The solution below worked for me. Hope this is helpful for someone else.


Go to System Preference > Keyboard > Input Sources

Add US keyboard, deleted Koterei.


Go to Photoshop > Preferences > Interface

At bottom of dialogue box, choose US keyboard as defalt.

Close Photoshop.


Return to System Preferences add Kotoeri.

Jun 13, 2014 1:19 PM

Reply Helpful (1)

Jul 5, 2014 3:18 AM in response to Barb.T In response to Barb.T

Thanks everyone. What worked for me was a version of the suggestions above. I had the problem with the character appearing in all my Photoshop CS6 keyboard shortcuts and rendering them largely unusable. However, I don't have any other keyboards besides US English enabled on my Mac. I do have Spell Catcher installed, which works through the keyboard input method. So, I switched from Spell Catcher back to English (with the US flag), launched Photoshop and presto, my keyboard shortcuts were restored, absent that obnoxious symbol. Once in Photoshop, if I reselect Spell Catcher, the symbol returns so I have to run Photoshop without the help of Spell Catcher - or forego the use of keyboard shortcuts while it's on. Since the developer of Spell Catcher passed away last year there will be no more updates to the otherwise very useful utility. Apparently this keyboard shortcut problem in the various guises reported here is linked to some element of the OS X input method in Mavericks, as Photoshop seems to manifest the issue in relation to one specific input source or another. This is the first application in my experience to have a problem with Spell Catcher in OS X 10.9. So I will continue to use it, except in Photoshop. Spell Catcher was never updated for Mountain Lion or Mavericks so people like me will have to use it "at our own risk" as the saying goes. Be that as it may, it does appear to be a bug in Photoshop that's at the root of this matter as different people have somewhat different problems with the OS X input method - not that I expect either Adobe or Apple to do anything about it.

Jul 5, 2014 3:18 AM

Reply Helpful

Feb 21, 2015 8:42 PM in response to jpbuquet In response to jpbuquet

This actually solved my problem (all shortcuts gone), in OS 10.9, Photoshop CS6. Thank You!!!

I simply had to switch from Japanese keyboard to US keyboard before starting up Photoshop!!!

Even deleting the preference file multiple times didn't help, until I switched the keyboard from JP to US.

Feb 21, 2015 8:42 PM

Reply Helpful
User profile for user: helena.hoang

Question: Can't use the keyboard shortcuts in Photoshop CS6 when updating Mavericks