Previous 1 2 Next 24 Replies Latest reply: Mar 7, 2014 8:55 PM by Babycatgrandma
creativestreak Level 1 Level 1 (0 points)

I upgraded to OSX Mavericks today on my MacBook Pro (it's a 2011 model). One of the items that wanted to update was iPhoto, so of course I did that. When it was done, I couldn't get it to open. Instead, I got this message:

 

"The iPhoto Library is locked, on a locked disk, or you do not have permission to make changes to it. iPhoto can try to repair the permissions."

 

Withe option to repair it. After I clicl on the repair button (and a briefe stint with the beachball), I get this message:

 

"The iPhoto Library is locked, on a locked disk, or you do not have permission to make changes to it."

 

iPhoto was working fine before. I checked the Get Info on the iPhoto Library file and it says that I have Read & Write permissions. I clicked on the gear icon at the bottom and was given the choice to make Me the owner of this file, so I clicked that. Then I tried the whole thing over again with the same result.


The odd thing is that Aperture appears to work just fine.

 

Thoughts?


MacBook Pro (15-inch Core 2 Duo), OS X Mavericks (10.9)
  • CMTailor Level 1 Level 1 (5 points)

    Fixed this issue on my Mac by locating the iPhoto Library in /Users/username/Library/iPhoto and opening the Library with iPhoto. iPhoto did not display the Library is locked message; instead offered to upgrade the Library in order to use the new version of iPhoto (as always after upgrades).

     

    Starting iPhoto directly, however, results in the same problem. So, for now, I guess, this little workaround is a quick way to access to your photos.

  • creativestreak Level 1 Level 1 (0 points)

    I had tried that already. Not surprisingly, the iPhoto Library file was locked when I first opened it. So I unlocked it and tried again, with the same result. After reading your reply, I went back to double check and it was locked again. Odd. I've tried opening iPhoto while holding down Command + Option, but that didn't bring up the rescue dialog as I was expecting it to.

     

    I'm stumped.

  • CMTailor Level 1 Level 1 (5 points)

    Strange, my iPhoto Library is not locked but I encounter the same issue when opening iPhoto directly (i.e. from the Applications folder). When opening the Library from the Finder, you can bring up the rescue dialog by pressing cmd+alt. However, even rebuilding the whole library did not help for me…

     

    I think we have to wait for Apple to fix these issues.

  • Terence Devlin Level 10 Level 10 (126,965 points)

    Couple of things to try:

     

    Restart your mac and try launch iPhoto again.

     

    If that fails:

     

    Go to your Pictures Folder and find the iPhoto Library there. Right (or Control-) Click on the icon and select 'Show Package Contents'. A finder window will open with the Library exposed.

     

    Look there for a file called ‘iPhoto’Lock.data or similar. Drag it to the Desktop. Make no other changes. Start iPhoto. Does that help?

     

    If not: Where is your iPhoto Library stored? If it's on an External Disk, what format is that?

  • creativestreak Level 1 Level 1 (0 points)

    I tried this just as you suggested, no results. I still keep getting the same 2 error messages. I even tried Option-Command opening iPhoto after the steps you offered and there was still no rescue box.

     

    On a side note: I did happen across something interesting when I followed your steps to where I found the iPhotoLock file. There are 2 iPhoto Library files in there. One called Library.iPhoto and one called Library6.iPhoto. Both of them were modified at the exact same time on the same date... July 2, 2012 at 10:43 PM. Now that I don't understand at all because I know I've made changes to iPhoto since then. So I'm not really sure what this is all about.

     

    One other thing: now that I've gone through these steps, the Date Modified for the "iPhoto Library" file found in home>photos is now just a few minutes ago (the last time I tried to repair it. So it's obviously accessing the file, it's just not able to do anything with it.

     

    So have I just added a whole other layer of complexity to this enigma?

  • jenj814 Level 1 Level 1 (0 points)

    I also had the same problem and I have the same MBP.  I decided to just buy the latest version of iPhoto, installed it and now it works fine   I know you would like a free solution but it was only $14.99 and that worked for me.  I use that program so much it was worth it to me to have it fully functional and accesible.

  • creativestreak Level 1 Level 1 (0 points)

    Yes, but iPhoto is free with the OSX. And since I already have it, I do not have the ability to re-purchase it, nor would I. I don't think I should have to pay $15 to get a program that I already have for free just because the new OSX seems to have messed something up with it.

  • jenj814 Level 1 Level 1 (0 points)

    I completely agree, I just panicked and purchased it since it was so cheap and I had every photo from the last 2.5 years of my life on it (including wedding pictures).  Just one known solution and I was too impatient to figure out free one.  I just figured it was like any Windows OS upgrade that some programs do not work with new updates, KWIM?

  • creativestreak Level 1 Level 1 (0 points)

    Actually, no, I don't know what you mean. I've never used a Windows machine so I've never had to upgrade any Windows OS...

  • jenj814 Level 1 Level 1 (0 points)

    Haha!  Well, before I switched over to a Mac, I had dealt with the nightmares of Windows and was used to buying some new programs everytime there was an update!  I hope you find a (free) solution soon!

  • CMTailor Level 1 Level 1 (5 points)

    Terence Devlin,

     

    I tried restarting and moved the Lock.data file without success. I even deleted iPhoto.app and reinstalled via the App Store. My iPhoto Library is located on my Macintosh HD in /Users/username/Library/iPhoto, so the file system should not be a problem. Also, I repaired permissions with Disk Utility.

     

    As I said, opening the Library directly starts up iPhoto without the annoying dialogue.

     

    Further suggestions?

  • creativestreak Level 1 Level 1 (0 points)

    I tried opening directly from the file in Library, as you suggested and it works fine. Just like you. Now if I could only get it to open from the program itself...

  • patricia159 Level 1 Level 1 (0 points)

    This worked for me also. Thanks so much. It is a little work around, but will work until the problem is fixed.  I held down control/option key while I opened iPhoto, Open, Oother Library, IPhoto Library and it asked for an upgrade.  iPhoto works.  These may be the same steps you followed, but this was my sequence.

  • bilsw Level 1 Level 1 (0 points)

    Moving iPhoto Library from the Library folder to the Pictures folder solved the problem for me. I can now start iPhoto normally by clicking on the application. For whatever reason, it appears iPhoto now wants to start in the Pictures folder.

Previous 1 2 Next