Previous 1 2 3 4 Next 58 Replies Latest reply: Jun 20, 2014 6:09 AM by BobHarris Go to original post
  • sablesg Level 1 (0 points)

    Ditto that. Unable to find WPA2-Enterprise network on my Uni, where my other device (Android) can. Manually joining the network works, but have to do this every time it resumes from sleep.

  • MacGee Level 6 (8,555 points)

    I installed Mavericks last night (with some trepidation) on my Mac Mini and the transition was seamless. The Wifi carried on working as before. That doesn't mean that there's not a problem with Mavericks, but if there is, it's clearly not the whole story. There's probably some factor that people with problems have in common; if we could identify that, we would be halfway to finding a solution—or at least a workaround.



  • sablesg Level 1 (0 points)

    Hi Michael,

    The issue here is specifically for WPA/WPA2 enterprise encryption (802.1x). WPA personal works fine for me too. Can you confirm that yours is using WPA enterprise?

  • thepowerofnone Level 1 (0 points)

    Michael can you confirm that you are connecting to a WPA-2 enterprise network?


    To all other commenters instructing us to reset or fiddle with our routers, the issue is sort of in the name enterprise, most/all of us lack administrative access to our routers; if I were an IT professional working for an enterprise and a user approached me saying their has been a problem with my network ever since they  installed a piece of software, I know where I would point the finger. I certainly wouldn't rush about to check my entire WPA-2 system.

  • beguerisse Level 1 (0 points)

    I have the exact same problem, updated to Mavericks and now I cannot find the university's WPA network.

  • DrFreeman2 Level 1 (0 points)

    I use WPA-2 Enterprise Network.


    It seems to be the problem for this particular type of nework, you can view the network using the Network Diagnostic App but it does not show up in the Wifi bar sadly. (I am currently using the manual method to connect to the WPA2 enterprise).

  • anasimtiaz Level 1 (0 points)

    I'm having the same problem. Doesn't find WPA-2 Ent Network and even agter manually entering the SSID it doesn't auto-connect after the connection is dropped.

  • AntonioEsteban Level 1 (0 points)

    I'm having a slightly different problem - I can't get connections on 5 GHz after upgrading to Mavericks.


    The SSIDs on 5GHz are WPA2-Personal, and they worked fine before the upgrade. I can connect on the 2.4GHz channels (either an open SSID, or a WPA2-Personal). Full details:

  • tsl14 Level 1 (0 points)

    I have the same problem only with WPA enterprise. However, by typing in the SSID and enter username and password I am able to connect also woth WPA enterprise. Whatever I enter is forgotten when the mac hibernate. This is an OS bug. Apple, please fix ASAP!

  • AntonioEsteban Level 1 (0 points)

    Update: Good News! I'm not sure why, but rebooting my router seems to have cleared the problem of not being able to connect to the 5GHz SSID. In fact, I'm posting this through a 5GHz connection... See my blog posting ( for more details.

  • wifiguru Level 2 (240 points)

    Can someone take a wireless trace of their network and paste it here ?


    If you can get a system.log right after the failure and mention the name of the network you expect to join, I can take a look and try to help out. What channel is the network on ? Have you guys checked if you can get on 2.4 Ghz networks and only 5 Ghz networks are the issue ? Might help throw some light.

  • tsl14 Level 1 (0 points)

    Not sure I can dump my University network info. However, using the "airport" command, I find all available WIFI networks being a mix of 2.4GHz and %Ghz. The wifi network list in the system preferences->networks however is missing all WPA2-enterprise using 802.1X authentication (MSCHAPv2). Other WPA2 networks are OK. Manual connect does work, but need reconnection for every hibernation....

  • AntonioEsteban Level 1 (0 points)

    However, using the "airport" command, I find all available WIFI networks being a mix of 2.4GHz and %Ghz.

    I'm not familiar with the "airport" command, but it sounds useful. How do you invoke it?

  • AntonioEsteban Level 1 (0 points)

    Have a look at:

    Errrm... That URL links to this topic. When I type "airport -l" into Terminal, I get the following:


    % airport -l

    airport: Command not found.