Previous 1 2 3 4 Next 58 Replies Latest reply: Jun 20, 2014 6:09 AM by BobHarris
willny323 Level 1 (0 points)

My MacBook air cannot find WPA-2 enterprise wifi on the network list when updated to Mavericks, but I can add the network by choosing "joining other network" and typing username and password manually. Anyone knows how to solve this problem?

MacBook Air, OS X Mavericks (10.9)
  • MacGee Level 6 (8,555 points)

    You may have stopped your Wifi from broadcasting the network name for security reasons. You can change this setting in your Wifi preferences, but now that you've connected once, your MBA will automatically connect in future.



  • willny323 Level 1 (0 points)

    Thanks, but my Mac cannot remeber this netwrok, so I have to repeat the procedure every time after the computer wakes up.

  • DrFreeman2 Level 1 (0 points)

    Apparently this is an OS issue and from what I have been told, we have to wait for Apple to update it.

  • MVMVM Level 1 (0 points)

    Yeah, this is definitely an OS issue, had the exact same issue on university wifi with two different laptops, 802.11X connections seem to be broken in 10.9

  • Tioneb gnadmahp Level 1 (0 points)

    Same thing here. My WIFI couldn't see the WPA networks.

    One way to make it work is to go to "Join other network" and explictely fill in the details of your WPA network. Hope that help as a temporary fix.

  • thepowerofnone Level 1 (0 points)

    Same problem here; rMBP Early 2013. Seriously, what the **** Apple? How could you overlook this? Either a) for all your 6 months of beta testing you really overlooked checking something basic or b) you truely are trying to tell the shrinking portion of your user base which actually uses your computers for work to take their customer somewhere else! Personally I am sceptical it is a: one of your developers must work on an enterprise network somewhere.


    "join other network" then type everything in manually every time you wake from sleep is not an acceptable solution!

  • wifiguru Level 2 (240 points)

    Is the network that you guys are trying to join a hidden network ? If so, can you delete the entry from the Preferred network lists, reboot and then join the network using the Join Other networks option. Now check if the issue is resolved.

  • MVMVM Level 1 (0 points)

    The network I am trying to join is not a hidden network, it is visible to other (non 10.9) devices and under boot camp.

  • leodali83 Level 1 (5 points)

    Hi everybody,

    I'm having your same problems connecting to my Wi-Fi, which worked perfectly since this morning when I upgraded this Macbook, bought at the end of 2008 (actually quite old )


    Wireless connect to the router and lease for the IP correctly, but after that show the ! icon and doesn't surf on the Internet...Diagnose Wireless checks everything but the problem still occur.


    I sincerely hope they will fix this issue as soon as possible!

  • I love wireless Level 1 (5 points)

    Are you using WPA/WPA2 enterprise security?

  • leodali83 Level 1 (5 points)

    WPA2 Personal, exactly.

  • I love wireless Level 1 (5 points)

    Have you tried deleting your network from the preferred network list and then joining the network from AME and see if that works? This thread is for WPA/WPA2 enterprise, so lets try to keep it that way and we will track this in a new thread

  • wifiguru Level 2 (240 points)

    leodali, this thread is about not being able to see the wireless network when user scans from the WIreless Menu Extra. Your issue seems different in that you can connect but don't get an IP Address.

  • leodali83 Level 1 (5 points)

    Actually you are right, I will move my issue inside another post

Previous 1 2 3 4 Next