Previous 1 2 3 Next 62 Replies Latest reply: Oct 4, 2014 7:34 AM by huulong
Seigneur_Folken Level 1 Level 1 (0 points)

I installed Maverick this morning, and what was my surprise when I tried to use Kotoeri on my french keyboad (then Azerty)...

 

Until Mountain Lion, when i was using french language source, my keyboard was on the Azerty mode, and when using Kotoeri, my keyboard was converting to a JIS Keyboard (Japanese Qwerty).
But now, Kotoeri is using the Azerty mode, even when I use a JIS Blutooth Apple Keyboard.

 

The only trick to use the Qwerty mode for Kotoeri is to drag a US keyboard in the language source, then alternate between french language source for french, then US keyboard=>Kotoeri to use the Qwerty mode in japanese...

 

To be clear:
Until Mountain Lion:

 

French language source= Azerty
Kotoeri Japanese language source= Qwerty

 

With Maverick:
French language source= Azerty
Kotoeri Japanese language source= The same language source as the previously used.

 

So, the question is: Why did you do that?
It's just a **** to use this! All the people using japanese language I know are naturelly using the Qwerty mode for Kotoeri, and some japanese characters are not included in the Azerty mode (such as "~").

  • Tom Gewecke Level 9 Level 9 (75,340 points)

    Are you able to switch the keyboard for Romaji typing in Kotoeri Preferenes > Operation > Keyboard?

  • Tom Gewecke Level 9 Level 9 (75,340 points)

    I see that Apple has deleted the keyboard setting from Kotoeri Preferences and gone back to the old way where it is the last used keyboard which determines the Kotoeri layout.  So you have to go to the US layout in the "flag" menu before switching to Kotoeri.

     

    To let Apple know how annoying this is, use

     

    http://www.apple.com/feedback

  • Timoooh Level 1 Level 1 (0 points)

    I have the exact same issue!!!

     

    I have a Japanese keyboard and before Mavericks, I used to switch between Swedish as my main and Japanese as my second.

     

    But, after installing Mavericks... When I switch from Swedish input into Japanese kana... All of the symbols are not on the same keys as before... Now, I cannot write   " ~",  "?"  etc. symbols anymore, because the keys has all been replaced with other symbols.

     

    It's really annoying and I noticed by accident that the only way I can get the original Japanese symbol key setting is by having American as my first input and then when I switch over to typing Japanese... The symbols are exactly at the same keys as they used to be before I installed Mavericks.

     

    However, if I choose to have American as my first input then I cannot type with Swedish characters... It's really stupid!!!

     

    Is there no way to solve this problem? I tried to check if I could customize the Japanese symbols for the keys but there is no option...

     

    I am seriously considering to switch back into my previous OS x because of this. I need to be able to write these Japanese symbols like I used to.

  • Tom Gewecke Level 9 Level 9 (75,340 points)

    Timoooh wrote:

     

    if I choose to have American as my first input then I cannot type with Swedish characters...

     

    You can certainly type all the Swedish characters with the US layout, either by just holding down the key for the base letter and using the Character Picker menu which will pop-up, or by using the standard option/alt shortcuts.  But of course it is not the same as the Swedish layout.

     

    Only Apple can fix this issue.  For many years Kotoeri worked this way.  Everyone just switched to the US layout in the "flag" menu before going to Kotoeri, but it was unpopular enough they finally added a keyboard setting in the preferenes.  Why they went backwards is a mystery.

  • Timoooh Level 1 Level 1 (0 points)

    Do you know if there are any options in OS x Mavericks to customize the keys symbols/characters?

     

    If there is, I could easily just switch the symbols on the keys so that when I switch over to typing Japanese, the previous symbols layout determines the kotoeri layout.

     

    Thanks.

  • Tom Gewecke Level 9 Level 9 (75,340 points)

    You can try using the autocorrection system found in system preferences/keyboard/text (I think it's there).

  • Timoooh Level 1 Level 1 (0 points)

    Ok, so I tried it but appearently it would not allow me to change Japanese characters or symbols.

     

    How long does it take before Apple changes this? I wonder why they would do this in the first place...

     

    Or else I think I'll certainly go back to Mountain Lion!

  • Tom Gewecke Level 9 Level 9 (75,340 points)

    Nobody can tell you if or when Apple will change things in response to feedback.  You may well want to stay with 10.8.  I've found it's never really a good idea to just switch as soon as a new OS comes out.  There are always bugs or changes that cause problems, so best to stay with the old one while you try the new one from a separate partition or extra drive.

     

    In the past I think some people preferred alternatives to Apple's Kotoeri for Japanese, the most common being ATOK.

  • Seigneur_Folken Level 1 Level 1 (0 points)

    Thanks for your answers.
    I'm happy to see I'm not the only one to be annoyed by this thing...

     

    I'll send a feedback to Apple.

  • Timoooh Level 1 Level 1 (0 points)

    Thanks and yes please!

     

    Everybody should send feedback to Apple here: http://www.apple.com/feedback/macosx.html

     

    Also, refer to this thread. I believe that the more people who give feedback, the more likely they will change it. Let's hope for the best!

  • Aelfinwe Level 1 Level 1 (0 points)

    Hi!

     

    Same problem here when switching from French to Japanese... Very annoying!

  • I. Heiska Level 1 Level 1 (0 points)

    Same issue here.

    I have a japanese Macbook Pro with a japanese physical keyboard layout. I regularly need to switch between Japanese and Swedish layouts. In 10.9 the result of this change is that I'm unable to type japanese properly unless I go into System Prefs and add/remove the Swedish layout whenever I need to switch.

  • Timoooh Level 1 Level 1 (0 points)

    Yes, same here. I bought my Macbook Air in Japan because I used to live there and I speak Japanese... But the only way for it to work normal like before is if I use "American" before I write in Japanese. But that means that I cannot switch between Swedish and Japanese anymore... It's stupid!

  • Seigneur_Folken Level 1 Level 1 (0 points)

    Please send as many feedback as you can ^^

Previous 1 2 3 Next