8 Replies Latest reply: Dec 28, 2013 6:53 AM by BrianInCalifornia
Lysdexic Level 1 Level 1 (0 points)

Since upgrading, my Time Machine drive only displays the orange icon, not the blue/green Time Machine icon that is normally supposed to be displayed. I'm unsure if this impacts my back-ups or not. Is anyone else experiencing this?


MacBook Pro (15-inch Mid 2012), OS X Mavericks (10.9)
  • MajorIP4 Level 1 Level 1 (20 points)

    Well I use a WD mybook live NAS for TM backups and since installing Mavericks I don't even get the backup drive showing on the desktop. But the backups do work. Strange.

  • ssls6 Level 4 Level 4 (2,850 points)

    It can take Mavericks one or two cycles of TM to finally flip the icon.  You'll notice each time you boot.  You will also notice the TM active icon on the top menu no longer rotates, just a small arrow is added.

  • Lysdexic Level 1 Level 1 (0 points)

    I'll watch out for that change. Hopefully it takes effect. Thanks!

  • macboyinsf Level 2 Level 2 (240 points)

    ssls6 wrote:

     

    You will also notice the TM active icon on the top menu no longer rotates, just a small arrow is added.

    You know, I didn't even notice that until now; very subtle. Thanks.  My time machine IS working at least. I just thought there was something wrong with the menu bar icon.

     

    I don't get it.  Why take away the rotating icon? Visual cues are important.

  • WALTER-MILANO-ITALY Level 4 Level 4 (2,175 points)

    You may try this

     

    > Click Finder

    > Click Go

    > Click "Go to Folder..."

    > Enter "/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources

    > Look for "GenericTimeMachineDiskIcon.icns"

    > Drag icon file while holding option onto icon in top left of Hard Drives "Get Info" window.

     


  • WTF4CT Level 1 Level 1 (0 points)

    now that i know the new icon (double arrow when in back up mode) I like it.  I don't need a spinning icon to eat battery and one more thing for my eye/brain to process.

  • jpdemers Level 1 Level 1 (20 points)

    This will permanently set the icon to the TM blue-green image.  It's OK as a cosmetic fix, but you won't know whether TM has actually recognized the backup volume.

  • BrianInCalifornia Level 1 Level 1 (10 points)

    I had the same issue. I plugged in my Time Machine drive and it never changed to the blue-green Time Machine icon. (Prior to upgrading to Mavericks it changed in seconds.) What was worse, it wasn't making backups. For example, if the next backup was scheduled for 5:30 p.m. when that time arrived nothing happened.

     

    I tried rebooting but the icon would not change and it would not backup even if I selected Back Up Now from the menu. I went into Time Machine preferences and it said "Unknown" next to Oldest backup and Latest backup. After experimenting and recalling that I had a similar problem when I upgraded from Leopard to Snow Leopard I came up (i.e., reconstructed) with the following solution.

     

    1. Click the Systems Preferences icon in the Dock.
    2. Click Time Machine.
    3. Click Select Disk. If you're having the same problem as I did under "Backup Disks" it had the correct blue-green Time Machine icon. Under "Available Disks," however, my Time Machine disk had the orange FireWire icon.
    4. If your Time Machine disk does not have the blue-green Time Machine icon like mine did select it and then click Use Disk.

     

    I then went to the menu bar clicked the Time Machine icon and selected Back Up Now and it worked just like before. However, that first post Mavericks backup took almost an hour. (I have read that some post upgrade backups take hours.)

     

    A now a word of caution: before trying this definitely try rebooting as ssls6 suggested. Also, check your Time Machine preferences. It should look something like this:

    Screen Shot 2013-12-28 at 6.11.50 AM.png

    If you have dates and/or times for oldest and latest backups (I did not not) then my steps aren't necessary for you. Also, here's what I get now when I click Select Disk:

    Screen Shot 2013-12-28 at 5.53.08 AM.png

    As I mentioned above I had different icons under Backup Disks and Available Disks even though they had the same name.

     

    Hope this helps!