13 Replies Latest reply: Apr 9, 2014 4:38 AM by Cags23
swanhg Level 1 (0 points)

I just upgraded to mavericks and now safari doesn't startup. In the dock it is runing, but I can't select it in the finder window. i can force quit it, but after several startups, and checking software update it will not start up. Anypone else haver this issue?

iMac, OS X Mavericks (10.9), Safari not working
  • youruiner Level 1 (0 points)

    My only problem with Safari on Mavericks is that I can't use the address bar to visit any sites, haha. The application starts up bit it's acting weird. I can however visit sites from my reading list

  • jvhester Level 1 (0 points)

    I'm having the same problem on a mid 2010 13" MacBook Pro. Luckily I already have Chrome installed.

  • swanhg Level 1 (0 points)

    I repaired permissiomns and now is fixed

  • jvhester Level 1 (0 points)

    This only worked for me to an extent. I'm able to enter one address in the address bar, but once I click on a link within that first website I can no longer use the address bar to visit another site, and am forced to reopen Safari or use a different browser.

  • peterfromnorderstedt Level 1 (0 points)


    what exactly did you do? Do mind sharing your procedere here?

  • jvhester Level 1 (0 points)

    To repair disk permissions, search for Disk Utility in Spotlight and open it, select the HD (typically Macintosh HD), and click repair disk permissions. But this didn't fix everything for me, as you can see in my post above.

  • asjk Level 1 (15 points)

    I had a problem with Safari and the trackpad. It wouldn't accept pinch and zoom motions and when I tried to <swipe> to a previous page it sort of half-froze. The page would give just the slightest visual feedback of going to the previous page and then the page wouldn't update. The odd thing is that the title bar would show the name of the previous page but the same image of the original page would still be seen.

    Permission fixes with a reboot solved the issue and there were only a few things that were fixed. Java script, I believe, and Ruby I think were among them.

  • enarwpg Level 1 (0 points)

    Well the permissions thing may have worked Swanhg but I had the same problem as you ie. " enter one address in the address bar, but once I click on a link within that first website I can no longer use the address bar to visit another site, and am forced to reopen Safari ".


    My problem began right after I upgraded Java. I had a WD My Cloud app that would allow me to access my MyBookLive drive from anywhere outside my home. It required Java, which I thought was installed. Guess it wasn't because the app kept saying "plugin missing". I went to the Java site, downloaded and installed it because I wanted to test out the remote access of MyBookLive with a web browser. *


    Right after that Safari didn't work properly, Opera didn't work properly, side swiping didn't work, the App Store didn't work properly including . But because I just got Java workiing I thought what the **** it has to be Java. I uninstalled Java, rebooted and so far so good.


    I'll try installing Java again but in any case, crap like this should not be happening.....



    btw, you have to shut EVERYTHING but Finder down to install Java because if you don't it installs but Safari keeps telling you it's not there. Anyhew....

  • PhilMP Level 1 (0 points)

    The permission repair fix works but only for a day or so.  I am needing to fix permissions daily just to Safari.

  • snowmobile Level 1 (0 points)

    I have the same problem too since upgrading to Maverick.

    1) Can't access the address bar

    2) In the TOP LIST page when clicking on the an icon of a web page, nothing happens

    3) When I open Sarafi Preferences and then I want to shut it by pressing the red X, Nothing happens


    I tried everything I saw in this thread, repair permission, java installation/Upgrade, Switching to Chrome as a default and back again to Safari, deleting the safari .plist in Library, restarting Safari while pressing the shift key.


    Nothing has worked. It is extremely frustrating. I upgraded many macbooks and Imacs and never had this problem except on this macbook 13"/2010.

  • unburden1 Level 1 (0 points)

    Yes, weird.  Since upgrading to Mavericks,

    Safari will Not load Gmail.  Otherwise, far

    as I can tell, Safari is working fine for me.

    I'm using it now for this post & I have not

    observed other issues with Safari in Mavericks.


    I use a late 2012 15" macbook pro.


    Message was edited by: unburden1

  • James Donnelly1 Level 1 (25 points)

    I've stopped using Safari. Too many crashes. It also freezes on buttons that are supposed to open menus on a myriad of sites. It is very, very slow at times. Lots of other browsers that work fast and well.


    I am surprised that Apple's browser is the least compatible with Mavericks.

  • Cags23 Level 1 (0 points)

    I cured my mac using Mavericks...phew!!!


    Used a combination of methods cited on a few forums.


    1. Finder > Macintosh HD > Applications > Right click on Safari > (Contents folder is presented)


    2. Drag and Drop Contents folder into the trash and verify Admin password > OK


    3. Attempt to open Safari (I wont open due to missing content)


    4. Perform a Restart, whilst holding down the 'option' key upon restart


    5. Select Macintosh HD > Reinstall Mavericks OS


    6. Takes a few hours, but it will effectively reinstall a clean version of safari.....and away you go!!