Skip navigation

GarageBand 10.0 crashes

8925 Views 81 Replies Latest reply: Jan 23, 2014 8:30 AM by matejkolenic RSS
  • arai_unmht Calculating status...
    Currently Being Moderated
    Oct 27, 2013 1:11 AM (in response to ScottyTheK)

    Hi, same problem here, iMac Mid-2007 Core 2 Duo.

     

    GarageBand 10.0.0 crashes in _DOTLibrary_CBiquadChain_Mono2Double + 231 in com.apple.music.apps.MADSP.

    The function seems to contain SSE 4 operation, but Core 2 Duo T7300 in iMac Mid-2007 does not support SSE 4, and cause crash.

     

    I've already reported this bug in Bug Reporter.

  • léonie Level 8 Level 8 (46,510 points)
    Currently Being Moderated
    Oct 27, 2013 1:50 AM (in response to maskmackay)

    Not only am I getting a crash when I do anything more than a drum track, but now I have no sound in my admin profile. In any profile, GB still crashes. 

    If GarageBand 10 has no sound, baut GarageBand 6.0.5 has, quit GarageBand, log off and on again, and then remove the preferences.

    That brought the sound back for me.

    Open your user Library and remove everything in

    • ~/Library/Containers/com.apple.garageband10/
    • and any files with "com.apple.garageband10" in the name in ~/Library/Preferences

    Then log off and on again, before opening GarageBand again.

     

    To open your hidden User Library, use the Finder's "Go" menu. If you hold down the ⌥-key, "Library" will be shon in the "Go" menu.

     

    As to the crashes - have you checked your custom Audio Units? For me the crashes stopped, after I uninstalled nearly all third party audio units and VST plug-ins from

    • /Library/Audio/Plug-Ins/
    • and the hidden User library ~//Library/Audio/Plug-Ins/

    Apple has posted a knowledge base article, see:

     

    GarageBand for Mac (v10.0):

    Unexpected behavior with Audio Unit plug-ins http://support.apple.com/kb/TS5249

  • handyman282 Calculating status...
    Currently Being Moderated
    Oct 27, 2013 2:22 AM (in response to léonie)

    Excuse my Bad english. My Garageband 10.0 (IMac Mid 2007) crashes every Time, it should Play any Sound (Instrument oder Loop). What about the fact, there are only These Models concerned?

    When i Play a Loop, Third Party AUs Are Not in Action. I have the korg Legacy Digital Edition and it works Fine with Logic Express 9 and Maverick.

    I Cannot beliebe, that These third Party AUs are the reason for crashing, When they are Not in Action.

  • léonie Level 8 Level 8 (46,510 points)
    Currently Being Moderated
    Oct 27, 2013 6:31 AM (in response to handyman282)

    As the document shows, that I linked to, the support for some older Audio Units has been deprecated in the new, Mavericks only version GarageBand 10.0.

     

    Unexpected behavior with Audio Unit plug-ins http://support.apple.com/kb/TS5249

     

    Your older plug-ins may still be working perfectly with Logic 9 and Mavericks,

    And even, if you do not use them with GarageBand 10.0 in your current project, their presence may destabilize the application, because GarageBand will scan and setup the available Audio Units.

     

    Check with manufacturer's of your software, if your software is compatible with GargeBand 10.0 and if there is an update for older software.

     

    You can test for yourself, if plug-ins are causing the crashes on your system by temporarily removing all plug-ins from the installation libraries to a folder outside the Library and then restarting the system. For me, the crashes stopped immediately after I removed a certain 32bit VST plug-in and updated Melodyne to the 2012 version.

     

    My Garageband 10.0 (IMac Mid 2007) crashes every Time, it should Play any Sound (Instrument oder Loop). What about the fact, there are only These Models concerned?

    There are not only 2007 models crashing, I have also seen reports with respect to mid 2011 models. It certainly looks like there may be a problem with specific hardware platforms, and it is good to know, that the Apple developer are investigating this, but who says, that there is only one reason for the many crashes we are seeing?  When troubleshooting, it helps to narrow down the problem, and to make sure, that no other software is interfering.

     

    I tested yesterday by setting up a new Mavericks installation on a second internal disk with nothing but the new GarageBand added. It worked very well, but as soon as I added my GarageBand 11 plug-ins, the crashes started.

  • maskmackay Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 27, 2013 8:18 AM (in response to léonie)

    leonieDF wrote:

     

    Not only am I getting a crash when I do anything more than a drum track, but now I have no sound in my admin profile. In any profile, GB still crashes. 

    If GarageBand 10 has no sound, baut GarageBand 6.0.5 has, quit GarageBand, log off and on again, and then remove the preferences.

    That brought the sound back for me.

    Open your user Library and remove everything in

    • ~/Library/Containers/com.apple.garageband10/
    • and any files with "com.apple.garageband10" in the name in ~/Library/Preferences

    Then log off and on again, before opening GarageBand again.

     

    To open your hidden User Library, use the Finder's "Go" menu. If you hold down the ⌥-key, "Library" will be shon in the "Go" menu.

     

    As to the crashes - have you checked your custom Audio Units? For me the crashes stopped, after I uninstalled nearly all third party audio units and VST plug-ins from

    • /Library/Audio/Plug-Ins/
    • and the hidden User library ~//Library/Audio/Plug-Ins/

    Apple has posted a knowledge base article, see:

     

    GarageBand for Mac (v10.0):

    Unexpected behavior with Audio Unit plug-ins http://support.apple.com/kb/TS5249

    Okay, I did as suggested and removed all vestiges of GarageBand 10 from both preference folders.  That did indeed fixed the problem of no sound in that account. By the way thank you for the trick on how to get into the user library. So, the problem of no soundIs fixed. Thank you. Even though this was an off title issue.  Problem resolved.

     

    Now to the problem crashing. . . . I went to the folders you specified and I have no plug-ins in those folders at all. Although, I do have some additions to the input and output of my system audio called Sunflower. This works in league with a program called Audio Hijack which I do not use with GarageBand. Maybe this is a problem but shouldn't be. It's never been an issue with any program before and shouldn't be now. I'm open to more suggestions.

  • handyman282 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 27, 2013 8:19 AM (in response to léonie)

    I followed your instructions. Deleted all Plug-Ins both Main Library as User Library (was already empty - all my Plugins were in the Main Library). Restarted Mac - No Effekt :-(

  • léonie Level 8 Level 8 (46,510 points)
    Currently Being Moderated
    Oct 27, 2013 1:59 PM (in response to handyman282)

    Deleted all Plug-Ins both Main Library as User Library (was already empty - all my Plugins were in the Main Library). Restarted Mac - No Effekt :-(

    Then you can put the plug-ins back. I hope you only moved them from the library and did not delete them completely.

    Now you can safely tell Apple that the "unexpected behaviour" in your case cannot be related to plug-ins.

  • léonie Level 8 Level 8 (46,510 points)
    Currently Being Moderated
    Oct 27, 2013 2:10 PM (in response to maskmackay)

    . Although, I do have some additions to the input and output of my system audio called Sunflower

    I have Sunflower and Audio Hijack on my other Mac installed. It does not seem to cause problems, but I#ll check again, just to be sure.

  • handyman282 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 27, 2013 10:12 PM (in response to léonie)

    How can i Tell Apple about my unexpected behavior? The garage Band Support offers no direct contact but this

    Support Community?

  • maskmackay Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 27, 2013 11:18 PM (in response to handyman282)

    handyman282 wrote:

     

    How can i Tell Apple about my unexpected behavior? The garage Band Support offers no direct contact but this

    Support Community?

     

    I believe the address is:  https://ssl.apple.com/support/feedback/  They do read this stuff.  They called me by phone yesterday, umselisited.   They said they're working on GB but are swamped by OS X 10.9 right now.

  • léonie Level 8 Level 8 (46,510 points)
    Currently Being Moderated
    Oct 27, 2013 11:37 PM (in response to handyman282)

    The feedback form for GarageBand is

     

    http://www.apple.com/feedback/garageband.html.

     

    Set the feedback type to "Bug Report".

  • Dannyjack68 Calculating status...
    Currently Being Moderated
    Oct 28, 2013 7:39 PM (in response to ScottyTheK)

    Hi-

     

    My GB won't even open after downloading Mav and the new Ver of GB. All I get is a pinwheel. I'm on a Imac Mid 2007.  Suffice to say, older GB recordings won't open. Ran Disk util and found nothing.

    Thanks

  • kerrja Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 31, 2013 10:49 PM (in response to Dannyjack68)

    Garageband is unusable. I have never experienced anything like this, even on windows. It crashes if you even lookat it too hard.

    Apple, we expect better.

  • kerrja Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 31, 2013 10:53 PM (in response to handyman282)

    Same here. No effect, it crashes at will. Totally useless. I am hoping that the idiot Presonus Studio one will work as I have nothing else since Mavericks killed Cubase.

  • kerrja Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 31, 2013 10:57 PM (in response to léonie)

    Thanks

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.