Previous 1 2 3 Next 39 Replies Latest reply: Jun 7, 2014 10:36 AM by MoonDogg98
nodavid Level 1 Level 1 (0 points)

I have a three monitor set up. I've always had the upper right corner (far right screen) designated as a Hot Corner to start the screen saver. Since upgrading to Mavericks, the hot crner doesnt seem to work. Setting is still the same in the prefs, but the screen saver won't turn on.

 

I think I saw that hot corners are supposed to be the corner of the active monitor, but this doesn't seem to work either...and doesn't really lend itself to my old behavior of throwing the cursor to the extreme upper right as I leave my desk to lock my computer.

 

Any thoughts?

 

TIA,

/david


Mac Pro, OS X Mavericks (10.9)
  • cbs20 Level 4 Level 4 (2,780 points)

    Remove your hot corner settings and then set them up again. If that doesn't solve the problem then you may need to delete a plist file somewhere, but I'm not sure what one.

  • matthewatkins Level 1 Level 1 (0 points)

    I'm having the same issues and tried this fix. It did help for a few minutes and they my hot coners quit working again.

  • nodavid Level 1 Level 1 (0 points)

    cbs20, Thanks for the hint, but that didn't seem to work for me.

     

    Weird that it came and went for matthewwatkins....

  • darkfreq Level 1 Level 1 (0 points)

    +1 having this problem as well. Did the suggested fix and it's still working but not sure for how long.

  • Justin Paul Reese Level 5 Level 5 (4,235 points)

    I've confirmed this as well, despite changing settings, deleting plist files, and restarting the Mac.

     

    The hot corners appears to not work.

     

    The only thing is just to set your screen saver to turn on after a minute. I often use hot corners to lock the Mac up when I need to leave the workstation.

     

    I believe this is a bug.

  • callumbrickwall Level 1 Level 1 (0 points)

    My problem is pretty similiar, I have the top right set to sleep display.. However, Since the Mavericks update it completely restarts the Mac. - No idea why.. I agree with Justin, seems to be a bug - for now I've set the display to sleep automatically after a minute, Thats the only thing I can suggest, To start the screen-saver automatically.

     

     

    Best of luck.

  • pboosten Level 1 Level 1 (0 points)

    I've noticed that no Screen Saver process (daemon/whatever) is running since I updated Maverick.

     

    (ps ax | grep -i screen)

     

    How do I start this process, and how do I make it start automatically after restart?

     

    Or is it not supposed to be running?

  • iClint_ Level 1 Level 1 (5 points)

    I think the screensaver is just broken.  I've not been able to get mine to come on when I lock my Mac and it used to come on instantly.  The only way I have made it run is by clicking the "preview" button.

     

    Honestly, I'm getting tired of bugs like these in new releases.  Used to things just worked.  Now I upgrade to iOS7 to instantly discover background image scaling is broken.  Now, I upgrade to Mavericks and in moments discover the screen saver is busted. 

     

    I mean, are they even testing this stuff anymore?

  • justinfromvenice Level 1 Level 1 (0 points)

    Same here. Hot corners are not working for me.

  • niccodeamus Level 1 Level 1 (5 points)

    screen saver is broken for me, hot corners work (except for screen saver corner)

  • Eric Root Level 8 Level 8 (37,085 points)

    Send Apple feedback. They won't answer, but at least will know there is a problem. If enough people send feedback, it may get the problem solved sooner.


    Feedback

  • pboosten Level 1 Level 1 (0 points)

    It works for me now... what I all did:

     

    1. removed ~/Library/Caches/com.apple.preferencepanes.cache (as suggested somewhere)

    2. removed ~/Library/Caches/<a subdirectory with ScreenSaver in it - cannot remember the correct name>

    3. reboot

    4. set the Screen Saver to time out after 1 minute

    5. let it time out

     

    After that the Hot Corner worked again

     

    Peter

  • niccodeamus Level 1 Level 1 (5 points)

    mine has fixed itself. 

    I changed the timer in screen saver settings from 5 minutes to one minute and waited.  it cut in on time and the hot corner now works for the screen saver.  i have changed the timer back to where i like it and the hot corner still works

  • justinfromvenice Level 1 Level 1 (0 points)

    niccodeamus wrote:

     

    mine has fixed itself. 

    I changed the timer in screen saver settings from 5 minutes to one minute and waited.  it cut in on time and the hot corner now works for the screen saver.  i have changed the timer back to where i like it and the hot corner still works

     

    This worked for me

Previous 1 2 3 Next