9 Replies Latest reply: Nov 13, 2013 10:09 AM by Reece1605 Branched to a new discussion.
Soroshd Level 1 (0 points)



I updated to Safari 7 yesterday and everything is just perfect, but I have just one problem: when I open a new tab it opens Top sites and this exactly what I want, but when I hit Cmd-T (new tab) it takes literarly 3 seconds before the new tabs loads and I can use it. It even has a small glitch. I want to keep Top sites as my new tab, becasue I find it very usefull this way.


I was wondering if anybody else has experienced the same problem as me? And is there a solution for this?

MacBook Pro, Mac OS X (10.7.2)
  • Soroshd Level 1 (0 points)

    I think that I have found the solution. Reseting Safari and restarting my Macbook did the job!

  • michaelb1234 Level 1 (10 points)

    I am having the same problem and restarting does not help. You should note that the 3 second delay only occurs when you start a new tab from a state of having no tabs. i.e. opening the 3rd tab seems smooth because safari has already drawn the tab area. Also this seems to be a problem when working in full screen mode. Try to see if you get the same problem under these conditions.

  • michaelb1234 Level 1 (10 points)

    The solution for me is to Show Tab Bar from the View menu. This keeps the tab bar open even with no tabs (or a single tab open.) This way Safari doesn't hav to draw the tab bar upon opening a new 2nd tab. The 3 second delay is due to Safari drawing the tab bar when working in full screen mode.

  • Soroshd Level 1 (0 points)

    Yes exactly. After reseting and restarting it worked faster for a litle time. But I clearly see that Safari takes time to draw the tab area for the first time (full screen mode). And after opening a third tab and so on, it goes fine and smooth. I gues that it is a small bug that Apple still must fix. Anyway, thanks for your help!

  • cultavix Level 1 (0 points)

    If you go into preferences you can select an option to open up a blank tab. I find this much better... I know its not a solution but a workaround if you simply want to get rid of this lag everything you open a new tab.

  • alexsant@aol.com Level 1 (15 points)

    It must be a glitch. I have tried resetting Safari, restored Mavericks and played with every Safari setting but it did not help. One interesting thing I noticed is when I booted up from an external hard drive, Safari works flawlessly. Tabs open smoothly and there is no lag loading top site pages. Another thing is that when I type the URL of one of the pages from the top sites in a blank page there is no lag when loading up. Will keep trying.

  • marioeg Level 1 (0 points)

    This is the fix:


    On the top sites screen select 'Bookmars' instead of 'Shared Links' on the sidebar tabs and keep it like that. Apparently Twitter takes some time to get its data which causes the lag.

  • alexsant@aol.com Level 1 (15 points)

    Hi Marioeg,


    Thank you for your input. I don't have "shared links" and do not use Twitter. I don't think that that is the case. I will keep trying some other options. It is annoying the way the pages load from the top site window.

  • Reece1605 Level 1 (0 points)

    I can back this up as definitely the thing to do.


    I changed my sidebar selection from 'Shared Links' to 'Boomarks' and the delay no longer happens.

    Its defiitely fetching the info from Twitter thats causing the annoying delay.


    Its a shame, because the only reason I like the Sidebar is for all the twitter results


    At least no delay now that its either turned off, or something other than shared links is selected.