1 Reply Latest reply: Oct 23, 2013 9:00 AM by mende1
NeddySeagoon Level 1 Level 1 (5 points)

Hi,

 

My MacBook Air has a processor speed of 1.7 and Mavericks needs 1.86.

 

All other requirements are okay.

 

Will Mavericks work for me?

 

Cheers

  • mende1 Level 10 Level 10 (90,705 points)

    If you have a Late 2008 or newer MacBook Air, you can run OS X Mavericks. Open  > About this Mac, and check which OS X version you have.

     

    If it's 10.6.8 or later, open the Mac App Store and download OS X Mavericks for free. The Mac App Store won't let you download it if your computer is not compatible. Make a backup of your files with Time Machine and check that your apps are compatible > http://www.roaringapps.com