Previous 1 2 3 4 5 6 Next 82 Replies Latest reply: Jan 7, 2014 1:55 AM by healeydave Go to original post
  • Austin Sloat Level 2 Level 2

    For another data point, most of our clients (10.9, 10.8.x, iOS 7,  and iOS 6.x) cannot connect to server 3.0 after the upgrade on L2TP; however, for some clients the upgrade did not change the ability to connect at all.  I work remotely and am the most frequent user and my iMac and connection was unaffected.  Our setup is a Mac mini behind a AEBS with a single Comcast fixed business IP address.  So far everyone can connect with PPTP once we turned that on and had the server adjust the port on the AEBS.

     

    For L2TP it is clearly not all or nothing.  My iMac is running server as well, but I know of two laptops that were also unaffected by the upgrade -- neither running server and one on ML & one on Mavericks.

  • Matti_A Level 1 Level 1

    Reverting Raccoon worked for me too. 

  • DougP Level 1 Level 1

    I just wanted to say thanks --

     

    I had actually downloaded the ipsec package from opensource.apple.com and had cracked open Xcode to begin investigating how to fix the problem... I guess that's the immediate solution to a problem if software development is your career.

     

    The solution of simply backing out racoon to the Mountain Lion version was too straightforward to occur to me  

     

    Anyhow, I recovered racoon from TIme Machine and my VPN works once again.

     

    Thanks!

  • Bi-noix Level 1 Level 1

    I just reverted to Mountain Lion version of racoon and it works...

    Definitely worth updating to the 16€ Mavericks Server.

  • eribble Level 2 Level 2

    Yep, reverting back works here also.  Although, I still can't connect via port 311 and check the status of my server.  Guessing it's another Mavericks bug as the same config worked under ML Server.

     

    Anyone else here able to connect via port 311?

  • Jim Putnam Level 1 Level 1

    This word for me.  Thanks!

  • Emilio Graveran Level 1 Level 1

    Can someone refer me to some information as to how to revert back to ML's version of Racoon?

     

    Thanks!

  • grumpytorpor Level 1 Level 1

    You'll need to copy /usr/sbin/racoon on ML to the same location on your Mavericks computer. overwriting the Mavericks racoon.  Owner and group need to remain root:wheel.  After the copy, restart.  Assuming your configuration is correct, the VPN should begin working as expected.

  • Sasha S Level 1 Level 1

    Your mileage may vary.  It didn't work the bunch of times I tried with one of my servers.  Congrats to everyone who can get it working without having to wait for an update from Apple.

  • keg55 Level 6 Level 6
    expertise.macosx
    Mac OS X

    To be clear, one needs a non-Server version of racoon from a Mountain Lion machine. Using racoon from an ML OS X Server 2.2.2 machine will not work.

     

    When I used an ML OS X Server 2.2.2 racoon version, it did not work. But, when I restored racoon from an ML machine not running OS X Server 2.2.2, external VPN worked. Like others I could VPN internally using the IP address, but not externally using my DynDNS host name, until now.

  • deKay 01 Level 1 Level 1

    I realise this thread is about Mavericks SERVER, but I notice a lot of people saying that port forwarding and connecting to their Mac via the internet (for VPN or whatever) is no longer working.

     

    I have a similar issue and thing that something to do with the firewall in Mavericks is broken:

     

    https://discussions.apple.com/thread/5538960

     

    I see some posts about turning off the adaptive firewall. How would I do that? I presume it's not the same as the firewall in Security & Privacy? That's off anyway.

  • Sasha S Level 1 Level 1

    Server 3.0.1 is out and claims to only fix Profile Manager migration issues.  The good news is, it didn't re-break VPN.  The strange thing is, the first time I did an ls -la |grep racoon from /usr/sbin/ , it listed the 2179648 Nov 1 version of the file.

     

    After running "cd /usr/sbin | ls -la |grep racoon" again...  it was reporting the 1279276 Mar 11 2013 racoon version again.

     

    Regardless, the update didn't seem to break the temporary fix for VPN.  I've been connected via an LTE tethered connection for the last 14 minutes.

  • Jim Putnam Level 1 Level 1

    Phew! But amazing that this wasn't fixed.

  • strangetpwn Level 1 Level 1

    Although the release notes for Server 3.0.1 don't mention VPN, the update has fixed the problem. I can now connect to the VPN from an external network - confirmed with iPhone 5 (iOS 7.0.3) and MBPr (OSX 10.9).

     

    I never tried the fix to roll-back racoon, and my version of racoon after the server update is still from Oct 23 which is the date I went from ML Server to Mavericks.

  • Sasha S Level 1 Level 1

    Out of curiosity, what file size do you have for /usr/sbin/racoon ?