Previous 1 2 3 4 5 6 Next 82 Replies Latest reply: Jan 7, 2014 1:55 AM by healeydave Go to original post
  • laundry bleach Level 5 (6,925 points)

    Looks like there is a VPN Update for OS X Server that just came out. It requires OS X 10.9.1. Installing it myself now.


    Good luck to everyone.

  • xxMACxx Level 1 (5 points)

    FINALLY!  Installed and VPN now works!

  • bobgeo Level 1 (25 points)

    Yes, agree, this latest patch fixed it. I had two folks test it externally, and all is good. I even went as far as turning off PPTP on the server gui and they were both able to connect in with the L2TP protocol.


    I am running standard Mavericks 10.9.1 with server 3.01 and the new VPN patch that was just released (no Mountain Lion Raccoon transplant).


    All good now!

  • fseyler Level 1 (0 points)

    Amazing......TKS.....FINALLY WORK!!!!!!

  • eidur Level 1 (0 points)

    did not fix my vpn problem

  • healeydave Level 1 (0 points)

    The VPN specific update didn't fix my problem nor did the Server 3.0.2 update released 6th January.


    I have my router configured to forward VPN requests via UDP on port 1701 and requests via TCP on port 1723 to my server. To be thorough, I've also tried port 1701 on TCP as well.


    I have my VPN in server 3.0.2 set to accept both L2TP & PPTP connections.


    I have deleted and re-created the VPN service on my iPhone 5S verifying the username and secret key are identical to the server settings.


    Strangely on the iPhone, it seems the only way to switch between L2TP or PPTP, is to make a change in the VPN screen for that specific tab and then hit the save button, rather un-authordox I think!


    If I make a change to the PPTP page in the VPN settings screen on the iPhone (which seems to be the way you switch to using PPTP), wwhen I try to connect, I get the following error in the Server VPN log:


    Tue Jan  7 09:26:54 2014 : DSAccessControl plugin: User 'vpnaccess' authorized for access

    Tue Jan  7 09:26:54 2014 : sent [CCP ConfReq id=0x1 <mppe +H -M +S -L -D -C>]

    Tue Jan  7 09:26:54 2014 : rcvd [IPCP ConfReq id=0x1 <addr> <ms-dns1> <ms-dns3>]

    Tue Jan  7 09:26:54 2014 : sent [IPCP TermAck id=0x1]

    Tue Jan  7 09:26:54 2014 : rcvd [LCP ProtRej id=0x2 80 fd 01 01 00 0a 12 06 01 00 00 40]

    Tue Jan  7 09:26:54 2014 : MPPE required but peer negotiation failed

    Tue Jan  7 09:26:54 2014 : sent [LCP TermReq id=0x2 "MPPE required but peer negotiation failed"]

    Tue Jan  7 09:26:54 2014 : Connection terminated.



    If I make a change in the L2TP page in the VPN settings screen on the iPhone (which seems to be the way you switch to using L2TP instead), I don't get any connection detail at all show up in the Server VPN log, as-if the L2TP requests are not making it to the server!?

  • healeydave Level 1 (0 points)

    Ah, this always happens to me.


    Within seconds of posting the last message, I made one other change on my router that I hadn't tried before.


    I set port 1723 to both accept connections via TCP/UDP and it worked.


    I do think that its now only PPTP thats working, I suspect L2TP is still deaf but at least I can VPN back in to my home.

  • healeydave Level 1 (0 points)

    ...... and within seconds of posting my last post, I now have L2TP also working :-)


    I have now created 2 x profiles on my iPhone, one called "Home PPTP" and one called "Home L2TP", that way I know to only adjust settings on the relevent tab in each profile.

    That's just better housekeeping though.


    What got L2TP working was creating port forwards on my router for 3 x L2TP connections. All ports are setup to use TCP/UDP but I required 3 ports for L2TP, 500, 1701 & 4500. I already had 1701 setup, so I'm assuming Mavericks VPN uses one of the other ports. I could take it further and systematically drop each of those 3 ports to see which (if any) arn't required be I can't be bothered, I'm just glad its working again.

Previous 1 2 3 4 5 6 Next