Previous 1 2 3 4 Next 48 Replies Latest reply: Jan 13, 2014 4:10 PM by smokesJSP Go to original post
  • Rahuld01 Level 1 (0 points)

    Hi Pahu,


    THanks a lot for the help..


    Dear All concerned facing this problem,


    Just follow the method that PAHU has given. I am mentioning the steps once again for everyones convenience.

    1. Delete the old printer from System Preferences > Printers and Scanners.

    2. Download the DMG file for fresh driver for Mac OS 10.9 from your printer manufacturer's website.

    3. Install the driver.

    4. Add a new printer from System Preferences > Printers and Scanners

    5. In case of network printers, add the IP address of printer, select LPD in protocol, Under "Use" section, go to select software and select your printer's software.

    6. Remember all these years you were selecting the UFR II version of the driver. For e.g. if you were using Canon iR 2018 printer, the earlier driver was Canon iR 2018 UFR II. Do not select the UFR II instead select Canon iR 2018 only.

    7. The driver is installed and ready to use.


    Cheers and Happy printing on Mavericks!!



  • Krisnj Level 1 (0 points)

    This did not work for me I still cannot connect to the printer after the install?  Please help.

  • Krisnj Level 1 (0 points)

    I followed the suggestions and it still didn't work.

  • PAHU Level 6 (15,930 points)

    If you followed Rahul's step by step instruction above then you should be able to print, assuming you have a Canon imageRUNNER copier.


    Since it is not working for you, please open System Information (Applications > Utilities) and select the Printers entry. Then select your Canon iR in the top right list. The bottom right pane will show information about the printer queue. Please copy and paste that information back here for me to check.

  • Krisnj Level 1 (0 points)

    Screen Shot 2013-10-30 at 4.19.45 PM.png


    I had to use a driver to set it up because I needed to print today and the PPD Canon IR C3380/C4580 is the only one that worked, however I still don't have the use of all the options I had before I updated to Mavericks.

  • PAHU Level 6 (15,930 points)

    Krisnj wrote:


    however I still don't have the use of all the options I had before I updated to Mavericks.

    If you mean finishing options then open Printers & Scanners, select the Canon and then click on Options & Supplies. Then select the Utility tab and click on Open Printer Utility. This will open the UFRII Printer Utility. Here you will see the Printer Information button. Press it. This will connect to the copier and show what accessories are installed. Press the OK button close this window and then Quit the utility. Now the driver should have the finishing settings.

  • Krisnj Level 1 (0 points)

    It is still not correct the printer only has two hole punch capability based on the options and no stapler.  All those were available before I updated.

  • PAHU Level 6 (15,930 points)

    Well then you can manually update the driver by opening Printers & Scanners, select the Canon in the Printers list and then click on Options & Supplies. Then select the Options tab and select what options are installed. OK the changes and then see if you have the stapling and other finishing options you had previously.

  • Krisnj Level 1 (0 points)

    Screen Shot 2013-11-01 at 9.45.21 AM.png


    The Finisher isn't correct.  I should have the option for Saddle Finisher Y2


    Screen Shot 2013-11-01 at 9.46.32 AM.png


    The puncher should have the option for three hole punch (Puncher Unit M1)


    Screen Shot 2013-11-01 at 9.47.32 AM.png


    The Paper drawers aren't the same the first is from my machine the second is from another in the office with the correct driver.


    Screen Shot 2013-11-01 at 9.50.54 AM.png

    Screen shot 2013-11-01 at 9.49.16 AM.png

  • PAHU Level 6 (15,930 points)

    Krisnj wrote:


    The Finisher isn't correct.  I should have the option for Saddle Finisher Y2


    Screen Shot 2013-11-01 at 9.46.32 AM.png

    You have the wrong finisher because you selected the wrong model.


    For the "one in the office that is working" you have shown they are using the iRC2880/3380 PPD for the older UFR2 driver.


    For your Mac, you have shown from the System Information > Printers that you have selected the iRC3880/4580. This is a different model to the iR C3380 and thus has different accessories.

  • sbolin Level 1 (0 points)

    I have a similar but weird variation of the problem - I have gone thru the steps listed, but when I "Select Software" I have -no- printers listed at all. So I can't add the proper driver.


    I've deleted my old irc3380 printer, applied the updated driver, but when I go to add the new printer...nothing. Very strange.


    I don't know what Canon does with their drivers, but I have problems every time I uprgrade the OS. Our office HP and Xerox printers have no problems, and usually I don't even update the drivers - they work as expected.


    Now when a new OS comes out I just search the discussion threads for PAHU, cause I know he will likely have the anwser.

  • PAHU Level 6 (15,930 points)

    Your symptom can occur if the Printers and Scanners preference pane was open when you ran the driver installer. Restarting the Mac resolves this symptom.

  • sbolin Level 1 (0 points)

    Yea, finally works. After reboot saw the list of printers, but oddly the 2380/3380 (non-URF) kept coming up as a generic printer. Don't know why. Deleted and added several times before it finally worked. Thanks for the help!

  • EliasKuk Level 1 (0 points)

    After installing Mavericks i cannot print anymore on my network printer.

    The printer has connected to a Windows XP pc, i see it under settings Windows printer but when i launch a print the printer goes into pause state. The message i see is "unable to connect to printer".

    I had this connection since Snow Leopard > Mountain Lion and it has always worked.

    MacBook Pro, OS X Mavericks (10.9)

  • PAHU Level 6 (15,930 points)

    Something has changed with Mavericks and it's ability to print via Windows XP shares. There is no issue for Mavericks when printing via a Windows 7 and Windows 8 share, but with the printer shared by WinXP the 10.9 Mac is getting RPC errors, as shown in the cups error log.


    D [05/Nov/2013:14:01:44 +1100] [Job 16] rpc_open_printer: RPC error 0x16c9a060

    D [05/Nov/2013:14:01:44 +1100] [Job 16] RpcOpenPrinterEx returned 0xc002001d!


    And this in turn results in the smb backend failing


    D [05/Nov/2013:14:01:44 +1100] [Job 16] smb backend (PID=427) stopped with status 256

    D [05/Nov/2013:14:01:44 +1100] [Job 16] smb backend will exit with status 1

    D [05/Nov/2013:14:01:44 +1100] [Job 16] PID 422 (/usr/libexec/cups/backend/smb) stopped with status 1.

    I [05/Nov/2013:14:01:44 +1100] [Job 16] Backend returned status 1 (failed)


    With the end of WinXP support in April 2014, I'm not sure how much effort Apple will commit to resolving this. It may prove easier to update the XP PC to a newer OS or get a printer that has its own network port - either WiFi or Ethernet - so that you don't have to share it from a PC.