Previous 1 2 3 Next 117 Replies Latest reply: Mar 30, 2015 6:42 PM by polocanada
alvarofromm Level 1 Level 1 (0 points)

Hi, after installing Mavericks there's a new process 'com.apple.IconServicesAgent' in Activity Monitor using 165Mb of RAM.

 

Anyone has any idea what it is?

 

Thanks in advance


MacBook Pro, OS X Mavericks (10.9)
  • Zakalwe Level 1 Level 1 (70 points)

    It is using 285MB on my machine...the second largest memory-hogging proces after kernel_task (freshly booted).

  • namyap Level 1 Level 1 (0 points)

    I have the same problem.

     

    Mine is using 99% Cpu and around 200 MB Ram!

     

    been like this for the past three hours

     

     

    Thanks

    MacBook Pro, OS X Mavericks (10.9)

  • punkinmood Level 1 Level 1 (0 points)

    Same here. Mid 2010 MBP with 4GB RAM.

     

    Mine hovers around 130-200MB. I wonder what it is & why it is consuming so much RAM? 

  • jyp371 Level 1 Level 1 (0 points)

    Hi,

     

    I have the same problem.

     

    Mine is using 374 MB of RAM.

     

    Mac mini

    Late 2012

    2,6 GHz Intel Core i7

    16 Go 1600 MHz DDR3

     

     

     


     


     


  • WarrenO Level 1 Level 1 (10 points)

    Same. I actually have two copies running, one at about 300 MB, the other at 200. Kernel_task is around a gig.

     

    Now I'd seen a post elsewhere (http://67.227.255.239/forum/showthread.php?p=87072616) suggesting that they'll get smaller when 'memory compression' is fully active … but I don't know what that means, and it's been since, what, yesterday…

  • marcopriz Level 1 Level 1 (0 points)

    Same here!!!

  • namyap Level 1 Level 1 (0 points)

    Mine is back to normal. After couple of restarts and two days gone after installing Mavericks, everything is back to normal.

  • mtburda Level 1 Level 1 (0 points)

    I've got the same problem, when I enter some folders I don't have any icons, I can't see my files and the process is running wild...

  • fortbailey Level 1 Level 1 (15 points)

    Found this thread through a Google search, as my com.apple.iconservicesagent was also going nuts in the same way as described. I don't know exactly why it was doing so, but I did have an interesting observation.

     

    Several hours ago, I tried to use the drag-and-drop method of creating an alias -- I was trying to make an alias of this file to the desktop:

     

    /System/Library/CoreServices/Applications/Network Utility.app

     

    When I tried, nothing appeared to happen. So I drag-and-dropped again. Still nothing. I figured it was a 10.9 bug and decided to move on to other things, including being away from my computer for several hours. When I returned, I found my MacBook Air fans on high rotation. I checked the Activity Monitor and found this process had 3 hours of CPU time, and was running at something like 98%. I killed it -- and the moment I did, two aliases to Network Utility appeared on my desktop!

     

    Still not sure why it happened, but there appears to be a direct connection between the two events.

  • iMuser.supersic Level 1 Level 1 (0 points)

    I have the same problem.. it takes 95-115% of cpu and makes it go up to 95°C.. So pesky

  • macfanta Level 1 Level 1 (10 points)

    mine using 344MB of RAM... only lose memory usagefor kernel_task

  • macfanta Level 1 Level 1 (10 points)

    I discovered it's some app start on login related...

     

    probably all of us had upgraded OS X Maverick, not a clean installed one.

     

    Can you confirm us?

     

    The IconServicesAgent is now using only 21.4MB of memory after I disabled some apps from "Login Itens"

     

    - KeyRemap4MacBook

    - Moon

     

    I opened both apps now and the resources is the same 21.4MB, without changes.

     

    ##### TESTED

     

    Yes, it works for me.

     

    Go to Preferences > Users & Groups > Login Itens

     

    Note and disable some apps: select with cursor and click on "-"

     

    Reboot and look at Activity Monitor if the procedure was successful.

     

    Open the app you disabled from startup and look if it changes the memory/cpu usage.

  • fortbailey Level 1 Level 1 (15 points)

    Nope, I did a clean install of 10.9 -- erased the whole hard drive, reinstalled everything from scratch. I have nothing particularly odd in my login items -- iTunes Helper, Messages, Twitterific and SMARTReporter.

     

    Aside from the one time I reported earlier, I haven't seen this problem since. In case at least, I'm pretty sure it was connected to my drag-and-drop alias creation.

  • WarrenO Level 1 Level 1 (10 points)

    Nonononononono.

     

    This is not Windows. We do not format and reinstall when we upgrade, or when a program seems to be having trouble running all of a sudden.

     

    This is peculiar behavior. How peculiar? My X.9 install was atop my X.8, which was migrated from a Mini running X.7, which had X.6 upgraded from it, which was X.5 before that on an even older Mini, migrated from an iBook G3 that had X.4 all the way down to X.2. (Seriously. I have passwords in my keychain to Web sites I haven't visited in more than half a decade.)

     

    This is a very, very old legacy-install machine that's been effectively running the same OS, more or less contiguously, since 2004 or so, with very solid reliability — even when the processor architecture was Motorola based, not Intel — and I've never had a serious problem with migration or updates, certainly not so serious that I've ever had to format and reinstall. I have never had to format and reinstall, in nearly ten years.

     

    (This is why I like both Mac and UNIX, which are basically the same at their core; they are rock solid, better than 90% of the time, in my experience.)

     

    No. X.9 has a problem that's been introduced with com.apple.IconServicesAgent. It should not be occupying a quarter gig of RAM, and should not be spawned in more than one process under any circumstance — it's apparently a core system process, not a user-executed series of instances.

     

    If I had to guess — actually, I do have to guess — I'd suppose the process is involved entirely in loading icon previews and drawing them to screen. I've a feeling, if that's the case, that it's trying to cache all icon data from all apps and files everywhere on the hard drive at once, on the off chance that any one random icon might have to render to screen. But of course it doesn't have to do that, since the odds that you'll want all icons showing at once are zero. (There are typically a quarter of a million files on a clean OSX install with your basic suite of Apple apps on top of that; that is a lot of files with a lot of icons.)

     

    My surmise is that someone overlooked that one thing; someone failed to notice that it's trying to keep a live cache of all icons simultaneously. I think we'll be seeing a change in its behavior with X.9.0.1 or thereabouts.

     

    Anyway. If anyone from Apple (or any third-party company, such as @dobe) suggests — in any troubleshooting context — that you should make a new user account, or format and reinstall, feel free to laugh at them and tell them to turn to Page Two of their 'user problem tech support script' book. This is the 21st century. We do not format and reinstall. We deal with the problem by finding it and killing it, always nondestructively to user data.

Previous 1 2 3 Next