Previous 1 2 Next 19 Replies Latest reply: Jan 14, 2014 1:53 PM by El Pezley
El Pezley Level 1 Level 1

I'm experiencing real problems with Aperture 3.5, so I hope someone can help.


When double clicking images I end up with a damaged file that looks like it is composed of several recently viewed images.


I have also clicked an image in a project, then gone to another project, clicked another completely different thumbnail, only for the previous image to appear and continue to appear!


This is UNGOOD!!Screen Shot 2013-10-23 at 23.09.36.jpg

Solved by William Lloyd on Oct 23, 2013 2:24 PM Solved

You tried "reprocess from original?"


Also are these on images that formerly were fine, or on newly imported images?  A defective card reader or bad memory card can cause problems like this.

Reply by crayboy on Oct 25, 2013 10:40 AM Helpful

It is the Radeon.

I moved my displays to the NVIDEA GeForce 8800 GT - no better.

I then removed the ATI Radeon HD 5770 - problem fixed. Well, not fixed, but identified!.

Reply by midiotlv on Dec 20, 2013 12:34 PM Helpful

Interestingly enough, I just moved both monitors to the same card (the ATI Radeon 5770) and Aperture works fine.   So, for me anyway, it seems that having the 2 monitors on separate cards is the issue (I haven't tried running both on the GT 120).   I guess I'll run like this until they have a patch (if they ever discover/fix this).  I've left feedback with Apple.

All replies

  • El Pezley Level 1 Level 1

    By the way I have rebuilt the databases, zapped RAM, repaired disk permissions and disks, tried different libraries and so on...


    So far, no luck.

  • William Lloyd Level 7 Level 7

    You tried "reprocess from original?"


    Also are these on images that formerly were fine, or on newly imported images?  A defective card reader or bad memory card can cause problems like this.

  • Clem Level 3 Level 3

    EP - what is your machine type, and where are the images/lib stored?

  • El Pezley Level 1 Level 1

    @ William @Clem


    Thank you both for your interest.


    I had tried to reprocess from the original, but it does not solve the problem.


    The images have always been fine and have been stored on this soft RAID, outside of Aperture without previous trouble.


    I am using a 2008 Mac Pro with 8GB of RAM and about 10TB of internal storage on HDD. My system is on a 128GB SSD. Yesterday I updated Mavericks and Aperture and that's when my problems began.


    I've always followed the updates closely and have never experienced something like this before.


    Somebody from the Apple team contacted me, so I am providing them with further infor to see if they can reproduce the problem...


    There seems to be carry over/memory from one image to another.


    If I zoom around the image, it clears up and I can see the photo clearly. When I return to the default viewing size, I get this effect.


    However, if I view a video (no problem), when I next go to a photo, the image that appears is pure white...


    Or, as is now the case, no matter which image I open, the default setting shows a photo from another project (undamaged).


    If I want to see the image connected to the thumbnail I have to zoom around first...


    Not sure if any of the above sounds familiar to you, but that's pretty mu much it.


    Thanks again!




  • El Pezley Level 1 Level 1

    Having had contact with Apple, the issue seems to be connected to the updated RAW fine tuning brick in the adjustments.


    Reprocessiing that way resolves the problem for now, on an image by image basis.


    Will update once more is known...

  • El Pezley Level 1 Level 1

    @William Lloyd:


    I could have sworn I reprocessed the original, but was unaware they had a new RAW engine, so maybe I just tried regenerating the thumbnail. Not sure how I missed that. So you were on the money and my answer was not correct this morning.


    So, I just found the Batch Reprocess with the New Aperture RAW File Engine (or something to that effect) menu.


    Looks like it's gonna take 15 minutes for each 10K of images.


    Thanks again!

  • El Pezley Level 1 Level 1

    I crowed too soon...


    Just finished the batch rebuild and the problem persists, which is probably why my previous effort failed too.


    With the individual button in Adjustments, it seems the result is more effective.


    Not sure though.


    Thanks anyway!

  • crayboy Level 1 Level 1

    I have the exact same issue, so following this in case there is a resolution.

    I have tried repairing and rebuilding the library. Deleting aperture ( including prefs/support files) and reinstalling. Reprocessing.

    Zoomed, picture is fine.

    Using iPhoto - pictures are fine.

    Also a 2008 Mac Pro.

    I have two graphics cards ATI Radeon HD 5770 and NVIDEA GeForce 8800 GT ( Both original Apple cards) - going to try swapping/pulling them see if that has any effect.

  • crayboy Level 1 Level 1

    It is the Radeon.

    I moved my displays to the NVIDEA GeForce 8800 GT - no better.

    I then removed the ATI Radeon HD 5770 - problem fixed. Well, not fixed, but identified!.

  • El Pezley Level 1 Level 1

    Hey Crayboy,


    I'd tested the same way you did, but skipped the last part as it was so late yesterday... But you're right, it works!! Thanks!!


    I read somewhere that the Radeon's don't play as nicely with UNIX as the NVIDIA's and that Apple has renamed their Kext files in Mavericks, or something to that effect. Some overclockers seem to know how to flash the BIOS on these cards, but it's beyond me.


    Instead I have to put up with what feels like an underpowered NVIDIA GeForce GT 120, but at least it works... And THAT is a bloody great relief.

    Not sure what card to put in the Mac Pro instead of the Radeon (some say the buses on the Early 2008 machines are too slow to reap much benefit from these cards, but my machine was faster with full res multi monitor support)


    Maybe I'll be able to find someone who can change the Device ID's so that Mac recognizes my HD6870, for now and evermore, regardless of which OS they release.


    It's a bit long in the tooth, but I'm reluctant to let it go as I've got it stuffed with goodies...


    Anyway thanks for taking the time to post, it got me on to the problem. Cheers!

  • Tom Lebsack Level 1 Level 1

    For what it's worth, I have a Radeon HD 5770 in my Mac Pro (2x2.8 GHz Quad Xenon model, 8GB RAM) and just upgraded to Mavericks and Aperture 3.5. Not having this problem, thank goodness. (I am having the NIK-Mavericks problem described on a couple of other threads, though).



  • midiotlv Level 1 Level 1

    I have an early 2008 Mac Pro with a Radeon HD 5770 and a GT 120 -- and I have this same issue (same exact issue...same symptoms/behaviors).   I am thrilled that somebody else has this issue (which means I don't have a failing graphics card -- I hope), and please let me know if I can help be another test-case for Apple support


    Until a fix comes around...I'm checking out Lightroom (just hope something is fixed within 30 days -- that's when my trial period is up). 


    I'm not keen to pull-out my Radeon 5770 to fix, but I would do it to test.



  • William Lloyd Level 7 Level 7

    Apple Support isn't here, and they don't monitor these forums, FWIW.

  • midiotlv Level 1 Level 1

    Yeah, I know (too bad they can't/don't).  I was just offering to be another case if the OP wanted to reference me.

Previous 1 2 Next