Previous 1 3 4 5 6 7 Next 92 Replies Latest reply: Jun 2, 2015 3:49 AM by Lukas Kalinski Go to original post Branched to a new discussion.
  • u352 Level 1 Level 1 (0 points)

    Im having to use other email clients that work. Such as Mail Pilot and Unibox. There is also a problem with smartmail boxes acting wacky. Apple got too big and is acting like microsoft. Half assing everything!

  • reezer69 Level 1 Level 1 (0 points)

    Yes, it is. I have had an escalated long discussion on this issue with Apple and the only option is to wait. It's frustating for me because I use my mailboxes as a file cabinet and it's tax season! Hang in there, I was assured they are working on it.

  • BuelD Level 1 Level 1 (0 points)

    PROBLEM SOLVED ... I hope.


    I just got off the phone with Apple where I shared my screen.  There isn't a problem with indexing or with software per se, but with us users.  Actually, the problem is with Apple tryng to be too cute and over-engineering the software, but that's my opinion.


    The Maverick upgrade included a new version of Mail that now parses the searches.  Even though you include "To" or "From", for example, in the search dialogue box, additional buttons above the Mailbox column further categorize your searches.  For example, if I search a person with "To", but have the "Draft" button clicked, the search shows nothing.  What's even more confusing is that these buttons only appear when you search so users may not even notice them.

  • crowdsourced Level 1 Level 1 (0 points)

    I may not be having the same issue as your are, or I'm just misunderstanding. In my case, I test by knowing I have emails form a particular person in an email account's mailbox. I go to search that name (e.g., Chris), and in the dropdown it shows the names and addresses of all the Chris's I know. It shows them!


    But then I select one, in this case a Chris I just received an email from. then puts From: Chris BlahBlahBlah in the box, searches, and finds NO RESULTS!


    And I'm looking on the left side of the window and can see that I'm in the correct "search" option. It shows it's searching that email account's inbox. The same one in which I can see the email from Chris BlahBlahBlah, after I empty out the search box.


    It's craaaaaaaazy. And the scenario you describe doesn't apply to my case. So I'm still saerchless.

  • BuelD Level 1 Level 1 (0 points)

    Same scenario for me so I did the following with the tech watching my screen and it worked.  Hopefully for you too.


    1. click on your Inbox

    2. search From:Chris as you did before

    3. now look above the mailbox & message list, in the gray area, and click on "All"


    Your message should now appear in the list.  If you click on other buttons, it may disappear.  Good luck!

  • crowdsourced Level 1 Level 1 (0 points)

    Thanks for the directions, but still no joy.


    1) Clicked on Inbox in Mailboxes Pane

    2) Enter "Chris" into search box

    3) Selected correct one from dropdown, so that From: email address appears in search box

    4) "Search: All" was already highlighted in blue

    5) No results.


    In my earlier post, I followed this same path, except that I clicked on the correct "sub" mailbox for the particular account I wanted to serach (rather than the "Inbox"), and it finds nothing.


    It always "Found 0 matches for search."

  • Michael Neale Level 1 Level 1 (0 points)

    Yes, I especially like it when you are just looking directly at a message from "Chris" and then it, and the other 100's of messages from Chris all disappear when you search for "Chris" - either in "all of message" or in "from", and either in "All" or in the folder you were just looking at.


    Come on, Apple, you are better than this!  It's not a little issue, it's a major bug in the core functionality of the Mail app which is core functionality of many users of Mavericks.  Time to fix it.

  • BuelD Level 1 Level 1 (0 points)

    I encourage y'all to call Apple and talk to a support supervisor.  After reading the last 2 responses, I'm not confident the problem was solved for me and I expect it will reemerge.  However, Apple thinks it's resolved and I don't believe they pay close attention to these threads.  They were polite, but they clearly thought the problem was with the user (me) and they need to be goaded into writing a patch.

  • HIJNX Level 1 Level 1 (0 points)

    I've always done that and with Mavericks it just doesn't work.


    This should have been fixed already.

  • DenisKlimenko Level 1 Level 1 (0 points)

    This problem was introduced with the release of the Mavericks.




    Search not works only in the mail client.

    Was trying to help me here:


  • reezer69 Level 1 Level 1 (0 points)

    I am happy for you that your problem was a mere oversight, but in my case and many cases on this thread it is much more than that. I wish it was my overlooking the simple cause of mailbox selection for a search. I too did the apple support thing, and it was determened that it was a known issue Apple is working on and the solution is to wait for them to solve it.

  • DenisKlimenko Level 1 Level 1 (0 points)

    Here are just a 10.9.3 working on graphic problems. About a problem with the email did not say.

  • KarlBundy Level 1 Level 1 (0 points)

    I have the same problem that I have no searching, and I am watching this thread for a possible solution.


    However is it possible to delete the mail and and reinstall it..?? would this solve the problem.

  • cmbond99 Level 1 Level 1 (0 points)

    Thank you.  This finally worked for me.  Just a couple notes,  I updated to 10.9.2 and just reindexing the mail folder  didn't work for me. I had to reindex my whole hard drive and that finally did it.

    defghik wrote:


    I fixed it by reindexing via spotlight. I followed the indexing instructions at this link:


    And the only folder I dragged in was the Mail folder from my Home directory. (Home Directory/Library/Mail).


    Thank you so much for your help Miska_FL! Hopefully that will help someone else having a similar problem.


    Thank you for the indexing tip NHC2365! That put me on the right track. Jaydisk, maybe you can try the same thing I did...

  • Tony Geers Level 1 Level 1 (25 points)

    Sadly, that doesn't work for me. I've tried re-indexing just (~/Library/Mail) and my entire disk at least twice. I've also experimented with safe mode as previously suggested. Mail Search, Flagged, VIPs, Smart Mailboxes, none of those things work.

Previous 1 3 4 5 6 7 Next