Previous 1 32 33 34 35 36 Next 601 Replies Latest reply: Sep 18, 2014 1:43 PM by dubi Go to original post Branched to a new discussion.
  • TeddyIsSam Level 1 Level 1 (0 points)

    I fully agreed with you. This is my first Mac machine. I was very excited as it was a Christmas gift. Now I felt very frustrated along with the journey for countless reinstallation of OS X and Windows on Bootcamp. It was not fun at all. And it eat up lots of precious holiday time.

     

    I had a chat with AppleCare yesterday and surprisingly the officer told me I am the FIRST one to complain this problem!!!!! I told them many of us had such painful experience and I shared the link to the officier. The officer redirected me to local service provider(Singapore) to perform the installation today. There is charge involved and AppleCare will help me to pay the charges(SGD100+). I have highlighted to the officer that I can only accept the fact that the installation is going thru Bootcamp and no other work arround is required. If this is not the case, the officer will help feedback to their engineer team.

     

    It does not make sense we should go through such painful process to get it working. Should Bootcamp be designed to support windows? If there is any compability issue, should Apple work with Microsoft to sort it out?

     

    Please voice it out to AppleCare to get more attention on the issue.

  • iampastwitsend Level 1 Level 1 (0 points)

    I managed to get Windows 8 installed.  Managed to get it updated to Windows 8.1 too, which is where I was stuck before.  Not entirely sure about what it was that I did differently.  I started with a plan to do an MBR installation of Windows 8, then update to 8.1, then to convert the MBR install to an EFI install.  When I tried that though, my keyboard / trackpad didn't work once I got to the personalzation portions of the Windows 8 installation.  Since that failed, I tried just to do the manual conversion of the Windows 8 MBR installation to EFI, thinking that might have something to do with why the keyboard / trackpad wasn't working.  Well, in the EFI boot following the EFI conversion, the trackpad and keyboard still didn't work.  An external mouse and keyboard didn't work either (connected via USB).  So I deleted the Bootcamp partition, started up Boot Camp Assistant again, set up the Windows partition, put the USB stick in a different port, and then tried the installation again.  Just sort of had a feeling it might work... and it did.  All that being said, I think this is a bad approach to solving the problem.  It's an Apple issue that Apple needs to solve, even if it requires technical assistance from Microsoft.  I dabbled with the installation off and on for about month.  Did the instalation enough times that I have my product key memorized.

     

    Please raise the issue with Apple so they devote the necessary resources to get the Boot Camp installation working without any "special" steps.  There are three or four days of my life that I want back....

  • Number88 Level 3 Level 3 (750 points)

    So which installation do you have? EFI or CSM bios?

  • iampastwitsend Level 1 Level 1 (0 points)

    EFI, I think.  Did it via the EFI installer.

  • iampastwitsend Level 1 Level 1 (0 points)

    Okay... now confirmed.  BIOS mode is UEFI.

  • Number88 Level 3 Level 3 (750 points)

    Thanks, and you setup the partition with Bootcamp?

  • iampastwitsend Level 1 Level 1 (0 points)

    With my final and successful attempt, I did set up the partition with Bootcamp.  To be clear though too, I've done it multiple ways -- i.e., creating the partition with Bootcamp, creating the partititon with Diskutil, creating space for the partition with Diskutil -- but then creating the parition and formatting with the Windows installer, etc.  At one point, I even wiped Mavericks and then tried doing the Windows installation with nothing else installed.

     

    On the successful attempt, I did use the partition I created with Bootcamp, without doing anything special (e.g., booting around the bootcamp installer to reformat / resize / re-whatever with Diskutil.  I did move my USB stick to a different port though.

     

    I can speculate that starting with the MBR partition, converting it to an EFI partition, then removing the partition, and then doing the EFI installation is the way to go -- but honestly, I have no idea -- and I'm not willing to go through the process of doing it again.  I've entirely lost the desire to see what is and what is not reproducible...   Maybe moving the USB stick made a difference too.  I have no idea.

  • iampastwitsend Level 1 Level 1 (0 points)

    Also, I did not clean up the EFI/Boot and EFI/Boot/Microsoft folders at all.  My working theory was that if the bootstore was valid, the installer wouldn't complain.  I never tried to confirm.

  • Number88 Level 3 Level 3 (750 points)

    I understand 

    Maybe if you keep using Bootcamp enough times the odd one will fail to create a hybrid MBR and then an EFI install will run ok    There do seem to be wild variations in people's experiences - even with exactly the same hardware.

     

    As far as converting an installed system from CSM to EFI it does not go particularly well - or it didn't on mine. One of the main problems being the Intel chip being recognised and difficulties with the Nvidia driver.

  • iampastwitsend Level 1 Level 1 (0 points)

    The nice part of what I wound up with is that since I did the EFI installation from start to finish, that I don't have a "mixed" install.  I'm just glad it's working.

  • heavensbow Level 1 Level 1 (0 points)

    Ok i tried everything but still cant go on with installation.No matter what i do it still says there is no right partition to install.

    A EFI Installation starts but stopped at 70% with error so it fails also.

    Now i give up.

    I realy hope there will be a fix soon.

    It is my first MAC and i by it because i can install Windows.

    I want try the MAC System because i like the handling,but i need windows for some Software they only for Windows and i need to work with them.

     

    brand new Macbook Pro Retina 15 512 SSD

  • JC Bond Level 1 Level 1 (0 points)

    If I were you I would try one more thing. Boot into the EFI windows installer. Erase the entire hard drive including the Mac OS Partition. Install windows as if this was a Windows only machine. In my experience this worked all the time. Then once you have windows installed go back and do an internet recovery of the Mac OS. You will loose the windows installation but in my experience doing a boot camp install after a windows only install could work.

  • riseyth Level 1 Level 1 (0 points)

    I had the same problem as everybody else but the key thing that got it working for me last night is running diskpart during before doing the Windows install.

     

    1. When setup comes up, and before you pick a partition to install into, press shift-F10
    2. diskpart
    3. list disk  -  this will show your current disk as a number - let's say it's disk 0 (it may be 1)
    4. select disk 0
    5. list volume  -  this will show the volumes on the disk. Note the volume no of your EFI partition - let's say it's 2
    6. select volume 2
    7. assign letter=B
    8. exit

     

    This worked with a normal BootCamp partition setup using a USB drive plugged into the left USB port.  Doing this also enabled it to work after completely erasing the drive using Disk Utility, so it would create the EFI partition, and deleting the one HFS+ partition it created, so I could put BOOTCAMP at the beginning of the drive.

     

    I ended up getting BitLocker working for the Windows partition and FileVault working for the OS X partiion, but I installed Windows first so it could do what it liked and then using 'gpt' created a HFS+ volume.  It appears that Disk Utility doesn't like the partition map that Windows creates containing the "Microsoft reserved partition", because its partitions are not separated by 128 MB, see https://developer.apple.com/library/mac/technotes/tn2166/_index.html, so I ended up using gpt to create a HFS+ volume at the end and then used Disk Utility to erase/format it.


  • IgorL Level 1 Level 1 (0 points)

    I have same problem.

    Tried to install Windows 8 and Windows 8.1 with original full version (non-upgrade) ISOs from Microsoft MSDN via Bootcamp Assistant & USB.

     

    Install always dies at the very end with "Windows could not update the computer's boot configuration. Installation cannot proceed".

    Also tried unsuccessfully other provided solutions on this Apple support Communities.

     

    riseyth can you clarifay your procedure.

    "1. When setup comes up " Window set up? If yes shift-F10 open cmd window. Diskpart command in cmd window?

    4. Only USB instalation has EFI Boot. To assign letter on USB disk?

     

    Would you be sokind to clarifay your procedure in more details.

  • riseyth Level 1 Level 1 (0 points)

    For 1), yes, windows setup.  Press shift-F10 as soon as the first setup window appears.  It just matters to do it before the install starts.  And yes, diskpart in the cmd window.

     

    For 4), no.  When you get or reformat the disk in a current Mac, the disk has a hidden partition named "EFI" at the front.  This partition needs to be assigned a unique letter, normally B.  Here's my partiton map, you need to assign "B" to the EFI one.

     

    $ diskutil list

    /dev/disk0

       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:      GUID_partition_scheme                        *500.3 GB   disk0

       1:                        EFI EFI                     209.7 MB   disk0s1

       2:         Microsoft Reserved                         134.2 MB   disk0s2

       3:       Microsoft Basic Data                         171.3 GB   disk0s3

       4: DE94BBA4-06D1-4D40-A16A-BFD50179D6AC               314.6 MB   disk0s4

       5:          Apple_CoreStorage                         327.5 GB   disk0s5

       6:                 Apple_Boot Recovery HD             650.0 MB   disk0s6

     

     

    gpt show /dev/disk0

          start       size  index  contents

              0          1         PMBR

              1          1         Pri GPT header

              2         32         Pri GPT table

             34          6        

             40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B

         409640       2008        

         411648     262144      2  GPT part - E3C9E316-0B5C-4DB8-817D-F92DF00215AE

         673792  334667776      3  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7

      335341568     614400      4  GPT part - DE94BBA4-06D1-4D40-A16A-BFD50179D6AC

      335955968     262144        

      336218112  639617368      5  GPT part - 53746F72-6167-11AA-AA11-00306543ECAC

      975835480    1269544      6  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC

      977105024          3        

      977105027         32         Sec GPT table

      977105059          1         Sec GPT header

Previous 1 32 33 34 35 36 Next