Previous 1 2 3 4 5 Next 102 Replies Latest reply: Sep 25, 2014 8:24 AM by Cyberfed Go to original post
  • professoreucalyptus Level 1 (0 points)

    I too have spent the last three days trying to back up my ibook to a LaCie Rugged 500G portable external hard drive. I had no problem with this at all for at least a year under Mountain Lion, but have not been able to back up at all under Mavericks. I have repaired my iBook's hard disk. I have reformatted the LaCie external disk. I have restarted in safe mode. I have restarted in repair mode. I have about 97 gigabytes to back up. Twice it got almost to the end (about 90 gigabytes, with plenty of room on the drive) and stopped backing up at all. I am at the point of just giving up on time machine and just backing up everything by hand, as I did in the old days.

  • alaz0 Level 1 (5 points)

    Started on a fully reformatted new disk for Time Machine.  Went away from home for four days.  Came back to find that in four days, Time Machine under Mavericks backed up 26.6 GB out of 465.9 GB.  At this rate, it will take Time Machine 70 days to do a single full backup. 


    Not making much progress around here.  It's now getting around 2 weeks with no backups.


    Apple, this is clearly a Mavericks problem.  Would you be kind enough to comment?

  • pvmikev1 Level 1 (0 points)

    I have exactly your problem.   It worked fine for a while, and now gets stuck in "Preparing Backup" and never does the backup any more.

  • professoreucalyptus Level 1 (0 points)

    Well, I just kept starting it to backup again and again, and after a few days it finally got over whatever the problem was, and now seems to be working normally for the moment. But what I did that fixed it, except the obvious things, I don't know. I did keep looking at the console as it was backing up, and it kept complaining about using too many resources. But I don't really know what that was all about.

  • professoreucalyptus Level 1 (0 points)

    The last thing I did, and maybe (but maybe not) what made the difference, was I went to the preferences pane for time machine, clicked "choose disk" and chose the disk I was already using. It started a new backup from scratch. But after a couple of stall-outs finally did finish it, very slowly.

  • pvmikev1 Level 1 (0 points)

    I tried the same thing, starting backups and starting backups and finally after about a 3 hour wait it did a 10GB backup OK.   Then after that,  it seems to be coming back to normal.


    Don't know why.   But patience for 3hours seemed to do the trick.   I don't know how long this will last, but it seems to be working for now.

  • alaz0 Level 1 (5 points)

    Tried to use Time Machine to an Iomega NAS.  Same problem.  Checked the WD website, they have upgraded firmware for their newer drives.  Mine are 17 months old and don't seem to be listed with new firmware.....  I tried to e-mail support, but my ancient, 17 month old drives aren't even listed anymore.  I will call them tomorrow when they are open.  What about my older WD USB dirves? 


    No one from Apple nor WD seems to pay any attention to this forum.  So, how do we get this major problem fixed?

  • Olssman Level 1 (0 points)

    I had the issue that it never got past the Preparing back up after upgrading to Mavericks that some of you describes. I deleted the time time machine preference file as described here by pondini: and when i tried again the preparing face took just 2-3 min and the backup is going at normal speed. Maybe that helps some of you. And thanks to Pondini for the info.

  • wagnerhans Level 1 (0 points)

    I have upgraded my MacBook Air (2011 model) and my iMac (2009) model to Mavericks recently. Since this upgrade neither machine will back-up correctly under time machine. I use several different WD drives (My Book 1 & 2 TB, my passport 1 TB) and both machines backed up (and restored) without any problems before the upgrade. Now, when I enter Time Machine Preferences I see the active back-up announcing 5 sec remaining (after more than 24 hours since starting the back-up) and this has not changed in several hours. I also see all the other issues described by other contributors ("preparing for back-up" for hours, unbelievably slow transfer rates ~ 1.6 GB/24h).

    I find it hard to believe that Apple have not resolved this problem yet. This kind of nonsense used to happen regularly with Windows but never with Apple.

    I have no intention to lose my previous back-ups or to re-install the OS.

    I have also not been impressed by WD support. I had a compatibility issue between WD software and OS X 10.8 which blocked the use of an external superdrive. Apple support correctly identified the problem and supplied a solution (remove all WD software from the machine). When I asked for help from WD they blamed Apple and refused to help. Interesting approach to customer support. I know which external disks to avoid in future.

    I would be really grateful if somebopdy could come up with

    - the cause of these problems

    - a simple way to fix it not involving losing back-ups or re-installing OS X

  • lightcable Level 1 (0 points)

    I had similar problem on my rMBP 2012 after upgrading to Mavericks. Then I checked Console and found out Spotlight complained "PM mdworkder: (Warning) Import: Bad path:". Then I googled and found out Spotlight had problem to index my exFAT formatted sd-card that I mounted in the sd-card slot. As soon as I excluded the sd-card from Spotlight. Time Machine started working.



  • alaz0 Level 1 (5 points)

    TRY THIS -- there may be a write permission problem on the "Macintosh HD" from the "upgrade"


    Right click your "Macintosh HD" -> click "Get Info".  At the bottom, check "Sharing and Permissions".  I noticed that my username was not on the list, and only "system" had write privileges.  "Wheel" and "'everyone" had only read privileges.  (I don't know how to find who is in the "wheel" group).  If you're not on the list, click the lock on the bottom right and open it with your password.  Then, click "+" at the bottom left and in the pop-up, you should see your username; click on it -> "Select".  It should be added to you "Sharing and Permissions" list.  Your Privilege will probably show up as "Read only".  Click on the privilege and select "Read & Write".


    Doing this, my Time Machine ia at least dong something, albeit slowly; but less slowly than before.  Let me know what you find.

  • alaz0 Level 1 (5 points)

    From the last two posts, it seems that some combination of permissions, spotlight and Time Machine is causing problems?

  • Bilalama Level 1 (0 points)

    Deleting "" and reselecting my external backup drive through Time Machine Preferences thereafter (as suggested in the link you posted) worked great! Time Machine on my MacBook Pro now works as it did before I upgraded to Maverick. Thanks for posting this link!

  • wagnerhans Level 1 (0 points)

    Thanks for all the updates. Unfortunately, while the tips posted worked for my MBA + WD Passport +USB, they did not resolve the issues with my iMAC +WD MYBOOK +FW800.

    I repaired the permissions, removed the external disks from TM, deleted the plist file, renamed the external drives, removed all WD related software, restarted the computer and added the re-named external disks to TM.


    - spotlight still taking forever to re-index

    - 'preparing to backup' message showing for three hours with any progress for one of the external disks, the second one says 'waiting to back up'.

    Fortunately, as I am retired and do not need my machines for critical business purposes I can live with this situation, albeit grudgingly. God help all the poor people who have based critical business processes on Apple Mac computers and now find they cannot back-up their files.

    When I was CIO of a medium-sized organisation, having re-introduced Macs against a lot of resistance, this could have cost me my job.

    I have contacted Apple support and they claim not to be aware of the problem and are asking me to carry out all sorts of (silly) tests.

  • lightcable Level 1 (0 points)

    I am sorry to hear that. It seems it is FW800 related? Apple is dumping FW to Thunderbolt. I suppose they didn't  run enough serious tests on FW devices. Time Machine is a critical software. This allows Mac users to upgrade from an old to a new Mac w/ a simple click (I did it four times and love it!). I am not aware Windows offering similar function because Microsoft doesn't control  hardware. If Apple didn't do right for Time Machine, this would scare off many  users (new and old) including those CIOs like you who want to re-introduce Mac to the companies.


    By the way, I've never gotten incremental backup working on the pre-Maverick backup. I had to start a new backup using a different partition in my NAS.

Previous 1 2 3 4 5 Next