Previous 1 2 3 4 5 6 7 Next 102 Replies Latest reply: Sep 25, 2014 8:24 AM by Cyberfed Go to original post
  • Protagonist Level 1 Level 1 (30 points)

    FYI, a few years back there was a little know problem with WD drives on the Apple FW connections. I ran into it on my system. It was my information that WD knew about it but was in no hurry to fix it because it effected a very small percentage of users. That is when I started replacing all my WD drives and I have not had the problem reoccur since I got rid of them. As I recall it had something to do with WD drives not waking up properly when they went to sleep on a FW connection.

     

    What I am saying here is that I am not going to be too quick to put all the blame on Apple here. From what I have read there seems to be a few third party applications that are also tied to this TM backup problem. I don't think Apple is going to be able to put out a magic bullet that is going to cure everyones problem.

  • alaz0 Level 1 Level 1 (5 points)

    Many good points in this thread and another active one on the same topic.  As a result, I have made good progress. 

     

    Norton:  As some others, I have Norton Anti-Virus (I had a scare some time ago, that turned out unwarranted, but I left Norton in my system anyway).  The "idle time scan" is a killer:  the internal drive is going non-stop, it kills performance, and it does not track in Activity Monitor properly.  Once I turned it off, it took an hour os so for my desktop hard drive to settle down, two long backups with Time Machine to get it settled down and its databases fixed (TM does this).  TM now runs almost normally over Fire Wire to my Western Digital drive.  Norton has had this slow down problem ever since Symantic bought them; it's been 10 or 20 years now.  MacOS probably does not need it.

     

    Western Digital:  I removed the WD Drive Manager, as recommended by WD.  My drive is still under warranty, and I am waiting for a firmware and Drive Manager update.  It may or may not help.  My discussions with WD tech support have been quick, to the point, ahd helpful.  They are trying to fix their part of this problem.

     

    Mavericks:  Despite the problems with Norton and Western Digitial, my desktop ran just fine under Mountain Lion.  With exactly the same configuration, Mavericks generated all kinds of problems.  Time Machine ground to a halt, and several applicaitons routinely crashed; now it's rare.  While points have been made about Apple having a poor response and defended as having reasonable response, Apple's big problem here really based on no response to these threads.  Consequently, we were all left with guessing what Apple's role is.  It seems to me that Mavericks is not much of an upgrade; I really don't see much of a difference from Mountain Lion except that everything runs slower than before.  (Personally, I really don't like the IOS7 icon art -- it looks like the cheesy icons we used to create on our own in the 80's when we used 300 and 1200 baud modems.)  I would like Apple to provide better debugging information to active users, such as all in this forum -- that would help a lot.

     

    Bottom Line:  Some of us have made progress, others haven't, all have spent a huge amount of frustrating time working on this.  There is a significant systemic problem here that is not fully resolved yet.  Apple really needs to evaluate such problems and contribute to significant problem threads, such as this one.  Apple owns the forums, they really should read and react to the major ones -- and this is a major one.

     

    For what it's worth.

  • Creeper74 Level 2 Level 2 (360 points)

    Great link, Olssman!  As soon as I added myself back to the access list for the boot OS X drive, the TM job started running at normal speed.  I didn't even have to stop the job that was running and start a new one.  Thanks for the find!

  • tbirdvet Level 4 Level 4 (2,370 points)

    I spoke too soon.  After having TM run fine a few days I noticed it started to say"preparing to backup" and it was this way for over an hour.  When I tried to go into TM it showed no backups.  I had to dismount the drive, restart and had to wait 10 minutes before it would show the backups again.  Something weird is happening and it must be Mavericks related because I made no changes from ML that could have any impact.

  • DeckerEgo Level 1 Level 1 (0 points)

    I had this exact same issue... even down to the model of backup drive. After the Mavricks update backups ran fine for a few days, then was stuck in "Preparing backup..."

     

    I did a repair disk for both the MacBook Pro's SSD as well as the external drive, but perpetually got the "Preparing backup..." status. I removed the external drive from Time Machine, wiped the backup drive clean, re-formatted and even re-partitioned the drive. I let it run for 16 hours after this with no luck.

     

    I noticed that the metadata indexing services were perpetually running, at times with 100% utilization, causing timeout errors, etc. It appeared that every time I re-connected the external (USB 3) WD 1TB drive Spotlight would hammer the living snot out of it performing indexing operations, even if the drive was empty.

     

    The thing that finally fixed it for me was that I added the backup drive as an exlusion to Spotlight. Going to System Preferences -> Spotlight -> Privacy I added the external drive to the "Prevent Spotlight from searching these locations" list. Once I did that I re-started the machine and forced a Time Machine backup. After about 2 hours, the initial backup was completed.

     

    Just like everyone else is noting in previous posts, it appears Spotlight is saturating the I/O to the external drive, causing a perpetual "Preparing backup..." state.

  • donna156 Level 1 Level 1 (10 points)

    Same problem.  I have a WD Passport, but it wasn't plugged in.  My Time Capsule was toasted instead.

  • wagnerhans Level 1 Level 1 (0 points)

    The saga continues. I can only confirm what you have seen. I implemented all the recommended fixes except completely reformating my external disks (I repartinioned them instead and selected the new partion(s) for TM). I also excluded all external disks from Spotlight. Made no difference.

    Looking at system.log I see what is happening, but not why. Every time I start a back-up, spotlight kicks in, spawns lots of mdworker processes which all eventually fail because they reach maximum resources.

    Conclusion: for reasons unknown(to me) Spotlight does not manage to index even the Mac HD and therefore retries every time a back-up starts. Without the index, TM does not know what it has to back-up.

    I have contacted Apple support and the case remains open. Will post update.

  • Malcolm Fuller Level 1 Level 1 (85 points)

    Based on what you see, I'd force Spotlight to reindex your hard drive:

     

    http://support.apple.com/kb/HT2409?viewlocale=en_US&locale=en_US

     

    Let it reindex before you try to use TM.

     

    Also, I'd put your TM drive under Privacy in Spotlight. If  your TM is still being blocked by Sppotlight, put your system drive under privacy. If that gives you a full TM back up, reindex your system drive then and see what happens.

  • tbirdvet Level 4 Level 4 (2,370 points)

    It now appears my TM is working correctly.  I discovered that I had the "put drive to sleep when possible" checked in energy menu.  This appears to be an issue for TM starting backups and my drive would not wake up.  I unchecked the box and now the "preparing to backup" is very quick and the backup starts.  This could be drive/enclosure or USB3 dependent but seems to have fixed my issue (at least for now).

  • pvmikev1 Level 1 Level 1 (0 points)

    For what it's worth,

     

    I also remember turning off the "put drive to sleep when possible" in the energy saver when my TM started

    working again after I was initially having problems.  I hadn't attributed the resolution to that, but you seemed to

    have hit on something.

     

    Thanks tbirdvet!

  • Typhoon92 Level 1 Level 1 (0 points)

    I have tried this solution. As of right now it appears to have solved my issue, Thanks DeckerEgo

     

     

    The thing that finally fixed it for me was that I added the backup drive as an exlusion to Spotlight. Going to System Preferences -> Spotlight -> Privacy I added the external drive to the "Prevent Spotlight from searching these locations" list. Once I did that I re-started the machine and forced a Time Machine backup. After about 2 hours, the initial backup was completed.

  • Alextobias Level 1 Level 1 (0 points)

    Same problem. I do a backup to a time capsule. I tried everything. Erased all files in time capsule, created new folders to do the backup, changed the preferences of the energy safe, tried to backup several times with no sucess. Now it shows it is doing the backup: 22.34 GB. Total size of the backup 223.54 GB. In fact it is showing this status for the last 48 hours. Any idea. For me it's a problem that need to be fixed.

  • PLexxiTronic Level 1 Level 1 (0 points)

    I have a 2TB WD My Passport USB drive connected to my MacBook Air (October 2010). I never installed any of the WD software. The drive has three partitions: 1) Mac OS Extended (Journaled) which will be used exclusively for Time Machine; 2) Windows NT File System (NTFS) which is used exclusively for the Windows 7 backups; and 3) exFAT which is used exclusively for all iTunes files (and this partition is used both on a Macintosh and on a Windows machine where iTunes on either machine can connect to the library on this partition).

     

    I reformatted the partition used for TM, so that I had a "blank "disc. I used the instructions from http://pondini.org/TM/A4.html to get rid of past, residual TM files.

     

    Rebooted. Opened TM preferences. TM was off. Plugged in my 2-TB WD Drive. Chose the Mac partition four TM and TM began backing up. I needed to back up 72.51GB. TM said it would only take three hours and began backing up immediately. HOWEVER, IT STOPPED AT 1.00 GB AND STAYED THAT WAY FOR OVER 24 HOURS.

     

    After reading this blog, I noticed a comment about exFAT drives. TM was still running. I simply ejected the exFAT partition of the drive. TM immediately started continuing the back up from where it left off VERY QUICKLY and it says it will be done and three hours. After running 30 minutes, 47 GB has been backed up and it says only 20 minutes are remaining.

     

    After it is done, I will go back and look at the log files. Especially, I want to see the spotlight log files that talk about exFAT, a format that I very much intend on keeping.

     

    After TM does this, now initial, backup of my machine, I will reindex my computer just for good measure.

     

    I should mention that this drive with its three partitions has worked just fine under the previous operating system – including the exFAT partition. For me and for this upgrade of the OS it looks like that partition has messed me up. I will have to research that further down the line.

  • Alextobias Level 1 Level 1 (0 points)

    I notice I have Norton anti virus. I disable the norton, erase all files in the time capsule, changed the options of the energy safe for never in all options and started a new backup using time machine. Same problem, when it reaches 22.38 GB it stoped... After about 24 hours, I stoped manually the backup and started a new one. I notice it begun apparently at the end of the last one as the size of the backup decrease. But it just reached 22 MB and stoped again. I waited about 24 hours and nothing change.

    Does anyone have any idea?

  • TimPollard Level 1 Level 1 (20 points)

    I had a similar problem after updating from ML to Mavericks. After trying everything suggested above without the problem being resolved, I was advised by a very helpful Apple 2nd line technician to re-index Spotlight WITH TM TURNED OFF AND THE TM DISK UNMOUNTED. I had previously exluded the disk, but turning it off and ejecting the disk before re-indexing fixed the problem. To be safe I also ejected all other drives as well.

     

    Spotlight then re-indexed happily, I re-enabled time machine and plugged in the disk and it was all good.

     

    Hope this helps someone.