Previous 1 2 3 4 Next 113 Replies Latest reply: Aug 3, 2015 10:52 AM by Godiex Go to original post
  • overmac Level 1 Level 1 (0 points)

    I'm having the same issue.

     

    Late 2013 Macbook Pro/Haswell/15in/2.6Ghz/16GB RAM/1TB SSD/Mavericks (fully updated).

     

    Tried to install Windows 8 and Windows 8.1 with original full version (non-upgrade) ISOs from Microsoft MSDN via Bootcamp Assistant & USB.

     

    Install always dies at the very end with "Windows could not update the computer's boot configuration. Installation cannot proceed".

     

    Also tried unsuccessfully:

     

    • Formatting Windows partition with Tuxera NTFS
    • Non-EFI setup (using "Windows" selection in boot manager) - this dies with an error message that the partition is GPT style and can't install on it - also tried deleting/recreating partition, no success


    After some 12 attempts also called Apple Care, who had me reset the entire computer via Internet Recovery, change Partition 1 from GPT to MBR, then back to GPT, recover, and try again.

     

    It's not working, I still get the same error.

  • fireduckzilla Level 1 Level 1 (0 points)

    I find comfort in knowing I'm not the only one experiencing this at the moment.

     

    Late 2013 Macbook Pro/Haswell/15in/2.6Ghz/16GB RAM/512GB SSD/Mavericks

     

    I've tried installing it with the CD (Windows 8) and with an ISO for windows 8.1 - I'm getting the same error.

  • skipsizemore Level 1 Level 1 (0 points)

    SOLVED!

     

    I haven't gotten anything useful back from Apple yet, but I found something on another thread that seemed worth a try. I managed to install Windows 8.0 x64 without any third-party tools or other foolishness. Here are my steps:

     

    1. Use Bootcamp to create EFI-bootable USB drive with the Windows ISO file.

    2. Uninstall any previous installations of Bootcamp, restoring the partition table to one big Apple partitition.

    3. Use Disk Utility in OS X to create empty space of the size I want my Windows partitition to be.

    4. Reboot the machine to the USB drive.

    5. Using the Windows Advanced partition options, create a new partition in the empty space. Windows will also create a small (128 MB or so) partition alongside it.

    6. Format the new partition using the Windows Advanced partition options.

    7. Proceed with installation onto that NTFS partition as before.

    8. Windows 8 installs!

    9. After installation, run the setup.exe inside the Bootcamp folder on the USB drive. This will install all the necessary device drivers.

     

    So, apparently, the problem is the partition created by Bootcamp. Maybe Windows setup wants to create its little extra partition but can't because the disk is fully allocated. I'm not sure, but I am happy to have it working.

     

    I hope that this will work for the rest of you!

  • BrIgNaStY Level 1 Level 1 (0 points)

    Skip...you're the man

  • Brian Kendig Level 2 Level 2 (170 points)

    I tried deleting the Boot Camp partition (and leaving it as empty space), then booting from the Windows 8 DVD ("EFI Boot") and letting the Win8 installer create its own partition there. Still no luck.

  • bdguy Level 1 Level 1 (0 points)

    Yes.  Similar issue with Win7 - get to the point of formatting partition to NTFS and Windows7 installation (via USB Optical drive) stalls.  Also have 1TB drive.  Wondering if anyone has this issue with the 512 drive.  Oddly, on the 1TB machine, when I use disk utilities on the full (unpartitioned) drive, it will not run all the way through the drive.  Need to run twice to get a 'green' conclusion.  Erase history in the verify box, and oddity repeats.  Run verify in succession without erasing and continue to get green.  Nothing like this happens on my 2010 MBP.  May be bootcamp issue, but also something in hardware given the odd behavior of disk utilities.

  • fireduckzilla Level 1 Level 1 (0 points)

    It took some time to get the partitioning right - if it goes wrong, its best to boot into windows installer, and delete (not format) the partions including the one created by windows as a reserve; boot back into OS X and use disk utilitys to extend the partition back to the full extent of the drive and try again.

     

    I followed the instructions linked by skipsizemore and it worked fine (the second time round after I actually included the support software in bootcamp!)

  • spignot2 Level 1 Level 1 (0 points)

    Late 2013 15", fully built, and I was having the same problem. I tried all of these solutions, and nothing was working, including:

     

    Straight bootcamp install, formatting the partition in the windows installer

    Deleting and recreating a new partition in the windows installer (including the creation of the 128 MB partition)

    Erasing the bootcamp partition in Disk Utility and creating the partition in windows installer

    Erasing the bootcamp partition in Disk Utility and reformatting NTFS using Tuxera

     

    I could not get anything to work, so I tried one last time with a straight bootcamp install, with the formatting in the windows installer, but moving the USB I was booting off of from the RIGHT USB port to the LEFT USB port, and it installed perfectly the first time without any issues. I'm not sure if this is a solution, or if I was just lucky, but if nothing else works, you may want to try it.

  • Dan9802 Level 1 Level 1 (0 points)

    Victory! This worked like a charm. Thanks Skip!

     

    Late 2013 15" MBP w/ Retina and NVIDIA.

    Windows 8.1 Pro ISO.

     

    Windows looks gorgeous on this machine.

  • Number88 Level 3 Level 3 (750 points)

    I'm interested in a couple of points.

     

    Firstly I understood that the Windows installer usb created by Bootcamp can not offer the EFI boot option when booted from. None of my BC created installers do.

     

    Secondly, once Bootcamp has partitioned the drive (whether you use that particulur partition or not) a hybrid mbr is created. This in itself should stop the Windows installer from offering the EFI boot option as it should detect that hybrid mbr.

     

    So my main question would be, how are you booting the Windows installer in EFI boot mode (if it was made via the Bootcamp process)?

  • Dan9802 Level 1 Level 1 (0 points)

    First time around I created a USB install stick from a PC, which did not give me an EFI boot option (only Windows boot).

     

    So I started over, and at that point, I simply copied a fresh Windows 8.1 Pro ISO to my MacBook Pro desktop, and then let Bootcamp erase my install stick and create a new one with the fresh ISO.

     

    In terms of the partition, it was simply empty space, rather than a true partition (per the solution above). I let the Windows EFI installer format the empty space for me. In other words, the only thing I used Bootcamp for was to create the Windows USB and add the drivers. 

  • Number88 Level 3 Level 3 (750 points)

    I see, thanks.

    So Bootcamp didn't create your Windows partition. Therefore the hybrid mbr was not created and the installer could offer the EFI boot option.

     

    In other cases above this does not appear to be the case and it makes me wonder whether in newer MBP's Boot Camp now does something differently.

     

    Cheers!

  • classified11 Level 1 Level 1 (0 points)

    i get the same error like before:

     

    "Windows cannot be installed to this disk. The selected disk has an MBR partition table. On EFI systems, Windows can only be installed GPT disks"

     

    Have somone an idea?

  • DYKWIA Level 1 Level 1 (0 points)

    Still not working for me unfortunately.

Previous 1 2 3 4 Next