Previous 1 2 3 4 5 Next 100 Replies Latest reply: Feb 2, 2015 9:46 AM by Anthony Main Go to original post
  • skipsizemore Level 1 Level 1 (0 points)

    I have never seen Windows say that it has to be installed on a GPT, although I have seen the opposite error. I expect that if you use the Windows Installer advanced options to re-create the partition and format it, it will make what it needs.

     

    As for getting the EFI boot option, it showed up for me every time. I created the USB boot disk by using the Disk Utilities in OS X to first create an image of my Windows 8 DVD, then using Bootcamp to create the bootable USB. I disconnected the DVD drive and booted with the USB stick in the right-hand port, and it offered me EFI as an option.

  • Brian Kendig Level 2 Level 2 (170 points)

    I finally got Windows 8 to install on my new Retina MacBook Pro (15", 750M graphics).

     

    What hadn't worked for me: going through the Boot Camp Setup Assistant, setting up a partition then using a Windows 8 Pro DVD to go into the installer. I tried installing to the Boot Camp partition, I tried deleting that partition and letting Windows re-create it; nothing worked

     

    What finally worked for me: I used Disk Utility to create a disk image of the Windows 8 Pro DVD and to convert the .dmg to an ISO. I then used the Boot Camp Setup Assistant to copy that ISO (along with the Boot Camp Windows-side stuff) to a USB flash drive. It rebooted from the flash drive and installed Windows with no problem. I think it was even in EFI mode, because the Windows modals were almost too tiny to read.

     

    Once Windows 8 was installed, I upgraded to 8.1 on the Windows Store. It's all worked fine!

     

    It's really weird that the various solutions work for some people but not others. I think this is some deep, weird, strange problem that's affected by some factors no one's guessed at yet.

  • jarvil Level 1 Level 1 (10 points)

    skipsizemore wrote:

     

    5. Using the Windows Advanced partition options, create a new partition in the empty space. Windows will also create a small (128 MB or so) partition alongside it.

     

    I hope that this will work for the rest of you!

     

    Where are you seeig the Windows Advanced partition option? How are you getting to this pre-installation?

  • skipsizemore Level 1 Level 1 (0 points)

    Hi, jarvil, I am talking about the Advanced options that are available when Windows asks where you want to install it. If I recall correctly, you'll see a list of partitions, and below that an "Advanced" link. Clicking that will let you remove the Bootcamp partition, re-create it, and format it. I'm fuzzy on the details, but I do remember that these were the steps I followed, and that I needed to get to the advanced options.

  • DYKWIA Level 1 Level 1 (0 points)

    I eventually got 8.1 installed by installing Windows 7, upgrading to 8.0, then upgrading to 8.1

     

    Almost a day wasted

  • legaleye300 Level 1 Level 1 (0 points)

    I can't even get to the screen asking about partitions. Once the very first screen pops up after booting off of the thumb drive, my keyboard and mouse do not work. Plugging in a usb mouse doens't work either (mouse doesn't even get power).

     

    Any ideas?

  • Nvius Level 1 Level 1 (0 points)

    I had a similar issue once I had Windows installed and prompted me to Personalize/Set Up Windows.  The issue was that I was using a USB 3.0 stick for my bootable device.  Switching to a USB 2.0 stick solved my problem.  Did not have a problem using my mouse/keyboard for the partitions, but I have a feeling this solution might work for you.

  • legaleye300 Level 1 Level 1 (0 points)

    My USB stick is USB 2.0, not 3.0...

  • Orphaned Gland Level 1 Level 1 (0 points)

    Thought I would add my experience, as I got Windows 8.1 to install with very little trouble.

     

    I have a Windows 8.1 DVD.  I unchecked all options during bootcamp installer except for the last one (to install Windows via DVD), using a USB bluray drive.  I used a USB memory stick as required to hold the boot files, and created the windows partition through bootcamp.

     

    The first attempt to install windows failed, with message that windows is unable to install on the drive.  Upon rebooting machine was stuck at the grey screen.  I rebooted with command-R held down, and ran the disk utility from the menu.  I deleted the partition created to install windows, and did nothing else (no need to resize osx partition).  I rebooted and held down command for boot menu.  From the boot menu I selected EFI.  I repeated the windows install and then created a partition with the empty space.  I left the drive 0 partition 3 (619MB) untouched, and windows created two partitions one of which is 128MB.  Windows 8.1 installation worked without any further problems.

  • legaleye300 Level 1 Level 1 (0 points)

    I'm not even getting that far... When booting from Windows on usb, keyboard/mouse don't work when asking what language I want to install (very first screen when setup begins).

  • peter.y Level 1 Level 1 (0 points)

    After formatting the new partition in the windows setup stage, it wont let me proceed saying that it can't install the content onto this partition...? any chance you have a solution for this as well?

  • skipsizemore Level 1 Level 1 (0 points)

    Hi, peter.y, did you format the partition after you created it? I believe that I had to explicitly tell Windows to format it after it was created. If that doesn't solve your problem then you should post the exact error message you see -- someone has seen it before, I am sure.

  • peter.y Level 1 Level 1 (0 points)

    I've got it to go pass that stage, and it was installing went smoothly until the finishing up stage, where it comes up with the error messages saying... "windows could not update the computer's boot configuration. installation cannot proceed"..!@#$#&*@(

  • Number88 Level 3 Level 3 (750 points)

    That sounds like you booted Windows in EFI mode.

  • cportela Level 1 Level 1 (0 points)

    Thank you for sharing your solution. I followed your instructions to the letter but when it came to completing the installation Windows would give me an error.  I forgot exactly what it was but something about "unable to write to disk or to partition table" or something along those lines. Essentially I had to insert a new item (3a) into your original recipe:

     

    3. Use Disk Utility in OS X to create empty space of the size I want my Windows partition to be.

    3a. Use Disk Utility to create a FAT partition that takes up all of the space left on the disk.

    4. Reboot the machine to the USB drive.

     

    During installation Windows created the 128MB partition all on its own and left the rest for Windows.

     

    My MBP comes with a 1TB SSD and I suspect this is why I had to do this... but I am only speculating.

     

    BTW, I was installing Windows 8.1 Pro.

     

    Thanks!

Previous 1 2 3 4 5 Next