Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: How to fix NTFS-3G on OSX Mavericks?

After upgrade to OSX Mavericks, I get error when I start up:


NTFS-3G could not mount /dev/disk0s4 at /Volumes/BOOTCAMP because the following problem occurred:


/Library/Filesystems/fusefs.fs/Support/fusefs.kext failed to load - (libkern/kext) link error; check the system/kernel logs for errors or try kextutil(8). the MacFUSE file system is not available (71)


I need some help in fixing this error.

MacBook Pro, OS X Mavericks (10.9)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Already solve. Just remove Macfuse and NTFS-3G on your System Preferences.

Posted on

Page content loaded

Oct 29, 2013 11:29 AM in response to Allan Eckert In response to Allan Eckert

Allan,


That "not supported" line seems like a cop out. It's not like there aren't standards. Yes, I know standards can differ by platform and change over time. More is the pity for modern times! In this case, the woe befalls the Apple consumer.


I mean, when was the last time you had to face similar difficulties plugging in your toaster? Why can't plugging in portable drives be as easy? I mean, they are *universal* serial busses (USB), right?!


Just a thought,

Chris

Oct 29, 2013 11:29 AM

Reply Helpful

Nov 15, 2013 12:11 AM in response to Allan Eckert In response to Allan Eckert

Allan Eckert wrote:


You need to discuss that with Microsoft because they are the ones who are forever changing the way NTFS works.


Which could be one of the primary reasons Aple will have nothing to do with NTFS.


Allan

This just seems like FUD to me - if by "forever changing" you mean "last changed in 2001" (v3.1 was released in 2001). Microsoft (at least to my knowledge) hasn't been changing the standard. The real issue is that the internals to either Apple's HFS+ or Microsoft's NTFS are openly available.


I thought this was solved back in 1999 or so when the iMacs could finally read "Windows formatted 3.5" floppies." It seems to have just gotten worse since then though. Unfortunately, the "standards" ChinaGamerGuy above points to are not openly available and hence there is little software (outside of windows) that reads NTFS. Linux supports it (the NTFS-3G code), but I don't think Apple would supply it because the code is GPL'ed.


And they have no motivation to, either. For both Apple and Microsoft it's just another way to provide vendor "lock-in". I wish we could just chose a standard filesystem for all computers (or at least open the standards up) so that we the consumers don't have to deal with this inanity and can just get on with using these system as tools...

Nov 15, 2013 12:11 AM

Reply Helpful

Nov 17, 2013 6:29 AM in response to Capik Rashid In response to Capik Rashid

I have created a script to initialize NTFS HDisks and use them in write mode just by using the native OSX driver, without third party software). It seems to work also under Mavericks. You can download it from:


http://sourceforge.net/projects/native-ntfs-osx/files/


You only need to run it once for each new ntfs disk. Next time you plug a ntfs disk that was alreadyinitialized with my script, the disk will be automatically mounted (however, it will not be displayed in the desktop, you will have to open it from /Volumes).


It is also important that the HD has been safely removed, since NTFS contains a flag to notice if the disk was safely removed or not, not allowing to mount it in write mode with the native OSX driver (something similar happens under Linux). In case it happens you just need to plug it into a windows PC and safely remove the HD (so it cleans that flag).


Hope this is useful to you.

Nov 17, 2013 6:29 AM

Reply Helpful

Nov 20, 2013 12:13 AM in response to Capik Rashid In response to Capik Rashid

hey!

i seem to have the same problem as you - unfortunately simply removing ntfs-3g and macfuse from the system preferences didn't work for me, there is still an error showing up that indicates, that these two programs weren't removed completely:


User uploaded file


how can i resolve this issue and remove all files associated with ntfs-3g and macfuse?

Nov 20, 2013 12:13 AM

Reply Helpful
User profile for user: Capik Rashid

Question: How to fix NTFS-3G on OSX Mavericks?