Previous 1 2 3 4 Next 50 Replies Latest reply: Feb 29, 2016 9:29 AM by ggiannak25 Go to original post
  • Alex White~ Level 1 Level 1

    Well, to update. I installed Gutenprint, as you suggested, then updated to 10.9 and my Printer (ip4000) worked (so far as I can see) as normal. I'm seeing the same Canon printer utility as I did under 10.6.8, so I'm not sure if it using Glutenprint or not? Anyway it all works so, it looks like I don't need a new printer


    Think I might need Vuescan for my Canon scanner though, but that's another matter!

  • heinzgruber Level 1 Level 1

    on my macbook air i started with os x lion and the ip4000 was installed flawlessly. a few month later i got to 10.8 and now 10.9. the printer is still there and working.

    now i ask me if i can extract the driver from my macbook air and the install it on my imac with 10.9? driver is

  • donjerrie Level 1 Level 1


  • Barb333 Level 1 Level 1

    It looks like PAHU's suggestion to download Gutenprint (third post of the thread) didn't help everyone but it did help me so I encourage everyone to give it a try and want to thank PAHU.


    Before that, I had the latest driver available from Canon installed, the printer did work and print but after updating to Mavericks, it printed ok only text but producing prints with lines and deformed colors when printing photos.


    I installed Gutenprint v5.2.9 from this site and did nothing else (not unistalling any driver or anything) and now it works great! I printed a high def photo on photo paper, turned out as good as it used to.

  • Jo! Level 1 Level 1

    I am getting a link to a german page. doesthis matter for the software, or does it work in any language?

  • sukkolowski Level 1 Level 1

    I think it is multilanguage. But you can find the same solution on canon's english page I think.

  • Fn12 Level 1 Level 1

    The PIXMA iP4300 CUPS Printer Driver Ver. (OS X 10.5/10.6/10.7/10.8) from eries/pixma_ip4300#DriversAndSoftware seems to be working.





  • THeyl Level 1 Level 1

    Yes, I have tried and it works pretty good.


    Download the last version of the driver from the Canon website. This is the release for 10.6!

    Once you have the dmg file, right-click and open it, IGNORE the warning, open it up anyways.

    Switch on your printer and make sure it's connected.

    You should be able to see the ink status information now. The printer show up in the list of installed / known printers.


    Restart both your printer and your Mac, and this is it.

    Unfortunately I didn't record it, but it was as simple as that :-|

  • dawglover Level 1 Level 1

    I have just now been able to get my Canon iP4000 printer to work with OS X Mavericks, as follows:


    Downloaded Canon iP4000 driver from


    Used PAHU's tip (control-click on driver's .dmg file, then choose "Open") to force DiskImageMounter to do its magic.


    It's working!


    Thanks to all – and PAHU in particular.

  • jacobgco Level 1 Level 1

    If you go to the Canon driver downloads for iP4200, it determines that you're using Mavericks and tells you there are no drivers for it.  But if you change your OS to 10.7, you can download that driver and install it (using "Open with" -> "Installer") and it works fine on Mavericks.

  • robrandomnumber Level 1 Level 1

    I had this problem with my Canon Pixma ip1700 and I was able to get it working by installing the Apple Canon Driver ( and then telling the Printer Setup dialog that my printer was an ip1800 rather than in ip1700.


    The ip1700 isn't listed in the set of printers supported by this driver, but it seems to work fine anyway.


    It might be worth trying the same with other Pixma printers - install the driver and then try posing as other printers to see if the driver works.

  • ecubed Level 1 Level 1

    I have a MacBook Pro running OS 10.9 and when I connect the Canon Pixima IP 4000 it  works  fine. We purchased a new iMac to replace an old one and the printer will sometimes print one job after startup and then hang.  I downloaded the Gutenprint  5.2.9 driver hoping that would work but I see from the thread that it doesn’t. Do you know the name of the library folder on my MacBook Pro that would hold the driver that is working so I can copy it to the iMac? Or, I still have a Time Machine backup up from the old iMac that I could search also.

  • seppthethreat Level 1 Level 1

    The IP4000 was not working on my new MBP. I tried all the suggested solutions here and non of them was working. But it is working on my old MBA (3 years). Both with the latest OSX (10.9.3). I checked the driver versions on both MBs and they are different.

    To get the printer working on my MBP I copied the IP4000 driver files from the MBA.
    The path is /Library/Printers/PPDs/Contents/Resources.
    The IP4000 is working now on both MBs


    Just let me know if you need the driver files.

  • ecubed Level 1 Level 1

    I tried copying the files you suggested from my MacBook Pro (the printer works with the MacBook) to the iMac but the printer still wouldn't work. I downloaded the lastest version of Guten-Print from Source Forge and that did work. The Pixima IP4000 is working with my iMac running Mavericks.