Previous 1 2 3 4 Next 177 Replies Latest reply: Mar 2, 2014 5:14 PM by Arielsam Go to original post Branched to a new discussion.
  • sukhvinderind Level 1 Level 1

    after updated my iphone 4 to 7.0.3 ios i lost my wifi, its not connected, it showing not connected, please help me

  • sukhvinderind Level 1 Level 1

    same problem with me no wifi connection after updating 7.0.3 ios iphone 4, plz help

  • jon_jg Level 1 Level 1

    I got the same problem after updated 7.0.3 on my Iphone 4.. I've been losing wi-fi signal even when it's working on other devices, and many times cannot connect again.. i've tried turn off / turn on.. reset networking but it seems that wi-fi only works when it wants.. 

  • ellensu Level 1 Level 1

    No recognition of my network password for my wifi on my iphone 5 and mini ipad after I updated with 7.0.3. My other devices, an Iphone 4s and regular Ipad were not updated and they connect to my wifi perfectly. There is something wrong with the update...don't use it. Hope Apple fixes it soon. Two out of 4 devices are useless for wifi.

  • Sharone Abramowitz Level 1 Level 1

    Having the same problem. Mac Air wifi works fine, but ipad since update to 7.0.3 is not working. Apple please fix!

  • zackkl Level 1 Level 1

    try this ; switch the airplane mode on and then connect the wifi , then switch the airplane mode off and the wifi is connected . It works for ME.. i dunno other will work ... sorry for any grammer mistake.. haha

  • Lawrence Finch Level 8 Level 8
    Mac OS X

    You are not talking to Apple, only to other users. Is the problem only with your home WiFi? If so, try resetting your router by removing all power from it for 15 seconds. This will reset the router's ability to assign IP addresses. Your MBA works because it already has an address; the phone needs a new address after updating, and, if the router's DHCP daemon has crashed it can't get one.

  • Moises Rosales Level 1 Level 1

    Same issue here, after the update the wifi range has decreased a lot, i can conect but stand behind the router  ti mustie be an issue with 7.0.3 for sufre.

  • Lawrence Finch Level 8 Level 8
    Mac OS X

    If it was a problem with iOS 7.0.3 the 300 million people who installed it (including me) would all be posting about it. It's a problem with your phone or your router. If it is only one network that has the problem try rebooting the router by removing all power for 15 seconds or so. If it is all networks try Settings/General/Reset - Reset Network Settings.

  • themattconnolly Level 1 Level 1

    I upgrade my OS and now my phone has problems connecting to every wifi network, and you suggest it is the fault of all the routers? I think the volume of complaints on this board suggest it is in fact a significant issue, maybe not impacting 300 million people though. Plenty of people with iphones do not connect to wifi, and not everyone has enough free time to complain on a message board like us.


    As many people here have said, Reset Network Settings does not fix the problem. I flashed my router firmware and it didn't make any difference.


    If anyone has a better idea on what we can do to get this resolved instead of posting on this board, please share! My phone is out of warranty, and Apple seems reluctant to ackowledge an OS issue until they have a fix for it.

  • Lawrence Finch Level 8 Level 8
    Mac OS X

    I am so sorry you can't read. I said "if it is limited to one network" then it is the router.

  • Benny89 Level 1 Level 1

    I have an iPhone 4s and since update to iOS 7 the Wi-Fi Buttom in Setting is Grey, and activate the Wi-Fi is impossible. I restore the iPhone with iTunes but nothing, also restore Network Setting... Must be something in the software. Please Help....

  • haonavy Level 1 Level 1

    Updated my phone today and it has turned into a complete brick. No networks of any kind will work. No wifi, no 3G, nothing.


    Sits "Searching..." for long time then shows up "Vodafone UK" with 5 bars for about 10 seconds and then switches back to "Searching..." again (never does get 3G or E or even GPRS signal).


    I've tried all manner of restores and network resets. It isn't the wifi router fault (iPad and computer still work fine) and I know it isn't the network (everybody else's phone works fine). The 7.0.3 update killed it.


    Guess I'll have to put it on the shelf until 7.0.4 because right now it is just a paperweight.

  • acesinica Level 2 Level 2

    To haonavy,


    Try toggle airplane mode, this flips the radio antennas on and off, might get them to work.

    Power off your phone, wait for a few minutes, then power up again. This is to ensure you are starting from an initial state.


    To test for sure whether your phone's cellular portion (Vodafone UK) is working or not, borrow someone who has the same service, same type of SIM, put it into your phone. Move to a different location and see you can get a signal.


    For wifi, click on the [i] next to the wifi entry, then click on forget network. Your router may already have that phone's MAC entry in its table so it won't give a new IP address before the lease expires. But your phone may have its IP entry erased due to the upgrade. The phone will keep asking for an IP address but the router won't give it a new one because the phone's MAC address is still within lease period (registered before the upgrade).


    A reset of the router would fix this limbo condition, reset iphone too, to clear up any limbo states from previous failed login attempts.

  • mfs3168 Level 1 Level 1

    There are numerous posts with the same issue, not 300 million affected but clearly a percentage of folks who upgraded to 7.0.2 and/or 7.0.3 no longer are able to connect to any wifi networks on their iPhones.  I have reset network settings, reset all settings, even gone so far as to restore from itunes.  Nothing works.  No wifi is found at all.  My other devices work just fine and are able to connect (i didn't update those) so it is clearly a software update issue that is affecting some users.

Previous 1 2 3 4 Next