Previous 1 2 3 Next 36 Replies Latest reply: Jan 7, 2014 10:26 PM by RupertRupertRupert Go to original post
  • thejeters247 Level 1 (0 points)

    Patience apparently worked for me, because I don't know exactly what I did to fix it. Skip to last paragraph for what I did do.


    First of all, I've had the same issues noted above, after updating iOS7 on my AT&T iPhone 4.  On several apps (facebook, Yahoo Fantasy, Weather, Google, etc), I'd get the "connect to itunes to use push notification".  It was especially bad on Yahoo Fantasy Football since it would pop up immediately after clicking OK.  Additionally, iMessage, Facetime, and Find My iPhone would not work.  It kept telling me "waiting for activation" on iMessage and Facetime or would tell me to check my network connection and not sign me in.  Texting without iMessage was costly for me.


    Happy to say that all is well now, but it got worse before it got better.  I looked through all of the suggestions I could find on this forum short of doing the "restore to backup" option.  I've done that once before and refuse to go through that process again and lose purchased app data. I also can't believe that an iOS7 improvement/update should cause people to have to reset/restore their iPhone.  Incredible.


    Anyway, the last thing I did before everything started working was to try again to turn off iMessage and Facetime in "Settings", logout of iTunes/Appstore, turn off Location Services for FindMyPhone (Settings/Privacy/Locations Services/very bottom), and delete FindMyPhone.  I rebooted the phone and then did a hard reboot twice (or whatever you call the Home+Power 10sec restart).  After a long long wait for loading, I went to Settings.  When I tried to click on "Messages", it just highlighted the word and froze.  Closed "Settings" and tried clicking "Facetime" and got the same frozen highlighted reaction.  Ugh!!  Even worse than previous attempts.  I think I tried reloading FindMyPhone and location setting.  Then went back to try Messages and Facetime and maybe did another reboot.  Just when I was ready to toss my phone and go droid shopping, the Apple angels paid me a visit around midnight and without any other explanation allowed me to turn on iMessages and Facetime without saying "waiting for activation" and likewise I didn't get a "connect to itunes" pop-up when I checked to see my Yahoo fantasy team still had a fighting chance even after the Dallas debacle on SNF.  I will not be the first to update to next iOS.

  • SDLRxD12 Level 1 (0 points)

    @Karpatri: Great suggestion. I did the hard reboot with my iPhone 4: it fixed the iMessage, the Facetime, and the push notifications without crashing everything!

  • atatua Level 1 (0 points)


    Hunter Guererro's solution posted on October 24 worked for me:

    Sign out of Appstore

    Power down

    Switch on

    Sign in to Appstore




    I have a iPhone 4 and i do the next, maybe can help


    Go to settings>itunes store & appstore>logout from the account

    Turn off and turn on the idevice

    Again, go to settings>itunes store & appstore>login


    It works without a restoration.

  • ivancho999 Level 1 (0 points)

    Hello All,

    This issue is because of Facetime!

    I am guessing its the latest fix but I could be wrong. Either way here is how you fix it.

    1. Go to Settings -> Facetime

    2. Turn on facetime (if its off). It will say waiting on activation and it could take a couple of minutes so be patient.

    3. Once activated all your phone number and email addresses information will show up below. At this point your problem is solved.

    4. If Facetime was originally on but you dont see any of your information below (which is the exact issue your having), turn it off, restart your phone (turn it off and back on), Then follow step 1, 2 and 3 again.


    Hope that helps!


  • bartman is here Level 1 (10 points)

    This worked for me:



    iOS 7.03

    iPhone 4


    After upgrade to iOS 7.03, iMessage, Facetime and push notifications stopped working. iMessage and Facetime displayed the "waiting for activation" message but never activated.


    The fix:


    1. iMessage and Facetime turned on

    2. turn off wifi

    3. turm off iphone

    4. turn on iphone

    5. turn on iMessage

    6. wait a few seconds and you will be prompted for icloud userid amd password - enter your credentials

    7. wait a couple of minutes and iMessage and Facetime will be activated and you are back in iBusiness.


    Hope it works for someone eles!



  • n8hoven Level 1 (0 points)

    If you have played games where you change the date and time, you need to set automatically or set to the actual date

  • RupertRupertRupert Level 1 (0 points)

    Thanks, turning off wifi and rebooting my phone worked for me. I lost FaceTime and iMessage after upgrading to iOS 7 from iOS 6. What a weird bug.

Previous 1 2 3 Next