Previous 1 2 Next 25 Replies Latest reply: Jul 6, 2014 10:19 PM by oleyar Go to original post
  • MrsStephenson Level 1 Level 1 (10 points)

    I was having the same problem running OS X Mavericks. The workaround I used was this:


    This sounds like I'm creating a new account, you're not, but bear with me, as it was the only thing that worked (I'd reset router, checked DNS, reinstalled mavericks etc)


    Go to quick links,

    Select login

    Select create new Apple ID

    When presented with the welcome to the App Store page, select continue

    Check the box "I have read and agree..."




    using two fingers, swipe back to the the main App Store page

    Select login

    But this time log in


    Hopefully this will work for you

  • Jerome Colas Level 2 Level 2 (220 points)

    Well, MrsStephenson, this is brilliant.


    This is very simple and works for me; the same procedure also works for iTunes, where I have similar issues.


    Thanks a lot!

  • jaspermiel Level 1 Level 1 (0 points)

    absolute genius!! thank you!

  • Coolbit Level 1 Level 1 (0 points)

      Wow, i was almost sure i got to reinstall the os, but you saved me from this! Thank you MrsStephenson, your help highly appreciated!

  • Baxil Level 1 Level 1 (0 points)

    +1 for this fix.  The problem was driving me crazy until I tried this and it worked instantly.

  • mojdeh banafsheh Level 1 Level 1 (0 points)

    @ MrsStephenson

    Please help me, I did it but it doesn't work for me! I have MacBook pro OS X 10.9

    I'm really blocked



  • MrsStephenson Level 1 Level 1 (10 points)

    Really sorry, I have no other solution to this I'm afraid. Do all the usual stuff, restarting etc then give it another whirl.

  • Chippy99 Level 1 Level 1 (10 points)



    Please can you expand on how you got this to work for iTunes.  It's iTunes I am having problems with.  (Actually the App Store too, but I have managed to fix that due to your fantastic tips on the previous page.)


    I am sure this is something to do with purchases under one ID not being transferrable to another computer.  I have 2 Apple ID's - one is my work one and the other my personal one.  The work one is for my work iPad.


    There's a credit balance (i.e. money!) on my work account - left money over from some stuff they installed for me.


    I thought I would try and buy an App for my personal iMac using my work AppleID and the spare funds.  This worked.  I just logged in to the App Store using my work ID and made the purchase and installed the software.


    Since then however, I can no longer log in to ITunes with my personal ID.  It's like this account has been permanently associated with the work ID.  I can log in to iTunes using my personal ID when logged in to OS X as a different user.


    So I am sure it's something to do with preventing unauthorised copying.  Since you were able to fix it for the App Store, I guess there must be a similar fix for iTunes, but I haven't figured out how to do it.

    Any ideas?  I would be most grateful.


    The irony is, I am not trying pirate anything - they are both MY apple ID's !!!

  • tau1776 Level 1 Level 1 (0 points)

    Hi Jerome,


    This totally worked. Thanks so much.

  • Rhea88 Level 1 Level 1 (0 points)

    This didnt work for me :'(




    I click on the "Welcome" link under Quick Links in the App Store and it asks me to sign in with my password.
    I do this and then it totally just DOES NOTHING and I'm still not signed in or anything.


    I know that my password and everything is alright because I can sign in and view all my account info on the support page on the website and on iTunes, but it just wont let me sign in to the App Store.


    I tried to Install an app and it asked me to sign in again. I do this and this time it says "Unknown Error" and I have to click "OK" and a second later it says "We could not complete your request. An Error has occured in the App Store, Please try again later. (4)."


    I too have changed countries a few months ago and have updated all my App account information and everything was working fine until just now, while trying to update my software to Mavericks, which I cannot do.




    Please Help,


  • oleyar Level 1 Level 1 (0 points)

    i see quick links but what does 'two fingers' mean?

Previous 1 2 Next