Previous 1 2 3 Next 75 Replies Latest reply: Sep 5, 2014 7:18 AM by TotnesMatt
macmikey Level 1 (20 points)

So I jumped on the "free upgrade" without thinking maybe I should let this thing get its legs first. Ah well...


I really like Mavericks by and large, but Mail suddenly isn't pulling AT ALL. According to Mail Connection Doctor, Mail is able to connect to the internet, but neither of my accounts (my Comcast address or Gmail--yeah, I know there's a story there) are succeeding in pulling mail AT ALL. I keep getting this:

Could not connect to this [SMTP,, or Google IMAP] server. Check your network connection and that you entered the correct information in the Account preferences. Also verify that the server supports SSL. If it does not, deselect the "Use SSL" checkbox in the Advanced tab of Account preferences.

Because I know some will respond condescendingly that I shouldn't complain when an upgrade changes things, let me say that I've already checked these issues and the settings are all correct--that is, they were as I had them set before the upgrade. At least, all the settings I can find are the same as before. Anyone else having this issue?

MacBook Pro, Mac OS X (10.6.8)
  • David MacDonald2 Level 1 (140 points)

    Yes. That's my experience too. My Mail IMAP accounts are working, but another account that uses POP and SMTP to a server I have used for years has stopped working under Mavericks. I have checked on a Mac still running ML, where Mail continues to work OK.

  • MK_SPACE Level 1 (0 points)

    I face similar problem on MacBook Pro. After upgrading to Maverics last evening, i immediately stopped receiving emails. All my Email accounts are on POP and I was receiving emals very well before the upgrade. From my iPhone 5 on the same network, i am able to receive emails. Apple must work fast to resolve this problem because we cant work by using the phone.

  • MK_SPACE Level 1 (0 points)

    Anyone with a solution to this kind of a problem?

  • Flisalisa Level 1 (0 points)

    I have the same problem. Was 1,5 hours on the phone with Apple support yesterday - they had no clue how to solve it, sent to technicians, will take up to 4 days to solve....

  • RJM Level 1 (20 points)

    I am having the same problem with Mail.


    MBP trying to POP Yahoo Mail on AT&T Uverse.


    No issue before the Mavericks upgrade.

  • joseph_chiu Level 1 (0 points)

    The same here, and I upgrade same OS X 10.9 with different Mac mini.(one it's ok to sync the email from exchange server, and the other fail.).

    - MacBookPro it's ok to download/ sync the email from exchange server.

    Confirm this issue didn't occurred before upgrade to Mavericks.

  • David MacDonald2 Level 1 (140 points)

    If you want to check if the email server you are trying to contact is OK, then run up Terminal and enter:


    Telnet <> 25




    Telnet <> 110


    where <> is the name of your mail server. The first command will check if port 25 is open, the second if port 110 is open (these are the default SMTP and POP ports respectively).


    Needless to say, the server I am trying to contact is up and running and works, as it always has, with previous versions of Mac OS X (and even further back). This problem is only with Mail in Mavericks – it doesn't seem to try to establish contact with the mail server at all.

  • barelywired Level 1 (0 points)

    Same thing happened here.  I performed the upgrade, opened mail and witnessed the DISASTER that Apple (what used to be a good company) has executed on with Maverick.  I don't care if it's free.  Charge me $19.99 and make it work.  This may be the worst upgrade I've ever seen in any software....EVER.


    In addition to the myriad of things I'm experiencing.


    Mail has been displaying "undocumented features" (bugs) in the following ways.


    Smart Maiboxes are not working properly

    Mail is not displaying that is there (I can see it on other non-upgraded devices)

    Response times are very long for basic tasks

    My favorite feature is how you can click on the mail app and it takes several seconds for it realize it needs to do something.


    I seem to have found something that helps get things to a semi-functional state.


    Rebuilding the mailboxes.  Just select the InBox you are concerned about.


    In the mail application select Mailbox---->Rebuild


    I seemed to get myself to borderline functional state.


    Still having sent messages sitting in the outbox.


    Have mail conficts showing up from 2010.


    Other mysterious items.


    Apple - please get a fix quickly.  It appears your developers are part of the same team that built the National Healthcare website.

  • MK_SPACE Level 1 (0 points)


    The server is OK, Telnet to port 110 is ok. my iPhone 5 is working very well on POP using the same network as my MBP.

    This is definately a serious bug. Is there anyone from Apple following up this discussion and what is his/her comment on this? By when should expect a quick fix to this problem. I feel like throwing my MBP to the trash bin because all my email are not working.

  • Sha-Rab Level 1 (0 points)

    Had the same problem with my Exchange account (not Gmail!) and the sync got stuck.


    I had to rebuild the mailbox and leave it at that overnight to get it working. Now works fine and mail deliveries are ok.



  • MK_SPACE Level 1 (0 points)

    Hi Sha-Rab,


    Is your Exchange account working on POP or IMAP ? - Is your POP working now?


    I have tried to rebuild and i lost some unread  emails. Probably because i am not connecting to server?

  • Sha-Rab Level 1 (0 points)

    Hi MK_SPACE,


    My Exchange is working on RPC not POP or IMAP.


    POP3 to another account - and that works fine.


    You shouldn't loose any email unless you set POP3 to delete messages from the server after you receive them.

  • macmikey Level 1 (20 points)

    Okay, I've figured out what's wrong on my end. I don't know if this helps anyone else, but this solved my problem.


    I had taken my MBP to work and set the installation to run while I was at work. In my situation, however, I don't have a work address, per se; I have my home Comcast address and a Gmail account. (Still don't think that works, but I'll live.) At work we're on Comcast (I think that's all we have in my little town), but it's not my home network. Seems Mavericks wasn't letting me retrieve mail from the Comcast server until I got home... but now that I'm home, it pulls just fine. We'll see how it behaves when I go back to work...


    On a related note, it seems this happened in January when I took this job (or whenever I updgraded to Mountain Lion, I'm not sure). Even 10.8 didn't really like checking home mail while away from home, but accepted it before long. My un-UNIX-educated hunch is that it has to do with an entry--or lack thereof--in the http-config file (or some such). A line with the mailservers' addresses has to be written to this file before the OS will quickly point Mail to it. (I think this also applies for web addresses, which would explain somewhat slow Safari action. I'm a long-time Mac user, but as I said, an admitted UNIX newbie, so I could be full of hot air. It's just a hunch.)


    In any case, I'm functioning now. I hope this helps someone.

  • macmikey Level 1 (20 points)

    I was wrong, Gmail works, too.

Previous 1 2 3 Next