Previous 1 24 25 26 27 28 29 Next 398 Replies Latest reply: Jun 13, 2015 2:57 PM by petermac87 Go to original post Branched to a new discussion.
  • Vicent Level 1 Level 1 (0 points)

    it seems to be logic... when you clean the kernel and system caches with onix or similar it happens too (the message dissapears) but later, it comes back.

     

    So, I understand the upgrade/update cleaned the caches.... and the message gets out!. But it is temporal.

     

    So sorry!

     

    Vicente.

  • Sigismundus Level 1 Level 1 (0 points)

    The battery most likely is in bad shape and needs replacement - when I (after a long period of hesitation) took the laptop to the Apple store, they booted it up from network using a diagnostic system - which must have had nothing to do with Maverick I guess. It was clearly signaling battery failure.

     

    I still do not like the fact that one cannot simply order a genuine battery and replace at home. Perhaps one day there will be stong competition - "Pear" or "Pineapple" or another brand that will produce quality stuff and allow the users to service it DYI.

     

    While I generally like the fact that lots of not-necessarily-genuine components can be purchased online, I definitely would not go with third party batteries. I had lots of bad experience with such cheap products with my other laptop. It is a lotto game.

  • igor_marques Level 1 Level 1 (0 points)

    I just updated my OSX and started to get this issue with the "Service Battery" alert.

     

    Can we hope it's an OS bug?

  • Sigismundus Level 1 Level 1 (0 points)

    There is definitely something strange with Maverick. Even though I replaced the battery in the Apple store, the power life time indicated on the battery indicator seems to be very erratic. Sometimes it shows 5 hours left, but today, at the moment I disconnected the power supply, it showed 2:30h left. But 90 mins later it is showing still 2:02h. It looks that the new battery life is approx. 5 hours.

     

    We need a Pear to emerge.

  • igor_marques Level 1 Level 1 (0 points)

    So.. The alert dissapeared!

     

    I just spend the last few days (3 or 4, I guess) using my macbook until it reached 20% of charge an then charging it up to 100%.

     

    I hope this "method" can help someone else who'd freaked out like me, haha.

     

    For precausion for now on I'll start saving some money for a new battery.

  • Chalexey Level 1 Level 1 (0 points)

    I would even suggest you really use it until it shuts down and then give it some time (maybe for the whole night) without loading. I suppose this should help even better as it is the standard procedure for recalibrating your battery!

  • Csound1 Level 8 Level 8 (44,275 points)

    UniBody Macs have batteries that should not be calibrated, please note that and do not give out incorrect advice in future.

     

    Screen Shot 2014-05-22 at 14.47.00.png

     

    Discharging the battery until the Mac shuts down is a bad piece of advice.

  • 1noel9 Level 1 Level 1 (0 points)

    after updating my mid  2012 macbook pro non retina to 10.9.3, I notice some serious power drop to my battery in just weeks in just 58 cycles, tried all thess nram and smc thing but nothing work to me. any other solution to this problem?

     

    Model Information:

      Serial Number:          D86210303YVDGDLBC

      Manufacturer:          SMP

      Device Name:          bq20z451

      Pack Lot Code:          0

      PCB Lot Code:          0

      Firmware Version:          406

      Hardware Revision:          2

      Cell Revision:          158

      Charge Information:

      Charge Remaining (mAh):          1325

      Fully Charged:          No

      Charging:          No

      Full Charge Capacity (mAh):          4855

      Health Information:

      Cycle Count:          58

      Condition:          Service Battery

      Battery Installed:          Yes

      Amperage (mA):          -1192

      Voltage (mV):          11370

  • BFOSSEN Level 1 Level 1 (0 points)

    It's been a long time since I first started this thread, but I have some news (that may or have not been mentioned by others).  I decided to re-install maverick's off of my restore drive to try and remedy some other issues.  Low and behold, it's been a week now and no power warning!

  • erikayvonne Level 1 Level 1 (0 points)

    How do you do that?

  • matanglawinx Level 1 Level 1 (0 points)

    Update.  I'm not sure if this would woprkon anyone else.

     

    I've has a few ups and downs, and this even went 73% capacity at one time, even with the full drain and full recharge.   After I already installed 10.9.3, lost the error, then got back again, I gave up on trying to solve this after reaching a low 73% capacity.

     

    Then I went to a long bus trip where my laptop is on sleep more for more that 5 hours, and the error disappeared when I opened the laptop, and the capacity, went up 78%.  I used it for a while without charging, then charged it.  On my trip back, The bus had free WIFI so I used it a bit, till the charge was just round 75%, the capacity rose to 80%, Stopped using it when the bus started to move, then kept it on sleep mode for 7 hours the rest of the trip home, which was significantly longer.

     

    When I got home, the capacity was at 82%, the charged at 70%. I started charging it again, and after a few minutes, the charge went up to 83%.  It's seems putting it in sleep mode unplugged helped it recover somewhat.  It has gone down as low as 80% when I use it unplugged, but climb up again after I let it sleep.,

     

    Also, depending on how you use your Magsafe (or depending on the Magsafe itself), it might be connected and greenlit but not actually charging.  I just fairly recently found out that though I was taking good care of my Magsafe, I kind of neglected the 4 prong plug, the end prongs have lost they springiness and were not in contact with the laptop contacts.  So that might be incorrectly giving the battery a "full charge" status.

  • matanglawinx Level 1 Level 1 (0 points)

    Also, on that 3 day trip, I kept the laptop on sleep mode unplugged, plugging only when I'm using it for longer than an hour.  I wasn't really using it that much at the time, since we were touring the area and hiking all day.  So I was only able to use it eithr during lunch or dinner time.

  • Winkle35 Level 1 Level 1 (0 points)

    I have a mid-2010 MacBook. It has 651 cycles on it, and the battery drains pretty quickly anyway. I don't notice the battery draining issue, but I did see the Service Battery warning. I restarted the computer, and it went away. If the warning comes back, I will go to Apple. The condition of the battery was always Normal in System Information until now. My computer has also just been charging to 98% instead of 100%.

    I hope this is quickly fixed by Apple, since I don't want to pay $129 for a new battery.

  • laerm Level 1 Level 1 (0 points)

    So I think it's a little sad that this thread still exists. I got a new MBP about two weeks after Mavericks dropped, so I haven't ever had a need to post...but now I want to pull my previous mid-2010 15" out and use it for something and the battery issue still exists (for me, 222 cycles and change battery, and mine won't even run if the Magsafe is out). It started for me right after Mavericks came out. I didn't care, because I never use mine away from an outlet (though I did re-calibrate the battery every 5 weeks using Watts). Now, as I mentioned, I want to use the old one again but there's apparently still no fix for this problem. Adding insult to injury, the notice at the top that says that this has been branched to a new discussion says that I'm not authorized to view that thread.

     

    Thumbs down, Apple.

     

    Micah

  • matanglawinx Level 1 Level 1 (0 points)

    Update:

     

    I've installed Yosemite (on a separate partition).  The "service battery" message was gone, even though it's only at 72% health.  Even with the adapter unplugged, the health rose to 78%, without the "service battery" message.  I was only on Yosemite for about 30 minutes or so, and when I restarted on Mavericks, the error is back, and the battery health fell immediately to 77% (still unplugged).

     

    I'll continue to observe it when I can be on Yosemite for longer periods of time, but this seems promising.