Previous 1 2 Next 29 Replies Latest reply: Dec 14, 2015 6:31 PM by britta99
kysox185 Level 1 (0 points)

After installing Mavericks, my Apple Mail (connected to my work's Gmail account) stopped showing the Inbox's unread count on the dock. I switched it to "all mailboxes" to see if that would make a difference, and the dock shows 7 unread emails when there are actually none. When I switch it back to "Inbox" unread counts, it shows nothing. I've waited 15 minutes after receiving an email to see if it will show an unread message in the dock, but it does not. Does anyone have a fix for this?

 

Thank you!


MacBook Pro, OS X Mavericks (10.9)
  • Charles Rawlings Level 1 (15 points)

    Same here. New mail in inbox doesn't show a count number in dock icon. Yes, I have the preference (dock unread count) marked to show it!

  • joopgij Level 1 (0 points)

    I had the same problem, but just stopping and starting the mail app solved for me the problem.

  • blakely99 Level 1 (0 points)

    When Lion was installed, this same problem arose for some users.  I followed the instructions for deleting the "envelope" files in Mail.  I am currently rebooting and Mail is setting up the folders.  It says it will take 16 minutes.  I let everyone know if that worked.

  • kysox185 Level 1 (0 points)

    I ended up deleting the entire gmail account, and then adding it as a new account. Seems to be stable now. Thanks for the suggestions all.

  • Howard Brazee Level 1 (15 points)

    What are "envelope" files?

     

    Some of my new mail go to a smart folder, which shows the unread messages correctly.   When I read them, and the count in my box is still showing, I click on my in box to find more unread messages.   I don't have a gmail account.    My personal e-mail account is pop.

  • brandonnodnarb Level 1 (0 points)

    I have the same issue with an Exchange account (my gmail goes to another reader).  I have tried to disconnect and reconnect, as well as deleting the envelope files. Still no go.  Any other thoughts?

  • dznman Level 1 (0 points)

    I have the same problem. I also tried removing all mail preferences and restarting. Still no unread mail count.

  • MyFaithfulLabAssistantBeaker Level 1 (0 points)

    Me too. It's frustrating... have to wait for the next update I guess...

  • vol7ron Level 1 (0 points)

    Quit your mail entirely, then in terminal do:  

     

    • mv ~/Library/Mail/V2/MailData/Envelope* ~/Desktop 
      This moves all your "Envelope Index*" files to your desktop.  An alternative is deleting the files, but this allows you to keep them as a temporary back-up (you can delete them at-will later).  Also, you can move the files from Finder instead of Terminal, if you prefer. 


    • After the files have been moved, re-open Mail
      This should re-load all your email messages, updating/restoring the count

     

    While this works, it does not explain the reason the count goes missing, nor does it ensure that the count won't go missing again in the future, but at least it's a temporary workaround.

  • bobby.is.rad Level 1 (0 points)

    This worked. Thanks!

  • Howard Brazee Level 1 (15 points)

    It's not working today.   I tried a bunch of times.

  • Howard Brazee Level 1 (15 points)

    Interesting thing that halfway through a bunch of attempts today, I went to my iPad, opened mail in it, and deleted the mail on it.    Now my iPad doesn't try to re-read those e-mails, but my Mac certainly does.

  • Howard Brazee Level 1 (15 points)

    Once time I decided to empty my trash containing the envelope files that were copied to my desktop then deleted.    It could not be completed because the item "Envelope Index-wal 6.05.44 PM" is in use.

     

    That was because mail was open.   But I wonder why mail was pointing to the envelope file that was moved there when Mail wasn't open.

     

    So I'm making sure to empty the trash every time, and shut down some times as I keep working on this problem.

  • zmix Level 1 (120 points)

    Go to System Preferences > Notifications > Mail, and  make sure that the "Badge app icon" box is checked:

     

    Screen Shot 2014-01-20 at 12.44.54.jpg

Previous 1 2 Next