8 Replies Latest reply: Jan 17, 2014 6:50 PM by Darth
dkf747 Level 1 Level 1

I have update to Mavericks and Keynote 6.0.  I'm on a 15 inch Early 2011 MacBook Pro, and connected to a LG Display via VGA through the Apple VGA adapter.  When I try to play a slideshow, it only shows on the Mac Book Pro with the Presenter display behind it.  I tried clicking the switch monitors thing, but that does nothing except get rid of the Presenter display behind the show.  I hit the 'x' key to get the presenter display back.  I looked in preferences and other places, but I do not see a seting to show the show oon the other monitor.  The Apple help files are no help at all.  The weird thing that happens, is that I can drag the keynote app to the second monitor and hit "play" and it will work with the presenter display on the second monitor and the show on the MacBBook Pro.   Hitting 'x' gives the desired result, but when connecting to our projection system, or monitor, we do not want the app on the second monitor.  For what it's wooth, Power Point does work (Office 2011) as desired.  My question is; How do I fix Keynote to work properly?


MacBook Pro, OS X Mavericks (10.9), Keynote 6
Solved by Darth on Oct 24, 2013 4:36 PM Solved

I had this issue today in the previous version of Keynote on my MacBook Pro running Mavericks. I restored my desired behavior, which sounds just like yours - slides on secondary display/projected on screen with presenter display on my screen - by unchecking the box in System Preferences under Mission Control that is labelled "Displays have separate Spaces". I had to log out and log back in for that to take effect, but once I did, everything was back where it usually is. Hope that helps.

  • Darth Level 3 Level 3

    I had this issue today in the previous version of Keynote on my MacBook Pro running Mavericks. I restored my desired behavior, which sounds just like yours - slides on secondary display/projected on screen with presenter display on my screen - by unchecking the box in System Preferences under Mission Control that is labelled "Displays have separate Spaces". I had to log out and log back in for that to take effect, but once I did, everything was back where it usually is. Hope that helps.

  • dkf747 Level 1 Level 1

    Thank you!  That worked!

  • leeeveretthunt Level 1 Level 1

    Thank you, Darth.  I learned about this problem the hard way... while launching a presentation for more than 200 people.  How did you ever figure out the solution?  You are a life saver!

  • Darth Level 3 Level 3

    I was teaching my first class post-Mavericks upgrade and was having a fit finding out, in front of my class of 33 graduate students, that my projection set-up wasn't working. I had read something about getting rid of the menu bar on a secondary display in Mavericks and decided to try it. Since then, I've also read that assigning Keynote to all desktops, with the "Displays have separate spaces" box checked, might also do the trick, but I won't have a chance to test this until Monday afternoon. Glad you got it working!

  • jorhh Level 1 Level 1

    Darth, you are my hero of the week!

    I struggled with the presenter display not showing (Keynote 09 on Mavericks) and was lucky to find your post.

    Thanks!

  • davemurphy Level 1 Level 1

    perfect that worked for me!

     

     

    rgds Dave

  • beston Level 1 Level 1

    Darth, that solution worked wonders for me. Thanks!

     

    I almost gave up on keynote. Keynote 6 is terrible, and 5.3 was creating this issue.

  • Darth Level 3 Level 3

    Glad it was helpful, certainly hope presenter note adjustability comes back in Keynote 6 soon.