Previous 1 2 3 Next 44 Replies Latest reply: Mar 27, 2014 7:14 PM by akhannides Go to original post
  • ncollingridge Level 1 (10 points)

    I have been having this problem as well, and I have tried every other remedy I have found by trawling around, but finally it has been fixed by setting WebKitOmitPDFSupport to NO, as for the others above. FINALLY! Well done to those who found this fix.

  • stephan.zehrer Level 1 (0 points)

    Sorry yes this is correct setting  WebKitOmitPDFSupport = no will enable the preview within Safari.


    My personal requirement which i did not mention was to enable download and not preview within the browser.


    Nevertheless thx

  • Figgy Level 1 (65 points)

    This fixed it for me.


    .pdf files now display within Safari 7.0 just as swiftly and smoothly as they used in the version of Safari before the Mavericks download.


    A big thankyou to all those who provided suggestions and help.


    Top work cm477. Thankyou

  • cm477 Level 1 (5 points)

    In addition to the shell command :defaults write WebKitOmitPDFSupport -bool NO", if you are running the System Preference Pane "Secrets," make sure that the Safari setting "Load PDFs in Browser" is selected. I don't know how many of the Mac OS settings are still customizable in Mavericks with Secrets, especially since it looks like Secrets hasn't been updated since 2008.



  • dileep_s Level 1 (0 points)

    Thanks this worked for me too.


    defaults write WebKitOmitPDFSupport -bool NO

  • akhannides Level 1 (0 points)

    A year ago, I was able (somehow) to set Safari to do the following: when I clicked on a link to a pdf file, it just downloaded the pdf file to a folder without opening it. In Safari Preferences > General, I defined that folder as "Downloads" and I unchecked the "Safe open" box. I believe that this is what you and garylapointe were doing also.


    As of yesterday, it stopped working, and I'd get a new tab with all the gibberish one would expect if Safari is trying to interpret a pdf file on its own. I ran "defaults write WebKitOmitPDFSupport -bool NO" so that I can at least get rid of the gibberish and see the pdf file in Safari, until I can figure out how to disable it opening in Safari and just to download.


    If and when I find a solution I'll post it here. Just to be clear: my goal isn't to view pdfs in Safari when I click on a link to a pdf file, but to just download them to the folder I define in Preferences > General. No right-clicks, no drop-down menus were needed until yesterday.

  • cm477 Level 1 (5 points)

    akhannides: Your problem began recently, but had you already installed Safari 7.0 and/or Mavericks? I am curious if the automatic downloading of PDF's work for a while on Safarai 7.0 and then stopped recently, or you did not have the opportunity to test it yet on Safari 7.0.

  • stevewhitemd Level 1 (110 points)

    That is broken in Safari 7/Mavericks. Right now it is a bug and cannot be fixed. I've been reading this thread, other threads, and other resources, and it's just plain broke.


    In the meantime you can get PDFs to display within Safari 7 by:


    defaults write WebKitOmitPDFSupport -bool NO


    That isn't what you (nor I) want: we want to click a link for the PDF and have it download automatically to the Downloads folder (or wherever). But that is BROKEN right now, and if you set the logical argument on the string above to 'YES' you'll get the gibberish problem.


    Apparently a bug report has been filed to Apple. In the meantime you'll have to display the PDF in Safari and THEN save it using the save icon.



  • akhannides Level 1 (0 points)

    Hello, cm477. I'm running Safari 6.1 on Lion. Waiting for a fix....

  • cm477 Level 1 (5 points)

    Akhannides: Interesting that you are still running Safari 6.1 and Lion, yet this problem appeared for you just recently. I was thinking it was exclusively a Safari 7.0 and Mavericks issue.


    From other posts, it appears that this bug has been reported to Apple. Hopefully that is the case and it will soon be fixed (as they recently did with Apple Mail's issues).

  • stephan.zehrer Level 1 (0 points)

    Did you add a bug report?

  • Herbert Schulz Level 1 (10 points)



    I'd get rid of anything that hasn't been updated in a long time. All software can change under you especially those hidden preferences that most of these things use.


    Good Luck,

    Herb Schulz

  • hajrë Level 1 (0 points)

    Nothing is working for me and this thing is driving me crazy. Please help!! Is there any plugin/extension or anyting else apart from Adobe to view PDF fiiles in Safari as I give up in trying to fix it?


    Millions thanks!

  • cm477 Level 1 (5 points)

    Well, I thought that changing the shell command:


    Terminal command: defaults write WebKitOmitPDFSupport -bool NO


    more or less fixed my problem, but it only did so for several weeks. Sometimes when I would click on a page for a PDF, I would just get a blank gray page. If I clicked on that page, I could usually get the PDF to load and open within Safari.


    But now, for the past several weeks on my iMac, I cannot get any PDF to display within Safari. I just get that gray page and no matter where I right or left click, or refresh, I cannot get PDF's to display within Safari. I didn't change any setting or install any updates in that time. Now I just try to right-click the PDF link and download the file. Sometime this doesn't even work, so I copy the link and open it in Chrome or Firefox. I can still view PDF's within Safari with my MacBook Air.


    I didn't post anything sooner because I was hoping Safari Version 7.0.1 (9537.73.11) would address the issue. It hasn't. I seem to have a problem with Adobe in general because I often cannot see the windows of videos that use flash.


    This is pretty frustrating. I wish I could just re-install Safari,  but of course now that is impossible.

  • akhannides Level 1 (0 points)

    Just tried the old faithful again, in the off-chance they work as they used too:

    defaults write WebKitOmitPDFSupport -bool YES

    defaults write AutoOpenSafeDownloads -bool NO

    They now do! I click on the link and it just downloads uncorrupted without opening anywhere.
    For the record, I am running Safari 6.1.2 on 10.7.5.

Previous 1 2 3 Next