Skip navigation

Cannot View or automatically download PDFs in Safari 7.0

6707 Views 44 Replies Latest reply: Mar 27, 2014 7:14 PM by akhannides RSS
1 2 3 Previous Next
cm477 Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 24, 2013 5:15 PM

This is a bizarre problem since the Safari 7.0 update. If I click on a link for a PDF, instead of downloading the PDF and opening Acrobat or Preview, I just get a page of the underlying code.

 

E.g., clicking on  http://images.apple.com/media/us/osx/2013/docs/OSX_Mavericks_Core_Technology_Ove rview.pdf

 

gives me:

 

%PDF-1.5 %âãÏÓ 1101 0 obj <> endobj xref 1101 29 0000000016 00000 n 0000002539 00000 n 0000002690 00000 n 0000003122 00000 n 0000003237 00000 n 0000004185 00000 n 0000004648 00000 n 0000004761 00000 n 0000005026 00000 n 0000005537 00000 n 0000006159 00000 n 0000006419 00000 n 0000007050 00000 n 0000017804 00000 n 0000025298 00000 n 0000025328 00000 n 0000025454 00000 n 0000025490 00000 n 0000025567 00000 n 0000039803 00000 n 0000040145 00000 n 0000040214 00000 n 0000040332 00000 n 0000040409 00000 n 0000040687 00000 n 0000043992 00000 n 0000103676 00000 n 0000002338 00000 n 0000000876 00000 n trailer <<7ECE529081E14E87910F79877C04D8A0>]/Prev 4452637/XRefStm 2338>> startxref 0 %%EOF 1129 0 obj <>stream hÞ´T&#127;P’g ÿ>€ ˆ &#144;”   …° ašÓrˆŒÈ• ™3ónh&#157;Õ•— ×&#143;[5TÒ—Ê™^®U¶ uYËSS7·öC·Ì~l&#157;m-]k7ÙêÔ®:-k»vÝíá ”ÖþÝóÜËû}>ßïçûóá  í;ðÿTàÁÔâAÞ4 wÁM@tð³@6Ò  U0w#€…¿QEÕ`–¡%ÈY ˜  ,©ˆÊ c~ 7õ¬Žˆr{à1 Ô >Ÿ; D#P¶Íy Z ¬ p²•ÙÊÉy¾=ûíyÐ× ø ´« [øÙ†²¨ª°Ð&#157;ÜY ÷ÏTéÆËzm¡ŠÌêz-‹?GwC8•#­¯†Êâ%T#8©=”]_Þ/J6ÓS/×й‚!ûï ɲ BÞ  6YßVZiW &#141;N8/ º  Iš¾ALþô +úí¼M¦Nä »­Y&#141;y$X¨/ s£ Ùä  *gvnEÚ~Qè.çÍåaíù‚4MŸÅê_) öä ¡²[4ið ûÑÚÒTbS‘±s_ª&#141;]=ÿÎRC     ýîy»£ÄžYÈ Ï¯‹H      ‹e?œÄº¡¼ÒfÓg9½1·˜kÍ&#127;uȂΠ  d¼Ñ«E"N£æÁ CŽ’ã     Oy c ûÕCƒ  Zò ‰’&§•òëÕƘig lC_@†CµÉäá™]ñšó Q* ÉMÎ 4Y¦±m•oEž ã¿ŒD÷ Õ»œ c‚ÅVœ™KW)—¦¯þjÛø});²'ÁüŒ£ :  謶* ¥R>ëÔ+ •l&#144;]‚] ™‘¹äDÒ žba«ýõ×h£ã:}x ‹®s`ÝN傦z  ÷Z t€p»ÖÖrîž óc í&#143;{ ¬LÜeäù÷–¹ Ç ™©©å«¤Áû’÷B{Þä  ‹žñ(• \‘xM Ô§ÙÎ ^’+À&õy/Ìo˜m&#143;—™:A ಼TSïæ]äÛI×t?œgz¤Úbh QñTpfU‰[nËLë  É³™ÔüŸÎ Éú0(ä-5t%˜  ²iáÁ µkÄÚZ¶¢'3&#144;ï ± ÌjK[ÐtHÎ÷Î&#157; ¤­ 95÷¶ q7½Áÿ¢Œ´¬ŽÒ²éúîku®¬ó¿u݉!‹¡QcvNÈü¼ 4µáÛÙøÒþ|I ¹¯tbñ•?7æ|YÐûUd½à è“¢G@ &#141;îÅؤìÎÈÝ"¾·?4&#141;ÛÀó}! äA =ÕE WüŸ2f¿ä ÷’ði¿×/W åMÛ»þ¿ï) x æÓßÁïéøÙL¦  lT ÙÔ#¨ ²à!ºCY £”ÜÙà 1@…5Àå ” rX Jø›um” b Cà #i@ 0 O N  ExN ”bJê     v Gè :&#141;G² óâBk°ö)0Y `h&#143;Á^x  @ lƒÝ  oÁ ˆÃ» Î (etc.)

 

I get pages of this code.

 

If I do a "Save As" of this page in Safari, then it saves it as a proper PDF, viewable by any PDF reader. This happens on all PDFs, not just Apple's. I installed Mavericks and Safari 7.0 at the same time, so I don't know when the problem began. This happens on both my iMac and MacBook Air. I changed the default viewer from Acrobat to Preview, but it did not help.

 

I feel like I've been transported back in time 15 years when this is how files were exchanged...

 

Any ideas?

 

Running:

  • Safari 7.0
  • OS 10.9 Mavericks

 

on

  • iMac i7
  • MacBook Air i7
OS X Mavericks (10.9)
  • Carolyn Samit Level 10 Level 10 (84,180 points)

    Open a Finder window then from the menu bar click Go > Go to Folder

     

    Type or copy paste the following:

     

    /Library/Internet Plug-Ins

     

    Click Go.

     

    If you see the:  AdobePDFViewer plugin in the Internet Plug-Ins folder, move it to the trash.

     

    Restart your Mac and try opening a PDF file.

     

    If that didn't help, it may be a font issue.

     

    Try troubleshooting duplicate or corrupted fonts >  Mac Basics: Font Book

  • Linc Davis Level 10 Level 10 (107,930 points)

    From the Safari menu bar, select

      

    Safari Preferences Security

      

    and check the box marked Allow other plug-ins.

  • Linc Davis Level 10 Level 10 (107,930 points)

    From the Safari menu bar, select

      

    Help Installed Plug-ins

      

    Besides the following, what plugins are listed?

     

    • iPhotoPhotocast
    • Java
    • QuickTime
    • Shockwave Flash
    • WebKit built-in PDF

  • Linc Davis Level 10 Level 10 (107,930 points)

    I just noticed that there is no WebKit PDF plugin in 10.9. The Silverlight plugin has reported to cause problems with PDF viewing. I suggest you uncheck the box to allow plugins and see whether there's any difference.

  • Neo Blu Karbon Level 1 Level 1 (0 points)

    Since this morning, my safari 7.X can show pdf 

     

    I do not remember having any update from apple. So, it is probably due to the modifications I've done a couple of hours ago. Here are the two things I've done:

     

    1) Update you adobe plugins through adobe website:

     

    a) http://get.adobe.com/fr/reader/?promoid=JOPDC

    b) http://get.adobe.com/fr/flashplayer/?no_ab=1

     

    2) Since this issue with safari results from Apple security restrictions with Adobe plugins, all you have to do is go to safari "settings"/"preferences", then "Security" tab, and under "Security" tab check the "internet modules" and click to the right box to edit the "Setting for websites". Once inside, make sure both "Adobe Flash Player" and "Adobe Reader" are "Authorized/Allowed/Granted" to be use with any modules/links/websites: You will have a box on the right corner of each plugin suggesting "Ask", "Block", "Allow", "Always Allow", and "Unsecured mode".

     

    Let me know if it worked for you .

     

    NBK.

  • garylapointe Level 1 Level 1 (20 points)

    It's like it's not recognizing the MIME setttings that tells that it's a PDF so it's just displaying it as text.

     

    I don't think I've every had Acrobat installed on my MacBook and I haven't had Safari displaying PDFs.

    I had safari saving them and then I'd open them manually (which would be preview).

     

    I don't see how this could be an Adobe/Apple Security issue.

     

    (I do have updated flash installed but it's disabled by default with the click to flash plug in.  I've tried turing it on)

     

    FYI, I did not run the Safari 7.0 updater before I installed Mavericks, I installed Mavericks and it came with that.

     

    Gary

  • garylapointe Level 1 Level 1 (20 points)

    So after never having Acrobat installed, I installed Acrobat and I can see that it senses the PDF but it displays the black screen (before installing I was getting a white background).   I went and give the plug-in permissions but still no go.

    (I'd updated Flash earlier).

    If I turn off the plugins (via security options) I go back to seeing the ascii of the PDF and not the content (which is where I started).

     

     

    UPDATE:  After turning things on and off a few more times and relauching Safari a few times, Acrobat is working loading the PDFs in the page.  Thisn't my goal, I want Safari to go back to just saving them to the Downloads folder, but I wanted to report it did work.

     

    Gary

  • Neo Blu Karbon Level 1 Level 1 (0 points)

    Thanks for letting me know it worked for you 

     

    However i am not sure of what you mean by «go back to just saving them to the Downloads folder» Manually or automatically? ... In any case, unless you've change the location for downloads, this is supposed to be a default setting. Anyway, I recommend you these steps to try to restore you old settings:

     

    1) Checked if in your Safari's general settings the download folder is set to "Downloads". If not, just select the location and that's it... Everytime you save a file it will go there... Probably

     

    2) Whether the first one is ok or not, try to save any pdf file in your computer using these few shortcuts and confirm that the saved file went in the location you wanted:

     

              a) Open the pdf file in a new tab, then click on the save bubble which at the bottom center of the page =>

    Once you see the box at the top center of the page make sure that BEFORE clicking on "Save" you've selected "Downloads" folder IF that's NOT the default location.

     

              b) Two finger click (trackpad) / right click (mouse) / CTRL + click (Keyboard + mouse or trackpad) on the link to the pdf => a bubble appears and you have to select "Save the file under..." Once you see the box at the top center of the page make sure that BEFORE clicking on "Save" you've selected "Downloads" folder IF that's NOT the default location.

     

              c) LEFT ALT + Click on the pdf link.

     

    If these do not help can you clearly explain your problem?

     

    PS: Apple/adobe security issue: some codes use by adobe are obsolete, corrupted or too weak to protect people from piracy or computer complete crash... These have been reported quite much since 2009. Hence, Apple made sure that adobe plugins work in a sort sandbox, in order to protect people both from unsecured websites and file corruption. However, this "sandbox" is getting so paranoid that it led us to the trouble we encountered earlier with viewing pdf in our browser. You can google it or search it apple forums . There are genuine stories (sometimes exagerated for fun) and tons of information about it.

     

    NBK

  • garylapointe Level 1 Level 1 (20 points)

    I had "Open safe documents after downloading" as unchecked so PDFs just downloaded automatically when I clicked on them and did not open in preview (

     

    1) They aren't going to the download folder since they are (MIME type misinterptreted and) being displayed as plaintext in Safari.  If I option click them then they download.

     

    2) Everything when downloading is going to the correct place.  Just the PDFs that are displaying imporperly aren't going there (since it's not "downloading" them, it's displaying them.

     

    Gary

  • garylapointe Level 1 Level 1 (20 points)

    If I log in as a different user (guest or a test user) Safari displays the PDF properly in the browser (I can clearly tell that it's not Acrobat) but even unchcecking "Open safe documents after downloading" isn't getting it to save the file automatically. 

     

    Maybe that's not what I did to get it to save them years ago, I've been doing it this way for ages.  The saving is kind of minor, getting them to display NOT as plaintext is the important thing! Then I'll worry about the saving to the documents instead of displaying.

     

    Gary

  • Linc Davis Level 10 Level 10 (107,930 points)

    Please read this whole message before doing anything.
      
    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.
       
    The purpose of this test is to determine whether the problem is localized to your user account. Enable guest logins* and log in as Guest. Don't use the Safari-only “Guest User” login created by “Find My Mac.”
       
    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.
       
    Test while logged in as Guest. Same problem?
         
    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.
      
    *Note: If you’ve activated “Find My Mac” or FileVault in OS X 10.7 or later, then you can’t enable the Guest account. The "Guest User" login created by "Find My Mac" is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.