5 Replies Latest reply: Apr 9, 2015 6:52 PM by babowa
jim_julian Level 1 Level 1 (5 points)

I downloaded Mavericks through the app store and when I try to update I get "This disk cannot be used to startup your computer", therefore I cannot update.

 

Tried all of the usual things. Repaired drive etc.nothing was wrong.

 

All the advice I find on the net says I need to wipe the disk and do a clean install.  Any way to avoid that?

 

MacBook Pro 10.6.8

  • Blatay Level 1 Level 1 (0 points)

    I had the same issue.

     

    Finally got it to work.

     

    First I did what it says on this page.  That got me past the "this disc cannot be used..." thing. 

     

    From there I was getting a new error (hey, that's progress, right?) that said: "An error occurred while preparing the installation.  Try running this application again."  Running the application again yeilded the same error repeatedly.

     

    There was an installation folder that had been created on my harddrive.  I trashed that, tried again and it worked.

     

    Best of luck.

  • jim_julian Level 1 Level 1 (5 points)

    Thanks for your input.  I also tried that but it did not help.  I'm now in process of creating a bootable clone using SuperDuper and will then reformat the laptop drive and do a clean install.  I plan to reinstall all aps and just transfer my data files.  This takes too much time but it should work.

  • adam704a Level 1 Level 1 (0 points)

    Any other ideas? I have tried this as well as running /sbin/fsck -fy in single user mode. I am not sure if its related, but when I try to resize my osx partition (after booting to the Recovery HD) I get this error: "Couldn't modify partition map because file system verification failed"

     

    Software  OS X 10.8.5 (12F45)

     

    Memory  8 GB 1600 MHz DDR3

     

    Here is what my disk utility looks like and I have 422 GB available.

     

    Screen Shot 2014-01-28 at 9.22.44 AM.png

     

    Why ?

  • Noah Level 1 Level 1 (0 points)

    Hey guys I found a solution:

     

    1. Right click on "Install Mac OS X Mavericks."

     

    2. Click "Show Package Contents."

     

    3. Open the Contents folder.

     

    4.Go to SharedSupport

     

    5. Open "InstallESD.dmg."

     

    6. Install

     

    7. Enjoy!

  • babowa Level 7 Level 7 (27,625 points)

    Well, I'm puzzled by the fact that you have your 750 GB disk highlighted, yet on the right it is showing disk0s2 as having 750 GB with nothing on it although your Macintosh HD appears to be part of that disk0s2. I have no idea what disk0s1, 5, and 6 are or what they contain, but the only thing accessible seems to be your Macintosh HD - does that contain your OS? For comparison, here is a screenshot of mine (2 partitions on my internal hard drive):

     

    Screen Shot 2015-04-09 at 6.49.22 PM.png

     

    The area shaded in blue is the space my OS/apps/etc. occupies.

     

    Unless there is a viable explanation of your disk(s), my suggestion would be to boot into recovery, erase your drive, partition properly, and then reinstall from scratch. Make sure you have a backup first.