Previous 1 2 3 4 5 Next 124 Replies Latest reply: Mar 28, 2014 2:57 AM by Csound1 Go to original post Branched to a new discussion.
  • Brollissimo Level 1 Level 1 (0 points)

    The two mail accounts that I have rules set for are standard POP accounts. Filtering occurs after the mails arrive. It's nothing to do with the ISP. (and no... not a Gmail account)

     

    The specific problem, like the others posting here is that "Move" is copying, not moving. The problem exists both when a Mail arrives, and when manually applying a Rule to a selected mailbox (for instance, after editing a rule). This exact set-up worked perfectly with the previous version of Mail in Mountain Lion and stopped working properly immediately after installing Mavericks.

     

    The workaround of setting a copy and then a delete works for the time-being, so as long as the possibility exists that it's a problem with the new version of Mail, I'm not going to waste time delving about in the system looking for a non-existent error that Disk Utility doesn't pick up.

  • Barney-15E Level 8 Level 8 (43,305 points)

    If you look at this thread, there aren't many with this problem. Therefore, waiting for a fix will prove long and fruitless.

     

    It certainly may be a weird bug in Mail that only affects a few people, but if that is the case, Apple will only accidentally stumble upon it or randomly fix it when they change the buggy code to fix something else.

     

    There is a known problem with Gmail accounts, which has symptoms similar to what you describe.

     

    Since we are unable to replicate your issues, we cannot possibly find a solution on our own.

     

    If nobody wishes to solve the problem, I won't waste my time here, either.

  • patka1024 Level 1 Level 1 (0 points)

    Thanks for your time and help!

     

    1. Rebuild Mailbox - tried that one earlier - didn't work out

    2. Remove Envelope Index - tried that one now - didn't work out either

     

    The problem I was referring to about 'Apply Rule' is that manually clicking 'Apply Rule' doesn't have any effect (no filtering) whereas the messages are filtered out on arrival (with copy/delete work-around working fine).

  • Brollissimo Level 1 Level 1 (0 points)

    Thanks for your suggestions in your previous post, Barney. I'll give those a go if the problem continues... especially Rebuild Mailbox - that's easily done.

     

    I actually reinstalled Mavericks last night, which appears to have solved the move / copy issue. I haven't got time to check it thoroughly just now. I'll report back, but some of the Rules that I deliberately left on Move instead of Copy/Delete now appear to work as expected. Mysterious.

  • JimN Level 2 Level 2 (255 points)

    Joe, I agree with you, mail rules are only applied to incoming messages.  However, the company called InDev who make plugins for Apple's Mail.app called "MailTags" and "MailActOn" that transforms mail into a very nice GTD tool have within their "MailActOn" plugin, the capability to perform rule actions on outgoing email. 

     

    I don't know if that's what people above are referring to or if they're thinking that Mail actually filters outgoing messages but if the former, its probably some sort of bug between MailActOn and the new Mavericks.  I've been using the InDev tools for years and love them but do know they really struggle with last minute changes to Apple OS X code after major releases that impact their functionality.  I don't envy them, they've got to work with a lot of variables and rules is one of the most finicky things to work with (aside from security).

     

    I have been seeing partial rule execution on my Exchange mail but full execution on iCloud and Google messages so I'm thinking that its yet again, another nuance of dealing with Exchange at some level.

     

     

    Here's to hoping this gets resolved soon.

  • JimN Level 2 Level 2 (255 points)

    Pasta,

    for clarity, what sort of mail server are you working with?  i.e. Exchange, Google, iCloud, etc.?

     

    If Exchange, I think this might be something broken between Mail.app v7.0 and Exchange itself but not 100% certain. I too have partial functionality with Exchange messages being filtered with rules but then I find if I go to the main Inbox, "Select All" and manually apply Rules that they filter the remaining ones.  I haven't isolated the cause of this yet but do know that the nuances of working with Microsoft Exchange is very challenging for coders. 

     

    If you're having issues across the board with all servers, there may be some corruption with your rules and you may have to delete and recreate them.  Someone else much more familiar with the internal workings of rules may have a CLI script to clean them up but at the surface, recreating them might be the best avenue - albeit a painful one.

  • JimN Level 2 Level 2 (255 points)

    Brollissimo,

    What mail server are you working with?  Exchange?  iCloud?  Google?

     

    I'm seeing some partial filtering going on with rules with Exchange but all mail from iCloud and Google are working.  I haven't yet figured out which rules aren't working correctly but if you're working with an Exchange server, that might be part of the challenge.

     

    Helpful to understand what sort of platform you're connecting to before diagnosing it.

  • e.borri Level 1 Level 1 (10 points)

    I solved using an applescript and performing this script through the Rules as first rule.

    I'm still testing, but telling to "Apply Rules" executes my script and does his job.

     

    THe only bad thing is that the script mus be written indicating the rules in it!

    I mean, I do not apply the rules defined in Mail but I define my rules in the script.

     

    Anyway, it works… :-)

     

    Here is the script:

     

     

    tell application "Mail"

              set MessagesList to message of sent mailbox

              repeat with i from 1 to number of items in MessagesList

     

                        set Dest to (address of to recipient of (item i of MessagesList)) as string

     

                        if Dest does not contain "@mycompanydomain.com" then

      -- replace @mycompanydomain.com with your company's domain

     

                                  move item i of MessagesList to mailbox "From others"

      -- Indicate the proper destination mailbox

     

                        else

                                  if Dest contains "ABC@mycompanydomain.com" then

                                            move item i of MessagesList to mailbox "ABC"

                                  else

                                            if Dest contains "cde@mycompanydomain.com" then

                                                      move item i of MessagesList to mailbox "CDE"

                                            else

                                                      if Dest contains "xyz@mycompanydomain.com" then

                                                                move item i of MessagesList to mailbox "xyz"

     

      --//-- To add more rules, start copying here --//--

                                                      else

                                                                if Dest contains "@mycompanydomain.com" then

                                                                          move item i of MessagesList to mailbox "Someone els in my company"

      --//-- To add more rules, paste here --//--

                                                                end if

      --//-- To add more rules, end copying here --//--

     

                                                      end if

                                            end if

                                  end if

                        end if

              end repeat

     

    end tell

     

     

    I hope this help!!!

  • Max Cardale Level 1 Level 1 (5 points)

    Thank you for sharing that - it's an interesting workaround. Well done.

  • mountainbiker63 Level 1 Level 1 (5 points)

    "Apply Rules" is still a problem for me even after the yesterday's (7 Nov) Mail update for GMail.

  • caban Level 1 Level 1 (10 points)

    I removed my workaround...

    I did applied it a second time and erased everything...

     

    Some rules does it, some others no.

     

    I don't have a Gmail account linked to Mail.

     

    I applyed the Nov 7 fix, situation stiil the the same.

     

    BTW, I am talking of receive rules, I know the is no send rules.

  • caban Level 1 Level 1 (10 points)

    Thank you for the hint, but "MailTags" is not ready foor Mavericks.

  • John Smith50 Level 1 Level 1 (5 points)

    Mail fix of 7 november does not fix my Mail problems as described in this forum. Rules don't work. Can't click on name in contacts and email pops up with that name in address, Reader has no email link at bottom of page and other problems. Started exactly after Mavericks installed.

  • JimN Level 2 Level 2 (255 points)

    Well the update didn't do anything for me either.  Very disappointed because it also broke the InDev plugin "MailTags" which was updated for Mavericks but now the update to mail destroyed it and its what I use to manage my mail.

     

    I'm seriously thinking about going back to Eudora (tic)

  • pastafreak Level 1 Level 1 (15 points)

    I did a bunch of stuff to my MacBook Pro yesterday, ran disk utility, repaired permissions as well as checked the disk. I also reinstalled Mavericks and applied the Nov 7 update which in turn promted an update of SpamSieve. I also restarted my iCloud account to re-sync everything and Mail seems to be okay now. Note: Correction on my original post, I was only having issues with rules I had set up for incoming mail not outgoing mail. I do have one particular rule that I don't know if it's working since I am waiting to get an incoming email on that rule to make sure. Fingers crossed.

Previous 1 2 3 4 5 Next