Previous 1 2 3 Next 124 Replies Latest reply: Mar 28, 2014 2:57 AM by Csound1 Branched to a new discussion.
azamino Level 4 (1,620 points)

hello

 

does anyone have Mail working correctly with applying Mail Rules to Sent Messages?

 

i have Rules set up to put new Mail into various folders. This works as expected for incoming messages.

 

in previous OSX versions your Rules could be applied to Sent messages as well.

 

but in Mavericks it doesnt work (for me).

 

i have tried making new rules (not relying on previously set up rules), and still no go.

 

anyone?

 

thanks


MacBook Air (13-inch, Mid 2012), OS X Mountain Lion (10.8.2), iPhone 5, Time Capsule 1TB
  • John Smith50 Level 1 (5 points)

    Same here. Rules don't work. As well as other aspects of mail in mavericks.

  • ukstu Level 1 (0 points)

    I have this issue too, the Rules have stopped working since upgrading to Mavericks 10.9

     

    There is also an issue with Fulll Headers, if you switch Full headers on you can't then switch them back off unless you quit mail and restart it!

  • Gerry Shy Level 1 (0 points)

    I have the same problem with any message in any folder only excepting at the time they actually arrive. 

  • lclcv Level 1 (40 points)

    Same here. My Sent rules don't work in Mavericks. I have to move them manually. ARGH!

  • Yvesfb Level 1 (0 points)

    same for me.

    Since I installed Mavericks, rules do not work anymore when you add a new item in it (only old filters created before the upgrade seem working).

     

    Remark: before the upgrade, the rule system was not working in a consistent way (many normal emails were drawn to the undesirable folder). (and still the same after the upgrade)

  • smsghosh Level 1 (0 points)

    Same for me as well, none of the new mail rules works but old rules are working fine.

  • Jona Rotting Level 1 (0 points)

    Same problem. I do hear a swoosh sound from mail, but nothing happens! Apple, please help!

  • caban Level 1 (10 points)

    To me the rules are working, but they don't "move" messages.

    I replaced all the "moves" by "copy and delete", but this is a nasty workaround.

     

    Apple, please help!

  • pastafreak Level 1 (15 points)

    I am having the same issue. Apple Mail rules not working since Mavericks.

  • pastafreak Level 1 (15 points)

    Has anyone made any progress in solving this issue?

  • Joe Bailey Level 6 (12,210 points)

    Since Mail rules were first introduced in OS X 10.1 or so, I have never been able to get them to work for outgoing messages unless I automatically CCd or BCCd myself so that Mail saw them as both outgoing and incoming. At which point the rules worked on the incoming copy. Yes, I do end up with one copy of the message that has been processed under the rule and another in the Sent mail box. I just tested that once again and it still works in Mavericks but then I have not had any problems with Mail rules not functioning in Mail 7.0

  • Csound1 Level 8 (46,965 points)

    azamino wrote:

     

    hello

     

    does anyone have Mail working correctly with applying Mail Rules to Sent Messages?

     

    i have Rules set up to put new Mail into various folders. This works as expected for incoming messages.

     

    in previous OSX versions your Rules could be applied to Sent messages as well.

     

    Mail rules never worked on outgoing messages and nothing has changed in Mavericks.

  • pastafreak Level 1 (15 points)

    Okay if that is true how do I get an incoming mail rule to start working again after moving to Mavericks?

  • Csound1 Level 8 (46,965 points)

    Are you saying that in your installation of Mavericks rules do not work at all, not on incoming messages?

Previous 1 2 3 Next