6 Replies Latest reply: Nov 30, 2013 10:00 PM by mrcomanche
Temple123 Level 1 (0 points)

My iMac (late 2012) running OSX Mavericks is encountering problems creating a Windows 8.1 install disk via a USB thumbdrive. The drive has 8gb of space available, which is enough to fit windows. But when I choose my ISO image and select the drive I recieve an error message. The error is 'Bootcamp only supports 64-bit Windows installation on this platform. Please use a ISO file for 64-bit Windows installation.


I'm certain this ISO definately contains 64-bit, so I'm slightly confused.


I've followed instructions found in other discussions talking about adding an extra line of information to 'info.plist' found inside the Package Contents for bootcamp, but that has also not worked. If I try that, Bootcamp crashes upon being clicked every time.


Any help is appreciated

OS X Mavericks (10.9)
  • Jognt Level 1 (30 points)

    First up: a question. How did you fix the crashing Bootcamp Utility? It would help out this guy: https://discussions.apple.com/message/23523783?ac_cid=tw123456#23523783


    Next up: A possible solution (also posted here:https://discussions.apple.com/message/23523783?ac_cid=tw123456#23523783)



    It's possible you have a Windows ISO for both 32- and 64-bit. In this case it's probably detecting the presence of the 32-bit installer and forgets to look for another 64-bit version.


    A way to work around this is to not use the Bootcamp Assistant utility by following the listed steps:

    The way installing Windows should work either way using the Legacy BIOS mode:


    - Get a Windows ISO or DVD and copy the contents over to a freshly fat32 formatted USB stick of at least 4GB.

    - Download the Apple Bootcamp Support Software (4.x or 5.x, 5.x only supports 64-bit, get that if you are going 64-bit);

    - Copy the content of the Support Software folder over the the same USB stick from the first step. It should fit just right (it did on my 4GB stick with 2MB te spare!);

    - Use disk utility to partition your disk. Make sure the partition for Windows is Fat32 and at least 30GB;

    - Reboot your machine while holding Option/Alt at the chime;

    - You should be able to select either your OSX HDD or your USB stick labeled "Windows" -> Select Windows and press enter or click the arrow;

    - The Windows installer should now load, format the previously made Windows partition to NTFS;

    - Continue on your way.


    Can you try what I typed above? If it doesn't work, can you let me know at what step things go differently than described?


    Edit: This is based on the logical conclusion that any Mac that was shipped without ODD should be able to boot from USB.



    One other note is that Mac's have trouble booting from USB when multiple USB storage devices are attached. So make sure you connect only one storage device.




    Best of luck to you!

  • PenganLEANG Level 1 (0 points)

    Thank you for your fast reply and helping. However I don't have that Mac with me now so I will tell you if it works or not.

  • Temple123 Level 1 (0 points)

    Okay Jognt, I tried this. I put a windows 8 .iso + the bootcamp 5 drivers onto my 16gb USB. I put the ENTIRE bootcamp file download found on the apple website. I did this because from a previous thread we spoke on, my bootcamp assistant no-longer opens. I then proceeded to partition my drive using disk utility. I set my size to 150gb and waited for that to go through.


    I then restarted my PC, help Option at the chime and selected 'Windows' (my USB). I was greeted by a nice black screen reading 'no bootable OS found' or something along these lines.


    Sorry for the late reply, but if you're still here, I'd appreciate any further input very much!

  • Jognt Level 1 (30 points)

    Hi there Temple. Don't worry, when I try to help people I subscribe to those threads so I get an email when you reply .


    Just to verify: You say you copied the ISO over to the USB drive. You need to copy the contents of the ISO over, not the ISO itself.


    Let me know if that fixes it, otherwise I'll need to think a bit harder since I don't have Windows 8 myself.


    I can tell you that I installed Windows 7 via USB about 8 times today (testing an Unattended installation config to install Windows in UEFI mode to solve the problem of not getting an image on HD4000 GPU's). All these installs went fine. I installed via DVD (2x), USB(5x), and via copying the content of the USB over to a partition on my HDD (1x).

  • Jognt Level 1 (30 points)

    Just a heads-up:

    After getting curious why so many people can't boot the Windows Installer, I started troubleshooting.

    I deleted files from my USB one by one and checked every time if it was recognized as an installer.


    Apparently my mac still recognized it as a Windows boot device when it was empty. It kept recognizing it is bootable after formatting it (still empty).


    I decided to delete the partition on the USB drive -> No longer detected.

    I re-copied the windows ISO content to the drive so it was the same as before -> Still not detected.


    It seems there is something to this that I am missing, and I'll be troubleshooting some more for now.


    If my above advice works for you, let me know, if it doesn't let me know too please. Also let me know if it still recognises the USB drive as a boot-device.


    Also, don't copy the Bootcamp Support Software 5.x folder to the USB drive, copy the content.


    Your USB drive root should have at least the following folders:

    - $winpedriver$

    - bootcamp

    - sources

    - setup.exe

    - autounattend.xml

  • mrcomanche Level 1 (0 points)

    Hi man,


    I think the walkthrough of yours is brilliant, should work for many. Thanks for all the efforts.

    I'm still having some issues which are the following:


    1. Install windows option (the 3rd option) in bootcamp assistant is disabled. In other words I could create the install media, but cannot start installation that initialized from BootCamp assistant.

    I could live with that because it's easy to boot up from another USB media, as you said earlier.


    2. This is a bit more frustrating. I boot up from the installation media that I created with Bootcamp assistant, windows installer loads in, but there are no input devices - such as mouse and keyboard. Even if I attach a wired USB keyboard and mouse, windows installer cannot see it. I guess because it is USB3.0.


    In my opinion I could install my bloody windows easily if any of the issues above would be resolved.


    Any thoughts?