Previous 1 2 3 4 5 Next 100 Replies Latest reply: Oct 27, 2014 7:53 AM by drhundertwasser Go to original post
  • cetsk Level 1 (5 points)

    I was just testing to ensure that it was a user issue. I know well enough to not change anything. I can take care of myself. Thank you for your concern, though.


    I was able to get it working. Seems some config database for network was corrupted, inaccessible, or something else. Here is what I did:


    cd /Library/Preferences/SystemConfiguration

    sudo mv NetworkInterfaces.plist NetworkInterfaces.plist.bak

    sudo mv preferences.plist preferences.plist.bak


    I rebooted, and everything is back to working again.


    But Drew is right. Don't go mucking around in system stuff unless you are prepared to fix what you break!

  • Drew Reece Level 5 (6,343 points)


    That's great if it's resolved, just post a report if it goes flaky (etrecheck will help you see the general health so take a look at a report anyway).


    Mavericks seems not to like old software that runs at the system level.

  • macmark2 Level 1 (130 points)

    Was very excited to try something that worked for someone else...but, alas, it did not work for me.  Same lousy issue...

  • Drew Reece Level 5 (6,343 points)

    How clean is your system now macmark2?

    I know you went through & removed some items but it's not clear if it still could be third party software interfering.


    It seems like you isolated to the user account, is that the case macmark2?


    I'm trying to keep up, but everytime I have a suggestion it seems you have tried it a few posts back - good job :^)


    Some random ideas - boot to recovery & reset user permissions (you need to type 'resetpassword' into Terminal to open the GUI tool).


    Reinstall 10.9 over the top of this system to address any installer issues (it's counter-intuitive, but other 'bizarre errors' have had positive results via this method).


    Sorry nothing concrete, do you want us to look at another report?

  • Bob Bedick Level 1 (0 points)

    Same issue here. I can't open any kind of submenu or anything with an external window prompt in system preferences, I get the issue with being unable to close an unsaved textedit window (likely because it won't show the 'Do you want to save?' window), and I show the same 'shadows' on my Mail menu bar (which I originally didn't notice because my toolbar was set to show Icons only). Console shows me the same 'unable to convert NSNamedColorSpace System controlColor to Device RGB colorspace' errors every time I try to open something in System Preferences.


    I ran etrecheck and there seems to be very little overlap. cetsk's solution didn't work for me either, nor did any of the other suggestions from earlier in the post.


    Hardware Information:

        MacBook Pro (17-inch, Early 2009)

        MacBook Pro - model: MacBookPro5,2

        1 2.66 GHz Intel Core 2 Duo CPU: 2 cores

        4 GB RAM


    Video Information:

        NVIDIA GeForce 9400M - VRAM: 256 MB

        NVIDIA GeForce 9600M GT - VRAM: 512 MB


    Audio Plug-ins:

        BluetoothAudioPlugIn: Version: 1.0

        AirPlay: Version: 1.9

        AppleAVBAudio: Version: 2.0.0

        iSightAudio: Version: 7.7.3


    System Software:

        OS X 10.9 (13A603) - Uptime: 0 days 0:5:16


    Disk Information:

        ST750LX003-1AC154 disk0 : (750.16 GB)

            EFI (disk0s1) <not mounted>: 209.7 MB

            Macintosh HD (disk0s2) /: 749.3 GB (507.81 GB free)

            Recovery HD (disk0s3) <not mounted>: 650 MB


        MATSHITADVD-R   UJ-868 


    USB Information:


        Apple Inc. Built-in iSight


        Apple Inc. BRCM2046 Hub

            Apple Inc. Bluetooth USB Host Controller


        Apple, Inc. Apple Internal Keyboard / Trackpad


        Apple Computer, Inc. IR Receiver


    FireWire Information:


    Thunderbolt Information:


    Kernel Extensions:

        at.obdev.nke.LittleSnitch    (4050)


    Problem System Launch Daemons:


    Problem System Launch Agents:


    Launch Daemons:

        [loaded]    at.obdev.littlesnitchd.plist

        [loaded]    com.adobe.fpsaud.plist

        [not loaded]    hdapm.plist

        [not loaded]    hdapm.plist~

        [loaded]    org.gpgtools.gpgmail.patch-uuid.plist


    Launch Agents:

        [loaded]    at.obdev.LittleSnitchUIAgent.plist

        [loaded]    org.gpgtools.gpgmail.enable-bundles.plist

        [loaded]    org.gpgtools.gpgmail.patch-uuid-user.plist

        [loaded]    org.gpgtools.Libmacgpg.xpc.plist

        [loaded]    org.gpgtools.macgpg2.fix.plist

        [loaded]    org.gpgtools.macgpg2.shutdown-gpg-agent.plist

        [loaded]    org.gpgtools.macgpg2.updater.plist


    User Launch Agents:


        [loaded]    com.valvesoftware.steamclean.plist


    User Login Items:






    3rd Party Preference Panes:

        Flash Player

        Flip4Mac WMV



    Internet Plug-ins:


        Flash Player.plugin


        Flip4Mac WMV Plugin.plugin

        QuickTime Plugin.plugin


    User Internet Plug-ins:


    Bad Fonts:



    Time Machine:

        Time Machine not configured!


    Top Processes by CPU:

            24%    firefox

            14%    WindowServer

             2%    hidd

             1%    EtreCheck

             0%    fontd

             0%    Little Snitch Agent

             0%    SkyDrive

             0%    Little Snitch Network Monitor

             0%    mds

             0%    Flux


    Top Processes by Memory:

        403 MB       firefox

        131 MB       mds_stores

        119 MB

        61 MB        Finder

        47 MB        WindowServer

        41 MB        Dock

        25 MB        SystemUIServer

        25 MB        mds

        20 MB        gamed

        20 MB        SkyDrive


    Virtual Memory Statistics:

        1.69 GB      Free RAM

        1.24 GB      Active RAM

        416 MB       Inactive RAM

        426 MB       Wired RAM

        242 MB       Page-ins

        0 B          Page-outs


    I can post the whole Console messages if it would be any help.

  • foulgernz Level 1 (0 points)

    Same Problem For me. User specific, Mac Pro Early 2008 10.9.  Login as other user - veverything fine.  Login as "me" problem is there, either in safe mode or normal mode.  Any fixes to  Thanks

  • Drew Reece Level 5 (6,343 points)

    Little Snitch is running as a kernel extension, is that up to date? Have you isolated the issue to your user account? Create a new user & see if that exhibits the same behavior.


    I would remove all the user login items from 'System Preferences > Users & groups' to see if that makes any difference.


    I don't think it's related, but you have a Flash player from 10.6 inside /Library/Internet Plug-Ins/


    Also make sure gpgtools are up to date.

  • Bob Bedick Level 1 (0 points)

    Little Snitch is up to date, and this issue is only on my account; my guest account does not experience the problem.


    I have tried booting with no login items, however that did not help. Actually, a problem I experienced from doing that was that I was unable to add back the login items from the system preferences menu, but fortunately I could add them back from each program's options.


    I too found the Flash Player 10.6 item odd, but I only have one Flash Player.plugin in my Internet Plug-Ins folder. I used Adobe's uninstaller, which deleted that file, and afterwards when I ran etrecheck again, both Flash Player entries were gone. Upon reinstalling the latest edition of Flash, however, both entries had returned in etrecheck. I also don't think it's a related issue, as the ColorSpace errors persisted while Flash was uninstalled, but since you mentioned it I figured I would too.

  • luke_aus Level 1 (10 points)

    There are now 3 other threads which have now pointed to this one



    I think there is a larger issue going on here that is affecting secondary windows in System Preferences and "Save As" dialogues in multiple programs.



    System Prefs> Security & Privacy> Advanced button not responding in any of the frames ( lock is unlocked / I'm administrator)


    System Prefs> Security & Privacy> general allow apps downloaded from: wont let me choose Anywhere


    System Prefs> Time machine> options button not responding


    System Prefs> Network > Advanced button not responding


    Text edit won't let you save or save as from the menu or with key combo shortcut

    Can't close the last Text Edit window unless you have saved the document (i.e. the X in the corner of the window does nothing) - but quite (command-q) still works.

    And "Save As" dialogues from Pixelmator, Apperture and iPhoto don't appear to be working for different people.


    The errors are:


    7/11/2013 8:12:13.583 am System Preferences[390]: *** Assertion failure in -[NSSecureColor initWithColor:], /SourceCache/ViewBridge/ViewBridge-46/NSSecureColor.m:32


    and 2.

    7/11/2013 8:12:13.584 am System Preferences[390]: -[NSRemoteView viewDidMoveToWindow] caught non-fatal NSInternalInconsistencyException 'unable to convert NSNamedColorSpace System controlColor to Device RGB colorspace' with backtrace (

              0   CoreFoundation                      0x00007fff86a2d41c __exceptionPreprocess + 172

              1   libobjc.A.dylib                     0x00007fff9300ce75 objc_exception_throw + 43

              2   CoreFoundation                      0x00007fff86a2d1f8 +[NSException raise:format:arguments:] + 104

              3   Foundation                          0x00007fff935b2c61 -[NSAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 189

              4   ViewBridge                          0x00007fff86be965c -[NSSecureColor initWithColor:] + 724

              5   ViewBridge                          0x00007fff86be936f +[NSSecureColor secureColorWithColor:] + 48

              6   ViewBridge                          0x00007fff86c0ccfb -[NSRemoteView sendFontSmoothingBackgroundColorToService:] + 40

              7   ViewBridge                          0x00007fff86c0dbf5 -[NSRemoteView viewDidMoveToWindow] + 197

              8   AppKit                              0x00007fff8e5601d0 -[NSView _setWindow:] + 2899

              9   AppKit                              0x00007fff8e55d804 -[NSView addSubview:] + 364

              10  AppKit                              0x00007fff8e571953 -[NSFrameView addSubview:] + 45

              11  AppKit                              0x00007fff8e57fcb5 -[NSWindow setContentView:] + 511

              12  ViewBridge                          0x00007fff86c13868 rendezvousPanel + 895

              13  ViewBridge                          0x00007fff86c12f3f -[NSRemoteView beginSheet:modalForWindow:size:isCritical:styleMask:] + 420

              14  ViewBridge                          0x00007fff86c13eea -[NSRemoteView beginDeferredSheet:] + 209

              15  ViewBridge                          0x00007fff86c14098 -[NSRemoteView beginDeferredSheets] + 283

              16  ViewBridge                          0x00007fff86c18ca2 __85-[NSRemoteViewMarshal beginSheet:modalForWindow:size:isCritical:styleMask:withReply:]_block_invoke + 83

              17  ViewBridge                          0x00007fff86c1c892 __deferBlockOntoMainThread_block_invoke_3 + 441

              18  CoreFoundation                      0x00007fff8695e7cc __CFRUNLOOP_IS_CALLING_OUT_TO_A_BLOCK__ + 12

              19  CoreFoundation                      0x00007fff8694fee5 __CFRunLoopDoBlocks + 341

              20  CoreFoundation                      0x00007fff8694fc6e __CFRunLoopRun + 1982

              21  CoreFoundation                      0x00007fff8694f275 CFRunLoopRunSpecific + 309

              22  HIToolbox                           0x00007fff93221f0d RunCurrentEventLoopInMode + 226

              23  HIToolbox                           0x00007fff93221cb7 ReceiveNextEventCommon + 479

              24  HIToolbox                           0x00007fff93221abc _BlockUntilNextEventMatchingListInModeWithFilter + 65

              25  AppKit                              0x00007fff8e54928e _DPSNextEvent + 1434

              26  AppKit                              0x00007fff8e5488db -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 122

              27  AppKit                              0x00007fff8e53c9cc -[NSApplication run] + 553

              28  AppKit                              0x00007fff8e527803 NSApplicationMain + 940

              29  libdyld.dylib                       0x00007fff8e5245fd start + 1

              30  ???                                 0x0000000000000001 0x0 + 1


    timestamp: 08:12:13.584 Thursday 07 November 2013

    process/thread/queue: System Preferences (390) / 0x7fff776b3310 /

    code: line 607 of /SourceCache/ViewBridge/ViewBridge-46/ViewBridgeUtilities.m in logCaughtException

    domain: exceptions



    So far I have tried:

    1.  I Repair Disk in Recovery mode but there were no issues so it had nothing to repair

    I ran "repair disk permissions" but that has made no difference


    2. I just reinstalled OSX Mavericks from within OSX Mavericks but that hasn't helped either


    3.. Boot into your recovery partition (restart, hold down ⌘R until you see the Apple logo), and use Disk Utility to repair your hard drive. Repair permissions too while you're there.OS X: About OS X Recovery

    as suggested by Arthur - but no help


    4. Cetsk also suggested running:

    cd /Library/Preferences/SystemConfiguration

    sudo mv NetworkInterfaces.plist NetworkInterfaces.plist.bak

    sudo mv preferences.plist preferences.plist.bak


    and then restarting - this also didn't help with any of the issues


    5. removing the following didn't help


    /Preferences/ preferences .plist



    /Preferences/By Host/ of them)



    6. I can't create a new user because the secondary menu simply won't come up in the "Users & Groups" system preferenes when I unlock then try to click on the "+" nothing happens


    Anyone got any other ideas?

  • luke_aus Level 1 (10 points)

    I just tried the guest account and there are no issues with a guest account


    the work around is to go to the guest account then create a new administrator account (use your old admin account login details to permit this when prompted)

  • Drew Reece Level 5 (6,343 points)

    Sorry this may not be relevant, since you just posted the "use guest account workaround", posting anyway…


    Should we take a look to see where "ViewBridge" lives on your system, it could indicate if it is part of the OS or a third party tool.


    To search the system you must use Terminal (Spotlight doesn't look into hidden or system owned files)


    The Terminal command would be…


    sudo find / -iname 'ViewBridge'


    (In summary: as root, search on / for case insensitive name 'ViewBridge')

    Use 'man find' for the manual.


    Obviously it is never a good idea to run random sudo commands from random people on the internet, hopefully you have a geek to run it by (or a backup).


    Here is what my 10.9 shows…


    It looks like it is part of the OS, I also have Xcode installed.

  • Drew Reece Level 5 (6,343 points)

    You could try the old fashioned 50/50 troubleshooting method, assuming you have really good backups & some time on your hands!


    Delete 1/2 of your home folder & see if it resolves anything, if yes you have 50% fewer items to test, restore 1/4 of them, rinse & repeat, otherwise remove 1/2 of the remaining 1/2.


    It is a brutal 'sledgehammer to crack a nut', but sometimes you just find a really tough nut!


    Obviously time may be best spent focusing on the ~/Library, but it isn't always the source of the issue.

    Rip out the ~/Library/Caches & other items from the bad account via the new admin account to prevent the OS locking files from deletion when the user is active (using sudo in the Terminal) - ask if you need help.


    Feel free to post an EtreCheck report if you want a second opinion on the system…


    PS I would compare the output of the 'id' command when run as each admin user.

    Hopefully they have similar entries in the 'staff' group.


    NB: Supply the username to see both entries without logging in twice e.g.


    id admin

    id bad_user


    Added note about id command

  • luke_aus Level 1 (10 points)

    Hi Drew

    thanks for yor response

    I tried deleting a bunch of config files that had anything to do with colour/monitor/screensaver etc. - but that didn't help (note that I did this from within my own admin account so OSX Mavericks may just have restored the backup files


    I am up and running on my new admin account without too much work so it's not too bad


    Good idea on the sledge hammer apporach - but I might have to leave that to others

  • Drew Reece Level 5 (6,343 points)

    I read somewhere that the preferences are stored in memory in 10.9 (& maybe earlier) so deleting whilst logged in doesn't always work, I just can't find where I read that!


    Did you check the group id's?

  • dianeoforegon Level 5 (4,685 points)

    Since a new User and/or using Guest User has fixed the problem for several posters, I suggest you create a new User in System Preferences  and move to the new User. This could be quicker than trying to track down the problem and it gives you a clean start.


    You can drag your files to the Shared folder for access in the new User.

    After logging into the new User, drag from Shared (it actually copies) and place it in the Local folders. (make sure you have enough free disk space since this will double the data during the process.)


    I would not bring over much from the ~/Library.


    For example, if you drag Documents folder to Shared, when you log into the new User do NOT drag the folder but the contents to the new Documents folder.


    I would be very careful about adding browser plugins and verify that each third party app is up to date.

Previous 1 2 3 4 5 Next