13 Replies Latest reply: Oct 10, 2015 10:39 AM by imero1
jakecool84 Level 1 Level 1 (0 points)

Every time I try to restore or update my iPhone 5s in iTunes (using my Windows Vista) I get the message "The iPhone/iPod cannot be updated. An unknown error occured (17)", and my iPhone is stuck in recovery mode. (I have a program to "kick" it out of recovery mode so I can still use it without needing a restore.) I'm not sure what is causing the problem, but it's really anoying and I would like to get it fixed ASAP. I have already tried restarting my computer, uninstalling and reinstalling iTunes, disabaling my firewall, and uninstalling my antivirus, but nothing has worked. I am positive that the problem is not being caused by the iPhone because I have tried to restore / update my old iPod 4g, resulting in the same error code... One more thing, I was getting "error 3004" earlier, but that turned into "error 17" whenever I disabled / uninstalled my antivirus (McAfee from Bell)... Any ideas on how to fix this? Thanks.

iPhone 5s, iOS 7.0.2