Previous 1 2 3 Next 75 Replies Latest reply: Nov 13, 2014 4:06 PM by PeterBreis0807
Wolf.NBM Level 1 (0 points)

I had to apply a hack to get SMB (to Windows Server 2008R2) to even work in Mavericks, but now I have encountered a new problem:


Any file I open in Pages or any other iWork app from an SMB share becomes unsavable, as soon as anything is changed in it.


It starts with an Autosave error: "The document could not be autosaved. You don't have permission to write to the folder that the file is in."


From there, I can't even duplicate it, export it, or anything. Everything I do gives me a "The location of the document xxxx cannot be determined."


Even if I try to do a "Save as", I get the same "You don't have permission to write..." error (even to my own desktop!).


If I try to "Duplicate" the file- I lose all embedded elements (images) and most of my formatting.


I don't recall having this problem before, but I just started testing the iWork applications again since upgrading to Mavericks. I have been looking for an alternative to Microsoft Office for my company's staff, but this really makes iWork "not ready for prime time" in a business environment. I hope this has something to do with the SMB2 issue, and it will be resolved soon, but I am open to any suggestions to try to fix the problem.

iWork, OS X Mavericks (10.9), MacBook Pro Retina
  • RBuday Level 1 (5 points)

    I have the same problem. I'm using Tuxera on Mavericks to read/write files on an NTFS server. iWork 09 worked fine on Mountain Lion and Tuxera, and continues to work fine on Mavericks. Other applications have no problem with Mavericks and Tuxera (TextEdit, MS Office, Photoshop, etc). The problems seems only with iWork 2013 and SMB shares.

  • Segalla Level 1 (0 points)

    Same problem here with a linux samba server.


    If I make a copy of the file (don't rename it after copying), open with Pages 13 (Pages and Keynotes too) then I can save it but if rename the copy then a i get the same error I got with the original file.

  • dsacgt Level 1 (0 points)

    Same problem here with new iWork under Mavericks using windows SMB drives. I can't save any of my work to the network!


    I've submitted the bug to Apple via feedback.

  • Wolf.NBM Level 1 (0 points)

    At least I know I'm not crazy and others are having similar issues. There are lots of other reports of the problem on other forums as-well. I did report it in Feedback as a bug, but at least here you can usually-eventually get some kind of an answer from someone at Apple.


    The only "solution" I have found online is to use CIFS, which still doesn't work on Windows networks. It may work on some NAS devices that support it, but it is not an option for anyone running SMB1. Some have also said it is an actual permissions issue. I have "full" read/write access to the volumes I am accessing (I'm also the sysadmin), and I even changed one to allow for "everyone" access- no dice.

  • dwb Level 7 (22,625 points)

    In Pages 4 you could choose to save as package or a flat file. What is your default (look in Pages' Preferences). At work when we switched to Windows server I had to switch iWork so it didn't save as a package. Since Pages 5 doesn't have that option and only saves a package I'll bet that's why you are having the problem. I see it on some other (but not all) Mac applications that save files as packages.

  • Wolf.NBM Level 1 (0 points)

    iWork does seem to be saving everyting ot packages now, but that seems irrelevant, since the network volumes still have permissions for it to do whatever it wants. And, as you said- there is no option to turn that off anymore.

  • dwb Level 7 (22,625 points)

    True it shouldn't be a problem but like you I have full admin rights to the servers at work and I've seen the same problems with other programs that save as packages - an early release of Art Text for example. There is something special about a package or how a program updates a package once it has been saved that must cause the problem. Belight did eventually release an update that resolved the problem so we can hope Apple will too.

  • Segalla Level 1 (0 points)

    I set Pages 09 to save new documents as a package and it worked as it should in our smb linux server (mac os thinks it is a windows server).


    Any iwork 13 app can't save on the same shared driver except when we make a copy of the original file and use it without renaming it, if we rename it we get the same permission error we got with the original file.

  • _cpo_ Level 1 (0 points)

    same problem for me in mavericks and iwork 13. f.e. pages yells at me it cannot save files even I created them.


    I think I already know where the problem is: access rights are being changed when saving a document. It definately screws up the ACLs and then complains it cannot save, because the ACL which gives the user write access is removed (even so the parent folder has ACLs which should be inherited by all new files automatically - and do, but not when pages saves a document). Some ACLs are inherited, but not those giving the user write acces.


    Why the **** is pages touching the acls???

  • natecw16 Level 1 (5 points)

    I also have this issue, and am also experiencing similar save-to-SMB problems from Preview.

  • Wolf.NBM Level 1 (0 points)

    There is more information and a partial work-around for general SMB issues here:


    Unfortunately, this does not fix the problems with iWork and other apps trying to use SMB network shares at-all. In my own experience using Mavericks for a week- I am constantly having SMB issues I didn't have before Mavericks, including losing connections to shares at-random and having to reboot to get them back. This is almost like the "dark ages" when Apple dropped SAMBA.


    iWork is still completely unusable on an SMB network, and no fixes have been even hinted-at. I just finished pitching iWork as a replacement of MS-Office at my company, and this happened.(!)

  • WLWEsq Level 1 (45 points)

    Yep, same problem here—even though I can save to my Desktop and then copy the file to the proper place on the server, it's hardly an efficient workaround.


    Maybe it's just me, but the "upgrade" seems to be oxymoronic in this case. Disappointing.

  • _cpo_ Level 1 (0 points)

    just noticing that weird new folders are created when saving a pages document (on share simply having rwx rights for everyone). the folders have the name "[8 random lowercase chars]-[6 random chars]". maybe some temporary files it fails to clean up - might be related to this issue ...


    what a mess.

  • Wolf.NBM Level 1 (0 points)

    Just to add to this- we allowed some other users at my company to "upgrade" to Mavericks. Even with the SMB1 trick that has been posted- they are reporting issues with other software beyond iWork having the same problems, including MS-Office and Adobe products. There is a permissions issue that seems to be a throw-back to earlier versions of OS X.


    iWork just takes it to an extreme because of its versioned auto-save system that gets stuck in an unrecoverable loop thanks to this SMB problem.

Previous 1 2 3 Next