4 Replies Latest reply: Feb 10, 2014 1:52 PM by Federico Ava
rjeffords Level 1 Level 1

3.2GHz Intel Core i5 27" iMac (only upgrade being a 1TB fusion drive)


When I first received the computer I plugged it into my old USB 2.0 hub with all of my other peripherals plugged into that.  Initially it worked but after a few minutes, everything became unresponsive (including my bluetooth mouse and USB keyboard which was plugged into the hub).  I began to troubleshoot and ultimately determined the old hub was the culprit.  My logic concluded that maybe the old hub just wasn't compatible with USB 3.0 on the new iMac (because it certainly worked with my previous Macbook Pro.


So I ordered the highest rated USB 3.0 hub I could find: http://amzn.com/B00AYQ433U


...apparently same problem.


So what's the deal?  Why is it that when I plug any sort of hub into my iMac, the entire system freezes and goes unresponsive after a few minutes?  This just doesn't seem right. 


Side note:  I have a Griffin iMic that I use for my headset that I've also experienced considerable connection issues with.  This worked for 4 years straight on my old MBP.  What is up with my USB ports?