4 Replies Latest reply: Oct 26, 2013 10:07 PM by mende1
zamedic Level 1 (0 points)

I've just upgraded to Mavericks on my Macbook Pro and after completing the installation iTunes 11.1.2 will not open any more. When I try to open iTunes the software name shows in the upper right corner as normal, but a blank box with an "ok" button pops up (See attached screenshot)Screen Shot 2013-10-26 at 5.43.14 PM.jpg. When ok is clicked it shuts down anything iTunes related. This happens even if you click on a song to play. If you click on the song description window play icon the song plays, but still no iTunes.

 

I've tried deleting iTunes, but but get another popup stating iTunes is a OSX requirement. I'm now in the process of downloading iTunes to see if it'll install and possibly "repair" and will update if that solves the problem.

 

Any guidance will be greatly appreciated.


MacBook Pro, Mac OS X (10.7.3)
  • mende1 Level 10 (92,231 points)

    The iTunes reinstallation should fix the issue.

     

    Have you tried to open iTunes while holding down the Option (Alt) key? iTunes should ask you for the library, so check if you can create a new one or select an iTunes library

  • saffron63 Level 1 (15 points)

    I had this, in my case clicking any iTunes icons produced no response at all. I downloaded the DMG file from iTunes website and installed it, now it works perfectly.

     

    Also worth doing a permissions repair IMHO.

  • zamedic Level 1 (0 points)

    The option key... I've been holding down the command key... No wonder that didn't work. I should really be writing this stuff down!.

     

    Regardless, Downloading and reinstalling iTunes did the trick.

     

    Thank you mende1 & saffron63 for the assist!

  • mende1 Level 10 (92,231 points)

    You are welcome