Previous 1 2 Next 21 Replies Latest reply: Mar 6, 2014 9:25 AM by Hutchers900
miasm Level 1 Level 1

Can not print with HP LaserJet 6L since the upgrade to Mavericks. Any alternative driver for this printer?

Solved by Eric Root on Oct 26, 2013 11:05 AM Solved
Try looking here. It lists your printer. Gimp - Print
  • Ham Level 2 Level 2

    This printer is more than 10 years old!

     

    But good news, OSX has a built-in generic PCL driver that will work with your printer.  Add the printer in system prefs.  Manually select the generic PCL driver.

  • miasm Level 1 Level 1

    Of course, this is a very old printer, but it´s the best one I´ve ever had. Thanks for your reply, but that does not work. I tried it a few times.

  • Eric Root Level 9 Level 9
    expertise.macosx
    Mac OS X

    Try looking here. It lists your printer.

     

    Gimp - Print

  • Ham Level 2 Level 2

    How is the printer attached?  It comes standard with a parallel port.  So you have some kind of adapter?  Also what version of the OSX did it last work?  Finally, in system pref, when you add this printer, how are you doing it?  By IP address, or it is USB?

  • Lenticule Level 1 Level 1

    I also cannot print to my LaserJet 5L since upgrading to Mavericks.  In Mountain Lion, it worked fine by using the HP LaserJet Series PCL 4/5 driver that ships with OSX.  I'm printing through a generic USB adapter via the printer's parallel port.

     

    A software update installed the Apple 2.16.1 HP drivers (http://support.apple.com/kb/dl907) but that didn't change anything.

  • nanabuuui Level 1 Level 1

    I'm having the same problem with my HP Deskjet F4180 :/ Any solutions yet?

  • nanabuuui Level 1 Level 1

    hey, thanks! this totally helped! my printer works now!

  • Marble Joe Level 1 Level 1

    I have an HP LaserJet 5P and had the same problem. My LaserJet is connected to a D-Link ethernet print server, then to an Airport Express to support wireless printing.

     

    As recommended in earlier posts, I first downloaded the Gutenprint HP drivers at Sourceforge, version 5.2.9 That did not work. Then found the reference to the Apple kb here: http://support.apple.com/kb/dl907

     

    Downloaded these drivers. When setting up the printer, I got the autoselect option for Generic Postscript Printer and used that. Printer worked, but printed out garbage. I then deleted the printer, and this time selected the HP LaserJet 5P CUPS + Gutenprint v.5.2.9 THAT WORKED! I don't know if was the combination of downloading the drivers from Sourceforge and the Apple kb, or just the Apple kb that solved the problem, but I'm glad this is now sorted.

     

    I was a bit surprised when I hit this snag to begin with because the last upgrade I did from Lion to Mountain Lion, I did not have this issue. It was seamless.

  • miasm Level 1 Level 1

    Thanks al lot to all of you. It works. Now I´m using Gutenprint and I can print. Last details, I´m using my (old) printer with an adapter for USB (not as a network-printer). The last version was "mountain lion" and with 10.8 I had no problems with the driver. I´m really happy that I can print again and that I not have to buy a new printer. Thank you so much.

  • Randy R. Level 1 Level 1

    I also cannot print to my LaserJet 1200 since upgrading to Mavericks.  In Mountain Lion, it worked perfectly by using the HP LaserJet Series PCL 4/5 driver that is included in OSX.

    Apple support has continually denied the issue for the last 6 days.

  • generic73 Level 1 Level 1

    Same issue here.    Latest HP software has been installed via Apple's software update, we also installed the Gutenprint 5.2.9 (latest) DMG, with no success.   Still not able to print with a HP Laserjet 5P and OSX 10.9.   Please fix this!

  • miasm Level 1 Level 1

    After installing Gutenprint it works. May you can try it too? Have a look at the answer in this threat of Eric Root, there you can find a link, called Gimp-Print. I deleated the printer, then I installed Gutenprint and after installing the printer again it works.

  • generic73 Level 1 Level 1

    Yeah, I wasn't explicit in my first post but we did already try removing the printer and adding it back after installing Gutenprint, and using the  "HP LaserJet 5P CUPS + Gutenprint v.5.2.9 " option  that MarbleJoe mentioned above.    

     

    Still no luck.    

  • Lenticule Level 1 Level 1

    My LaserJet 5L is still not printing.  I've tried Gutenprint/Gimp-Print with a driver specific to my exact printer and also the Apple generic HP LaserJet Series PCL 4/5 driver, nothing works.  Everything spits out ASCII garbage characters.

Previous 1 2 Next